Installation von Modulen bricht mit 500 Error ab

Hier kannst du dich vorstellen und Fragen zum Plugin stellen.
Installation, Administration, etc.

Moderatoren: maennchen1.de, Joe, MKJ

matthias87
Beiträge: 11
Registriert: 19.04.2017, 17:58
Lizenz: wpShopGermany Enterprise

Installation von Modulen bricht mit 500 Error ab

Beitragvon matthias87 » 19.04.2017, 18:11

Hallo,
ich wollte in der Modulverwaltung ein paar Module installieren, allerdings bekomme ich nach Klick auf "installieren" eine 500er Fehlermeldung (bei allen Modulen). Ich kann bei diesem Webspace leider keine Serverlogs einsehen, daher wollte ich mal fragen, ob dies ein bekanntes Problem ist und wie ich damit umzugehen habe. Caching ist keines aktiv, das dazwischenfunken könnte. Alles andere scheint problemlos zu funktionieren, nur hier hakt es.

Vielen Dank!

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2054
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Installation von Modulen bricht mit 500 Error ab

Beitragvon ThoGoe » 20.04.2017, 07:31

Hallo!

Mit welcher wpShopGermany-Versionsnummer hast du das Problem? Welche WordPress-Versionsnummer ist bei dir installiert?
Bitte deaktiviere einmal alle anderen Plugins und stelle auf ein Standardtheme um. Danach probiere das Ganze noch einmal.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

matthias87
Beiträge: 11
Registriert: 19.04.2017, 17:58
Lizenz: wpShopGermany Enterprise

Re: Installation von Modulen bricht mit 500 Error ab

Beitragvon matthias87 » 20.04.2017, 18:53

Hallo,

ich habe jeweils die aktuellsten Versionen drauf:
- WPSG: 3.12.4
- WP: 4.7.3

Ich habe auch testweise alle anderen Plugin deaktiviert, das brachte keine Besserung. Zwischenzeitlich habe ich mir aber Zugang zu den Logs verschafft, das Problem ist folgendes:

PHP Fatal error: Call to a member function find_folder() on null in /var/www/xxxx/html/cms/wp-content/plugins/wpshopgermany/mods/wpsg_mod_core.class.php on line 2

Ich habe hier im Forum geschaut, da gab es das Problem mal bei geänderten Pfaden, allerdings liegt in unserem Fall der Ordner ganz normal unter /wp-content/uploads, da wurde nichts geändert. Rechte habe ich auch testweise auf 777 gesetzt, wie in diesem Thread erwähnt: viewtopic.php?t=5605
Brachte allerdings auch keine Besserung. Er zeigt im Ordner /html/cms/wp-content/uploads/wpsg_temp die Zip-Datei des Moduls an, was ich installieren möchte, allerdings sind diese 0 KB groß.

Eine Idee? :)

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2054
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Installation von Modulen bricht mit 500 Error ab

Beitragvon ThoGoe » 21.04.2017, 08:27

Hallo!

Das wp-Filesystem wurde nicht initialisiert, daher kommt der Fehler. Du musst deine Berechtigung auf 777 für den wp-content/plugins stellen. Wenn das keine Besserung bringt, würde ich sagen, dass serverseitig keine entfernte URL nicht geöffnet werden dürfen. Bitte setzte erstmal die Rechte auf den Plugins-Ordner und teste das Ganze noch einmal.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

matthias87
Beiträge: 11
Registriert: 19.04.2017, 17:58
Lizenz: wpShopGermany Enterprise

Re: Installation von Modulen bricht mit 500 Error ab

Beitragvon matthias87 » 21.04.2017, 15:58

Hallo,

die Änderung der Berechtigung brachte beim Pluginordner keine Besserung. Muss nur der oberste Hauptordner geändert werden oder noch weitere in der Hierarchie darunter? Momentan haben nun folgende Ordner Chmod 777:

- wp-content/plugins
- wp-content/uploads/wpsg -r
- wp-content/uploads/wpsg_produktbilder -r
- wp-content/uploads/wpsg_temp -r

Kann ich über phpinfo einsehen, ob das "Aufrufen entfernter URLs" gestattet ist? Auf welchen Parameter muss ich hier schauen?

Edit: allow_url_fopen ist on, allow_url_include ist off (falls benötigt..?). cURL ist verfügbar.

Edit2: Problem scheint, dass $wp_filesystem null ist an der Stelle, obwohl er es global holt. Wenn ich WP_Filesystem(); davor einfüge, meldet er "Modul erfolgreich installiert.", aber leider stimmt das nicht, die Dateien bleiben 0kb groß in wpsg_temp.

matthias87
Beiträge: 11
Registriert: 19.04.2017, 17:58
Lizenz: wpShopGermany Enterprise

Re: Installation von Modulen bricht mit 500 Error ab

Beitragvon matthias87 » 25.04.2017, 20:37

Hallo, das Problem ist leider nach wie vor nicht gelöst und ich kann solange den Shop nicht in Betrieb nehmen.. Eine Neuinstallation brachte leider auch keinerlei Verbesserung. Woran könnte es noch liegen?

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15184
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Installation von Modulen bricht mit 500 Error ab

Beitragvon maennchen1.de » 26.04.2017, 09:16

Liegen Dateien in dem Ordner wpsg_temp? Wenn ja, lösche diese bitte einmal und teste erneut.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

matthias87
Beiträge: 11
Registriert: 19.04.2017, 17:58
Lizenz: wpShopGermany Enterprise

Re: Installation von Modulen bricht mit 500 Error ab

Beitragvon matthias87 » 26.04.2017, 11:17

Hallo, das brachte leider auch nichts. Ich habe nun die Module erstmal per FTP hochgeladen und aktiviert, da ich es nicht mehr länger aufschieben kann.

Solltet ihr irgendwelche Angaben der PHP-Settings benötigen, um es zu rekonstruieren, bitte einfach mitteilen.

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15184
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Installation von Modulen bricht mit 500 Error ab

Beitragvon maennchen1.de » 26.04.2017, 11:39

Wird WordPress im Webroot ausgeführt, oder in einem Unterverzeichnis?
Klappen Bilderuploads in wpShopGermany und auch in WordPress (Mediathek)?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

matthias87
Beiträge: 11
Registriert: 19.04.2017, 17:58
Lizenz: wpShopGermany Enterprise

Re: Installation von Modulen bricht mit 500 Error ab

Beitragvon matthias87 » 26.04.2017, 11:50

Wordpress wird in einem Unterverzeichnis (/cms) genutzt, der Upload von Bildern klappt sowohl in WP als auch in WPSG-Produkten.

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15184
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Installation von Modulen bricht mit 500 Error ab

Beitragvon maennchen1.de » 26.04.2017, 14:27

Wie hast du WordPress konfiguriert, hinsichtlich der URL?
Ist deine Instanz dann so erreichbar: http://domain.de/cms/
Oder hast du das in WordPress so konfiguriert, dass die Instanz über http://domain.de erreichbar ist? So wie hier beschrieben: https://bueltge.de/das-wordpress-weblog ... ehren/393/
Oder meinst du das anders und hast lediglich das über Interface deine Providers so angepasst?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

matthias87
Beiträge: 11
Registriert: 19.04.2017, 17:58
Lizenz: wpShopGermany Enterprise

Re: Installation von Modulen bricht mit 500 Error ab

Beitragvon matthias87 » 26.04.2017, 14:54

Die Installation ist von außen ganz normal über die Root-URL (/) erreichbar, die Domain ist (mittels Confixx) so konfiguriert, dass sie das Unterverzeichnis als Hauptverzeichnis nutzt.

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15184
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Installation von Modulen bricht mit 500 Error ab

Beitragvon maennchen1.de » 26.04.2017, 14:58

Dann ist es aber nur ein Unterverzeichnis aus Administrationssicht, aber nicht für die Instanz. ;)
Für die Instanz ist das Webroot cms/.
Wie sind die Berechtigungen dieses Ordners?
Ist der Besitzer dieses Ordners der selbe, wie für die darin enthaltenen Ordner?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

matthias87
Beiträge: 11
Registriert: 19.04.2017, 17:58
Lizenz: wpShopGermany Enterprise

Re: Installation von Modulen bricht mit 500 Error ab

Beitragvon matthias87 » 26.04.2017, 15:15

Der Ordner /cms verfügt über chmod 755, der User ist derselbe, wie auch bei allen anderen Dateien/Unterordnern.

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15184
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Installation von Modulen bricht mit 500 Error ab

Beitragvon maennchen1.de » 26.04.2017, 15:43

Hat der Ordner wpsg_temp noch die Berechtigung 777 und es liegen immer noch keine Dateien darin?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)


Zurück zu „Allgemeine Fragen zu wpShopGermany“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 6 Gäste