Kunden-Login schlägt fehl

Hier kannst du dich vorstellen und Fragen zum Plugin stellen.
Installation, Administration, etc.

Moderatoren: maennchen1.de, Joe, MKJ

Anne62
Beiträge: 76
Registriert: 25.01.2017, 18:46
Lizenz: wpShopGermany Enterprise

Kunden-Login schlägt fehl

Beitragvon Anne62 » 17.05.2017, 13:44

Moin,
nachdem ich ein Kundenkonto für Testbestellungen angelegt habe, ein paar Produkte in den Warenkorb gelegt habe und die Bestellung ausführen möchte, bekomme ich, nach Eingabe von E-Mail und Passwort, folgende Warnmeldung und kann die Bestellung nicht abschließen:

Warning: Missing argument 2 for wpsg_mod_basic::customer_delete_pre() in /www/htdocs/v072774/landleckereien/blogshop/wp-content/plugins/wpshopgermany/mods/wpsg_mod_basic.class.php on line 2

Warning: Missing argument 2 for wpsg_mod_basic::customer_delete_pre() in /www/htdocs/v072774/landleckereien/blogshop/wp-content/plugins/wpshopgermany/mods/wpsg_mod_basic.class.php on line 2

(Diese erste Meldung erschein 12 Mal, danach folgt der Rest)



Warning: Missing argument 2 for wpsg_mod_kundenverwaltung::customer_delete_pre() in /www/htdocs/v072774/landleckereien/blogshop/wp-content/plugins/wpshopgermany/mods/wpsg_mod_kundenverwaltung.class.php on line 38

Warning: Cannot modify header information - headers already sent by (output started at /www/htdocs/v072774/landleckereien/blogshop/wp-content/plugins/wpshopgermany/mods/wpsg_mod_basic.class.php:2) in /www/htdocs/v072774/landleckereien/blogshop/wp-content/plugins/wpshopgermany/controller/wpsg_SystemController.class.php on line 2

Nutze ich dann im Browser den "zurück"-Button behauptet das system, es gäbe die Kundendaten nicht, obwohl ich sie ja in der Kundenverwaltung sehen kann. Habt ihr eine Idee, was das sein kann?
Ich nutze Shop-Version 4.7.5, Firefox 53.0.2, Mac El Capitan 10.11.6, Twenty Twelve Eigendesign mit vielen Änderungen.
Vielen Dank schon einmal für eure Hilfe
Anne

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15181
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Kunden-Login schlägt fehl

Beitragvon maennchen1.de » 17.05.2017, 14:06

Hallo!
4.7.5 dürfte die WordPress Version sein, nicht die von wpShopGermany. Vielleicht kannst du das noch nachreichen?
Deaktiviere bitte aber zunächst deinen WordPress Debug-Modus, dann dürfte die Fehlermeldung nicht mehr auftreten.

Ansonsten: search.php?keywords=Missing+argument+2+for+wpsg_mod_basic
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Anne62
Beiträge: 76
Registriert: 25.01.2017, 18:46
Lizenz: wpShopGermany Enterprise

Re: Kunden-Login schlägt fehl

Beitragvon Anne62 » 18.05.2017, 10:25

Moin,
Danke als Erstes für die Tipps. Und ein großes Entschuldigung, gestern war's etwas hektisch - es ist natürlich Version 3.12.4 und die Website, um die es geht, ist http://landleckereien.de/blogshop/
Jetzt teste ich deine Tipps und meld mich wieder.
Beste Grüße und frohes Schaffen
Anne de Vries

Anne62
Beiträge: 76
Registriert: 25.01.2017, 18:46
Lizenz: wpShopGermany Enterprise

Re: Kunden-Login schlägt fehl

Beitragvon Anne62 » 18.05.2017, 10:56

Erster Tipp umgesetzt: der debug-modus steht auf false - stand er aber auch die ganze Zeit.. php-Version ist 5.6 (cgi). Da habe ich nachgefragt, ob es auf Apache umgestellt werden kann - weiß nicht, ob das irgendwie relevant ist.
Tja, es gab schon mal ein ähnliches Problem:
viewtopic.php?f=13&t=8462&p=50458#p50458

Nun schaue ich noch mal hier: search.php?keywords=Missing+argument+2+for+wpsg_mod_basic und dann sehen wir weiter.

Anne62
Beiträge: 76
Registriert: 25.01.2017, 18:46
Lizenz: wpShopGermany Enterprise

Re: Kunden-Login schlägt fehl

Beitragvon Anne62 » 18.05.2017, 11:15

Tja, leider komme ich da nicht weiter.

Ansonsten verweise ich auf das Problem viewtopic.php?f=13&t=8462&p=50458#p50458 wo ihr eine Lösung gefunden hattet. Vielleicht steht es damit im Zusammenhang?

Was bedeutet es übrigens, wenn in der Kundenverwaltung steht: Status: inaktiv ?
LGAnne

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15181
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Kunden-Login schlägt fehl

Beitragvon maennchen1.de » 18.05.2017, 11:48

Das ist doch exakt der selbe Fehler, den auch du selber gemeldet hast. Oder?
Er steht auch noch auf "zu erledigen", ist von uns also noch nicht behoben.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Anne62
Beiträge: 76
Registriert: 25.01.2017, 18:46
Lizenz: wpShopGermany Enterprise

Re: Kunden-Login schlägt fehl

Beitragvon Anne62 » 18.05.2017, 12:42

Du hast recht!
Es ist tatsächlich derselbe Fehler, aber bei einem anderen Vorgang im Kundenbereich, daher war mir das nicht aufgefallen.
Kann ich irgendeine andere Lösung einsetzen? Der Shop ist schon fast startbereit, aber ohne die Kundenanmeldung ist das nicht so toll.
Viele Grüße
Anne

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15181
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Kunden-Login schlägt fehl

Beitragvon maennchen1.de » 18.05.2017, 13:08

Beschreibe bitte einmal genauer, wann und wo der Fehler in deiesem Fall auftritt.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Anne62
Beiträge: 76
Registriert: 25.01.2017, 18:46
Lizenz: wpShopGermany Enterprise

Re: Kunden-Login schlägt fehl

Beitragvon Anne62 » 19.05.2017, 14:56

Ich versuche mal eine möglichst genaue Beschreibung:
1. Produkte in den Warenkorb gelegt
2. auf "zur Kasse" geklickt
3. Kundendatenformular ausgefüllt und am Ende auf "ich möchte ein Kundenkonto anlegen" geklickt.
4. Bestelleung beendet

Jetzt habe ich also ein Kundenkonto und möchte wieder etwas kaufen. Also wieder
1. Produkte in den Warenkorb gelegt
2. auf "zur Kasse" geklickt
3. Den oberen Check-In benutzt (E-Mail und Passwort), um mich wieder als Kunde anzumelden
checkin.jpg

Dann kommt die Warnmeldung:
warning.jpg

Klicke ich dann im Browser auf "neu laden" (Anhang Warning roter Kringel) kommt diese Meldung
warning2.jpg

klicke ich dort auf "neu senden", kommt dieses Fenster
abmeldung.jpg

Der Debug-Modus von Wordpress ist nicht aktiviert und auch im WPSG-Konfigurationsbereich hat er kein Häkchen.

aktive Wordpress Plugins:

Social Media Auto Post & Scheduler / 4.0.0
Gallery Manager Pro / 1.3.16
Simple Custom CSS / 3.3
Category Order and Taxonomy Terms Order / 1.5
wpShopGermany / 3.12.4

Abstellen der anderen Plugins scheint auch nix zu bringen.
So, ich hoffe, mit dieser Beschreibung könnt ihr was anfangen.
Ich habe dann auch mal alle templates von mir in den user_views deaktiviert - auch das brachte nix.

Ehrlich gesagt, bin ich bald soweit, WPShop zu deaktivieren und das Ganze unter "Lehrgeld" abzuschreiben ...
Aber vielleicht findet sich ja doch noch eine Lösung.

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15181
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Kunden-Login schlägt fehl

Beitragvon maennchen1.de » 19.05.2017, 16:28

Danke für die überdurchschnittlich gute Anleitung!
Wir testen das nächste Woche und versuchen das evtl. gleich zu fixen, sofern wir das reproduzieren können!

Vorab aber noch eine Frage:
Den verwendeten User hast du nicht zufällig vorher schon mal angelegt gehabt und wieder gelöscht?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Anne62
Beiträge: 76
Registriert: 25.01.2017, 18:46
Lizenz: wpShopGermany Enterprise

Re: Kunden-Login schlägt fehl

Beitragvon Anne62 » 19.05.2017, 16:57

Zu eurer Frage:
"Den verwendeten User hast du nicht zufällig vorher schon mal angelegt gehabt und wieder gelöscht?"
Das kann sein, da ich schon so viel getestet habe. Ich habe jetzt wieder einen neuen testuser angelegt und nehme dafür immer wieder zwei Mailadressen abwechselnd.

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15181
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Kunden-Login schlägt fehl

Beitragvon maennchen1.de » 19.05.2017, 17:49

Passiert denn der Fehler auch, wenn du einen Phantasieuser nimmst, den du vorher noch nicht hattest?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Anne62
Beiträge: 76
Registriert: 25.01.2017, 18:46
Lizenz: wpShopGermany Enterprise

Re: Kunden-Login schlägt fehl

Beitragvon Anne62 » 20.05.2017, 09:43

Moin,
Folgendes gemacht:
komplett neues E-Mail-Konto bei meinem Provider angelegt.
1. Produkte in den Warenkorb gelegt
2. auf "zur Kasse" geklickt
3. Kundendatenformular ausgefüllt und am Ende auf "ich möchte ein Kundenkonto anlegen" geklickt.
4. Bestellung beendet
5. Mail mit Bestellbestätigung empfangen - soweit alles o.k.
Dann wieder in den Shop
wieder Produkte in den Warenkorb gelegt
wieder auf "zur Kasse" geklickt
wieder den oberen Check-In benutzt (E-Mail und Passwort), um mich wieder als Kunde anzumelden
wieder Warn/Fehlermeldung :-(

Das Ganze habe ich auch schon mal probiert, nachdem der Rechner ausgeschaltet war.

Anne62
Beiträge: 76
Registriert: 25.01.2017, 18:46
Lizenz: wpShopGermany Enterprise

Re: Kunden-Login schlägt fehl

Beitragvon Anne62 » 23.05.2017, 15:46

Wie es scheint, habe ich den Fehler gefunden. Es gab ja noch andere, die hier im Forum ähnliche Probleme mit der Kundenanmeldung meldeten.
In diesem Thread
viewtopic.php?f=13&t=8500
fand ich die Lösung: in der wp-config.php-Datei muss die Einstellung "define('WP_DEBUG', false);" erweitert werden:
wie Dave89 schreib:
define('WP_DEBUG', false);
define('WP_DEBUG_LOG', true);
define('WP_DEBUG_DISPLAY', false);
@ini_set('display_errors',0);

Dann funktionieren auch wiederholte Anmeldungen.
Ich finde es ein wenig enttäuschend, dass hier gar keine Idee von maennchen1 kam, das an dieser Stelle der wp-config der Hase im Pfeffer lag, ähnliche Problem ist ja nun schon öfter in verschiedenen Threads behandelt worden.
Wie auch immer, ich teste nun noch mal ein wenig, ob es sich wirklich erledigt hat.

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2049
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Kunden-Login schlägt fehl

Beitragvon ThoGoe » 24.05.2017, 07:28

Hallo!

Wir haben die letzten Tage ebenfalls danach gesucht und ich für meinen Teil hatte die Debugfunktion in der wp-config vernachlässigt, da (wie du schon sagtest) dieser Fehler bereits im Forum behandelt wurde und ich davon ausging, dass du über die Suchfunktion diesen Fehler bereits ausgeschlossen hattest. Es tut mir Leid, ich hätte dir zwischendurch einmal schreiben sollen, dass wir an der Ursachenforschung dran sind. Es freut uns natürlich, dass der Fehler gefunden wurde und alles soweit funktioniert, wie du es dir wünschst.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!


Zurück zu „Allgemeine Fragen zu wpShopGermany“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste