Probleme mit Audioplayer bei mehreren Produktvarianten

Du hast Probleme mit der Formatierung der Anzeige und weißt nicht woher der Fehler kommt und wie du ihn beheben kannst?

Moderatoren: ThoGoe, maennchen1.de

matteobohe
Beiträge: 23
Registriert: 10.01.2015, 15:32
Lizenz: wpShopGermany Enterprise
Kontaktdaten:

Probleme mit Audioplayer bei mehreren Produktvarianten

Beitragvon matteobohe » 15.02.2017, 13:28

Hallo,

ich verwende wpsg zum Verkauf von Musik.

Über die Produktbeschreibung habe ich den standard Audio-Player von WordPress eingebunden.

Sobald ich im Frontend eine andere Produktvariante auswähle, wechselt die Darstellung des Audio-Players auf die Fallback-Variante.
Hier ein Beispiel: https://gemafrei.tv/

Habst ihr eine Idee wo das Problem zu suchen ist und wie ich es beheben könnte?

Viele Grüße
Zuletzt geändert von matteobohe am 20.02.2017, 11:35, insgesamt 1-mal geändert.

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15740
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Probleme mit Audioplayer bei mehreren Produktvarianten

Beitragvon maennchen1.de » 15.02.2017, 14:32

Hallo!
Derzeit gibt es einen Serverfehler "500" und es wird nichts weiter angezeigt.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

matteobohe
Beiträge: 23
Registriert: 10.01.2015, 15:32
Lizenz: wpShopGermany Enterprise
Kontaktdaten:

Re: Probleme mit Audioplayer bei mehreren Produktvarianten

Beitragvon matteobohe » 15.02.2017, 14:52

maennchen1.de hat geschrieben:Hallo!
Derzeit gibt es einen Serverfehler "500" und es wird nichts weiter angezeigt.

Oh Entschuldigung, ich hantiere im Hintergrund herum.. jetzt sollte es wieder gehen!

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15740
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Probleme mit Audioplayer bei mehreren Produktvarianten

Beitragvon maennchen1.de » 15.02.2017, 14:54

Wie fügst du den Player ein?
Der Inhalt wird per AJAX neu geladen. Ich befürchte dass hier deine Einbindung "kaputt geht".
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

matteobohe
Beiträge: 23
Registriert: 10.01.2015, 15:32
Lizenz: wpShopGermany Enterprise
Kontaktdaten:

Re: Probleme mit Audioplayer bei mehreren Produktvarianten

Beitragvon matteobohe » 15.02.2017, 14:57

maennchen1.de hat geschrieben:Wie fügst du den Player ein?
Der Inhalt wird per AJAX neu geladen. Ich befürchte dass hier deine Einbindung "kaputt geht".

Ich füge ihn per Shortcode ein. Entweder

Code: Alles auswählen

[embed]datei.mp3[/embed]
oder

Code: Alles auswählen

[audio src="datei.mp3"]

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15740
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Probleme mit Audioplayer bei mehreren Produktvarianten

Beitragvon maennchen1.de » 15.02.2017, 15:18

Derzeit funktioniert aber auch der Player nicht beim ersten Aufruf.
Deaktiviere bitte einmal andere Plugins und teste erneut. (Fange mal mit YOAST SEO an.)
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

matteobohe
Beiträge: 23
Registriert: 10.01.2015, 15:32
Lizenz: wpShopGermany Enterprise
Kontaktdaten:

Re: Probleme mit Audioplayer bei mehreren Produktvarianten

Beitragvon matteobohe » 15.02.2017, 15:37

maennchen1.de hat geschrieben:Derzeit funktioniert aber auch der Player nicht beim ersten Aufruf.
Deaktiviere bitte einmal andere Plugins und teste erneut. (Fange mal mit YOAST SEO an.)

Ich habe jetzt alles Plugins deaktiviert. Dass der Player beim ersten Aufruf nicht funktionierte, lag noch an einer Angabe in der htaccess.

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15740
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Probleme mit Audioplayer bei mehreren Produktvarianten

Beitragvon maennchen1.de » 15.02.2017, 15:54

Prima. Jetzt geht es.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

matteobohe
Beiträge: 23
Registriert: 10.01.2015, 15:32
Lizenz: wpShopGermany Enterprise
Kontaktdaten:

Re: Probleme mit Audioplayer bei mehreren Produktvarianten

Beitragvon matteobohe » 20.02.2017, 11:34

Hat jemand von euch Forumsnutzern Lösungsvorschläge?

Viele Grüße

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15740
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Probleme mit Audioplayer bei mehreren Produktvarianten

Beitragvon maennchen1.de » 20.02.2017, 11:41

Welches Problem hast du noch? Dein eingangs beschriebenes Problem ist doch behoben. Der Play funktioniert weiterhin, wenn du eine andere Variante auswählst.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

matteobohe
Beiträge: 23
Registriert: 10.01.2015, 15:32
Lizenz: wpShopGermany Enterprise
Kontaktdaten:

Re: Probleme mit Audioplayer bei mehreren Produktvarianten

Beitragvon matteobohe » 20.02.2017, 11:44

Hallo,

der Player funktioniert weiterhin, allerdings wechselt die Darstellung des Audio-Players auf die Fallback-Variante. Das ist zur Not auch in Ordnung, bingt aber ein paar andere Unannehmlichkeiten mit sich - angefangen mit den sich ändernden Aussehen.

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15740
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Probleme mit Audioplayer bei mehreren Produktvarianten

Beitragvon maennchen1.de » 20.02.2017, 11:52

Mit Fallbackmodus meinst du, dass z.B. die Statusleiste im Player fehlt?
Dann gibst du doch dem Shortcode weitere Parameter mit, oder?
Welche wpShopGermany Versionsnummer setzt du ein?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

matteobohe
Beiträge: 23
Registriert: 10.01.2015, 15:32
Lizenz: wpShopGermany Enterprise
Kontaktdaten:

Re: Probleme mit Audioplayer bei mehreren Produktvarianten

Beitragvon matteobohe » 20.02.2017, 11:56

maennchen1.de hat geschrieben:Mit Fallbackmodus meinst du, dass z.B. die Statusleiste im Player fehlt?

Ganz genau.
Dann gibst du doch dem Shortcode weitere Parameter mit, oder?

Nein, bisher gebe ich keine weiteren Parameter mit.
Welche wpShopGermany Versionsnummer setzt du ein?

Ich verwende derzeit Version 3.12.1.6036 mit WP 4.7.2


Zurück zu „Formatierung, Templates (PHTML), HTML, CSS-Anzeige“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste