Abonnentenvariablen werden nicht gespeichert...

Forum zu Fragen und Diskussionen zum WordPress Plugin wpNewsletterGermany
http://wpnewslettergermany.maennchen1.de/

Moderatoren: ThoGoe, maennchen1.de

mwerker
Beiträge: 2
Registriert: 06.10.2016, 06:20
Lizenz: keine

Abonnentenvariablen werden nicht gespeichert...

Beitragvon mwerker » 06.10.2016, 06:49

Moin Moin.
Nach erfolgreicher Einrichtung des Moduls "Abonnentenvariablen"
werden diese auch wie gewünscht innerhalb der Registrierungsmaske ausgegeben.

Nach erfolgreicher Anmeldung werden die Angaben allerdings nicht gespeichert.
(siehe Screenshot ganz unten)...

Kann jemand helfen?
Vielen Dank im Vorraus und viele Grüße aus dem hohen Norden. mwerker


(habe eine PlugIn Version aus dem Juli 2016 und eine Enterprise Lizenz)
Dateianhänge
problem-abonnentenvariablen.png

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15740
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Abonnentenvariablen werden nicht gespeichert...

Beitragvon maennchen1.de » 06.10.2016, 08:22

Hallo!
Könntest du bitte sagen, welche Versionsnummer du im Einsatz hast?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

mwerker
Beiträge: 2
Registriert: 06.10.2016, 06:20
Lizenz: keine

Re: Abonnentenvariablen werden nicht gespeichert...

Beitragvon mwerker » 07.10.2016, 11:39

Hallo. Es ist die Version 1.0.3 und das wordpress dazu ist aktuell.

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15740
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Abonnentenvariablen werden nicht gespeichert...

Beitragvon maennchen1.de » 07.10.2016, 17:09

Danke für die Meldung. Das ist in der Tat ein Fehler. Wir fixen das mit dem nächsten Update.
Wann es genau kommt, kann ich nicht sagen. Ich kann aber versprechen, dass wir es so zeitnah wie möglich heraus bringen!
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2551
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Abonnentenvariablen werden nicht gespeichert...

Beitragvon ThoGoe » 11.10.2016, 09:44

Hallo!

Das Problem ist, dass die Auswahl im Frontend als Wert in die Datenbank gespeichert wird. Wenn du diese Auswahl im Backend änderst, wird es als Index gespeichert. Eine Möglichkeit wäre es, wenn du den Code in der abonnenten_edit.phtml unter views/mods/mod_userfields mit folgendem Code austauschst:

Code: Alles auswählen

<?php

   /**
    * Template für die Abfrage der Abonnentenvariablen in der Abonnentenverwaltung
    */

?>
<?php if (wpng_isSizedArray($this->view['wpng_mod_userfields']['arAV'])) { ?>
   <div class="metabox-holder wpng_metabox-holder">
      <div class="postbox">                  
         <div class="handlediv"><br /></div>
         <h3 class="hndle"><?php echo __('Benutzerdefinierte Felder', 'wpng'); ?></h3>
         <div class="inside">
            <?php foreach ($this->view['wpng_mod_userfields']['arAV'] as $av) { ?>
               <?php if ($av['typ'] == '1') { ?>
                  <?php echo wpng_drawForm_Select('wpng_mod_userfields['.$av['id'].']', $av['name'], (array)explode('|', $av['auswahl']), $av['value'], array('noIndex' => true)); ?>
               <?php } else if ($av['typ'] == '2') { ?>
                  <?php echo wpng_drawForm_Input('wpng_mod_userfields['.$av['id'].']', $av['name'], $av['value']); ?>
               <?php } else if ($av['typ'] == '3') { ?>
                  <?php echo wpng_drawForm_Checkbox('wpng_mod_userfields['.$av['id'].']', $av['name'], $av['value']); ?>
               <?php } ?>
            <?php } ?>      
         </div>
      </div>
   </div>   
<?php } ?>


Damit sollte das Problem behoben sein. Teste das Ganze bitte einmal aus. Über ein kurzes Feedback würden wir uns freuen.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!


Zurück zu „wpNewsletterGermany“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste