Fehler bei update auf 3.12.1.6035!

Hier findest du nur Beiträge zu aktuellen Betaversion, von Beta-Testern. Beta, Beta, Beta! :)

Moderatoren: ThoGoe, maennchen1.de

Benutzeravatar
Frixi
Beiträge: 920
Registriert: 29.10.2014, 16:25
Lizenz: keine

Fehler bei update auf 3.12.1.6035!

Beitragvon Frixi » 26.01.2017, 12:06

Hallo maennchen1-Team,

beim Versuch ein Update von 3.12.1 auf die Beta 3.12.1.6035 in den WordPress-Aktualisierungen durchzuführen kam folgende Fehlermeldung:

Code: Alles auswählen

Plugin aktualisieren

Herunterladen der Aktualisierung von http://dl.maennchen1.de/wpsg/wpsg/wpshopgermany_dev.zip …

Entpacken der aktualisierten Version …

Die aktuelle Version wird installiert …
Kopiere Shop aus dem Pluginverzeichnis ...

Entfernung der alten Version des Plugins …
Kopiere Shop zurück ...
Fatal error: Call to undefined method wpsg_AdminController::callMod() in /var/www/vhosts/hosting4283.af929.netcup.net/httpdocs/wp-shop/wp-content/plugins/wpshopgermany/controller/wpsg_AdminController.class.php on line 68

Danach war der Shop weg - na ja, man lernt ja dazu und macht ein Backup.

Nach dem zurückgespielten Backup mutig einfach nochmals direkt bei den Plugins aktualisiert, diesmal kam eine simple Fehlermeldung (die ich nicht kopiert habe), danach konnte ich mich wegen des Wartungsmodus nicht mehr im Backend anmelden. Hier hat dann eine kurze Google-Suche ergeben, dass ich die Datei .maintenance löschen muss. Backup von 3.12.1 rein, und es läuft wieder.

Irgendwas bei der .6035 muss hier schief laufen, denn die .6017 wurde problemlos im Testsystem auf die 3.12.1 installiert.

Dies zu eurer Information.
Zuletzt geändert von Frixi am 26.01.2017, 12:36, insgesamt 1-mal geändert.
WP V.4.9.5 - WPSG V.3.12.5 - Shop: friXtender.de/shop

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15740
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Fehler bei update auf 3.12.1.6035!

Beitragvon maennchen1.de » 26.01.2017, 12:27

Hallo!
Also hatte der zweite Updateversuch geklappt (bis auf das maintenance Problem)?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Benutzeravatar
Frixi
Beiträge: 920
Registriert: 29.10.2014, 16:25
Lizenz: keine

Re: Fehler bei update auf 3.12.1.6035!

Beitragvon Frixi » 26.01.2017, 12:35

Nein, es kam eine Fehlermeldung direkt unter dem Plugin-Namen, dass das Update nicht durchgeführt werden konnte.

Ich habe nun im Testshop von .6017 auf .6035 upgedatet und das hat funktioniert. Es scheint wohl bloß von 3.12.1 auf .6035 ein Problem zu geben.
WP V.4.9.5 - WPSG V.3.12.5 - Shop: friXtender.de/shop

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15740
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Fehler bei update auf 3.12.1.6035!

Beitragvon maennchen1.de » 27.01.2017, 09:18

Danke für die Meldung. Wir konnten hier einen Fehler entdecken und beheben diesen bis zum nächsten Update (kein VÖ-Termin bekannt).
Es kann aber sein, dass der Fehler erst mit dem übernächsten Update bei dir nicht mehr auftaucht, da diese Datei beim Update-Prozess genutzt wird, werden wahrscheinlich die alten Scripte beim neuen Update verwendet.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Benutzeravatar
Frixi
Beiträge: 920
Registriert: 29.10.2014, 16:25
Lizenz: keine

Re: Fehler bei update auf 3.12.1.6035!

Beitragvon Frixi » 27.01.2017, 12:28

Ok, gut, dass ihr den Fehler gefunden habt.

Ich habe das Plugin vom Testshop jetzt einfach rüber in den Produktivshop kopiert, das hat funktioniert.
WP V.4.9.5 - WPSG V.3.12.5 - Shop: friXtender.de/shop


Zurück zu „wpShopGermany Beta-Tester“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast