Fatal error beim Plugin Update

Hier kannst du dich vorstellen und Fragen zum Plugin stellen.
Installation, Administration, etc.

Moderatoren: ThoGoe, maennchen1.de

Antworten
hgweber
Beiträge: 22
Registriert: 14.02.2012, 13:36
Lizenz: wpShopGermany Pro
Skype-Name: hgw7m

Fatal error beim Plugin Update

Beitrag von hgweber » 30.10.2018, 19:00

Hallo,

ich habe in einem Shop (mom-music.com) bei der Plugin-Aktualisierung folgende Fehlermeldung erhalten:

Fatal error: Call to undefined method wpsg_Shop Controller::getTempDir()

Das Plugin-Update hat damit abgebrochen, Produkte werden nicht mehr angezeigt (nur noch die Shortcuts).

Der Shop läuft aktuell noch in WP 3.5.1 mit wpshopgermany Pro Lizenz, Version 3.12.8 - PHP Version: 5.6.34 - und sollte jetzt bis WP 4.9.8 upgedatet werden.

Das Update sollte mit der alten WP-Version eigentlich keine Probleme haben, laut Angabe in den Details, soweit ich das verstanden hatte.

Danke für Tipps hierzu!
Heinz-Günter Weber
Zuletzt geändert von hgweber am 30.10.2018, 19:47, insgesamt 1-mal geändert.

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16137
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Fatal error beim Plugin Update

Beitrag von maennchen1.de » 30.10.2018, 19:09

Hallo!
Version 3.12.8 ist die letzte 3er Version. Hier gibt es keine weiteren Updates.
Meinst du ein Upgrade auf Version 4? Dann beschreibe bitte, wie du vorgegangen bist.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

hgweber
Beiträge: 22
Registriert: 14.02.2012, 13:36
Lizenz: wpShopGermany Pro
Skype-Name: hgw7m

Re: Fatal error beim Plugin Update

Beitrag von hgweber » 30.10.2018, 19:51

Danke für die Antwort. Ich hatte auf "Update zu Version 3.12.8" geklickt, dies ist dann auch gestartet, allerdings wie beschrieben hängengeblieben. In der Plugin-Übersicht wird diese Version aber schon angezeigt. Zuvor muss wohl Version 3.1.4 aktiv gewesen sein.

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 3073
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Fatal error beim Plugin Update

Beitrag von ThoGoe » 01.11.2018, 09:01

Hallo!

Bist du nach unserer Update-Anleitung vorgegangen?
Wurde das Plugin wpShopGermany aktualisiert? Bitte aktiviere den wpShopGermany in der Pluginverwaltung.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

Antworten