Fehlermeldung wpShopGermany 3.12.8 PH7.2

Hier kannst du dich vorstellen und Fragen zum Plugin stellen.
Installation, Administration, etc.

Moderatoren: ThoGoe, maennchen1.de

Antworten
Hille
Beiträge: 51
Registriert: 08.03.2012, 19:15
Lizenz: keine

Fehlermeldung wpShopGermany 3.12.8 PH7.2

Beitrag von Hille » 30.11.2018, 10:43

Hallo,

ich bekomme unter PHP7.2 (wpShopGermany 3.12.8 ) einen error500 beim Klick auf den Paypal Button. Folgende Fehlermeldung erscheint in der error.log:

Code: Alles auswählen

PHP Fatal error:  Cannot use PayPal\\Api\\object as object because 'object' is a special class name in /var/www/meine_domain.de/wp-content/plugins/wpshopgermany/lib/PayPal/Api/Payment.php on line 8\n
Wie kann ich das Problem lösen?

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16195
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Fehlermeldung wpShopGermany 3.12.8 PH7.2

Beitrag von maennchen1.de » 30.11.2018, 10:54

Hallo!
Bitte nutze für wpShopGermany 3 maximal ein PHP 7.1, oder aktualisiere auf wpShopGermany 4.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Hille
Beiträge: 51
Registriert: 08.03.2012, 19:15
Lizenz: keine

Re: Fehlermeldung wpShopGermany 3.12.8 PH7.2

Beitrag von Hille » 30.11.2018, 11:25

Danke für die Antwort. Kann eine Umstellung auf wpShopGermany 4 problemlos erfolgen oder gibt es dazu etwas zu beachten?

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16195
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Fehlermeldung wpShopGermany 3.12.8 PH7.2

Beitrag von maennchen1.de » 30.11.2018, 11:43

Version 4 ist nahezu neu programmiert.
Lies dich bitte hier erst einmal ein:
- https://wpshopgermany.maennchen1.de/faq ... version-4/
- https://doc.maennchen1.de/docs/wpshopge ... n-3-auf-4/
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Hille
Beiträge: 51
Registriert: 08.03.2012, 19:15
Lizenz: keine

Re: Fehlermeldung wpShopGermany 3.12.8 PH7.2

Beitrag von Hille » 30.11.2018, 13:16

Die Umstellung nach Anleitung auf 4.0.11 hat problemlos funktioniert. Allerdings erscheint die Fehlermeldung bzw der error500 nach wie vor

Code: Alles auswählen

PHP Fatal error:  Cannot use PayPal\\Api\\object as object because 'object' is a special class name in /var/www/meine_domain.de/wp-content/plugins/wpshopgermany-free/lib/PayPal/Api/Payment.php on line 8\n', referer: https://www.meine_domain.de/shop/warenkorb/?order_id=1468&wpsg_done=
Wie kann ich den Fehler beseitigen?

Hille
Beiträge: 51
Registriert: 08.03.2012, 19:15
Lizenz: keine

Re: Fehlermeldung wpShopGermany 3.12.8 PH7.2

Beitrag von Hille » 30.11.2018, 13:57

Ich konnte das Problem vorerst lösen. Ich habe die Payment.php ist dem Github PayPal-PHP-SDK verwendet

https://github.com/paypal/PayPal-PHP-SD ... PayPal/Api

Antworten