Produktbilder Upload

Bitte hier nichts mehr posten!

Moderatoren: ThoGoe, maennchen1.de

proseccoundwein
Beiträge: 34
Registriert: 21.06.2011, 17:27

Re: Produktbilder Upload

Beitrag von proseccoundwein » 29.04.2012, 21:22

Hallo Daschmi,

hab den Fehler gerade entdeckt...nach langem Suchen. Der Pfad war völlig korrekt (http://www.proseccoundwein.com/wp-conte ... eingau.jpg).

Es lag an den Schreibberechtigungen. Wir hatten vor einigen Tagen einen Serverumzug. Scheinbar haben sich da, aus welchem Grund auch immer, die Berechtigungen verändert. Läuft alles wieder :-).

LG Christian

e_fetch
Beiträge: 38
Registriert: 11.11.2010, 19:17

Re: Produktbilder Upload

Beitrag von e_fetch » 04.06.2012, 10:38

Moin,

ich habe ein Produkt angelegt.
Beim Produktbild-Upload erscheint das Auswahlfenster, ich wähle eine Datei aus, nichts geschieht.
Die Rechte von /wp-content/uploads/produktbilder habe ich jetzt mal auf 777 gesetzt.
Putzigerweise wurde das Verzeichnis zum Produkt "1" angelegt, das aber nicht beschreibbar ist.
Nachdem ich das geändert habe, lag das große bild im Verzeichnis "1", das Verzeichnis "tn" wurde angelegt - ohne Schreibberechtigung zu haben.
Der versuch, das zu ändern, wurde mit der Meldung "Kann entfernte datei nicht ändern" quittiert.
Providerproblem?
(Der Kunde will ums Verrecken nicht wechseln.)

Der Bilderupload in Wordpress-Artikel funktioniert.

Beste Grüße
sendet
Frank

Benutzeravatar
daschmi
m1.Mitarbeiter
Beiträge: 2383
Registriert: 04.12.2007, 18:23
Lizenz: keine
Kontaktdaten:

Re: Produktbilder Upload

Beitrag von daschmi » 04.06.2012, 10:55

Hi Frank,

Das wird an den umask Einstellungen des Servers liegen. Dein Provider kann dir da sicherlich weiterhelfen.

viele Grüße

Daschmi

e_fetch
Beiträge: 38
Registriert: 11.11.2010, 19:17

Re: Produktbilder Upload

Beitrag von e_fetch » 04.06.2012, 16:37

....so scheint es zu sein.

Er schrieb:
"Ich habe den Besitzer des jeweiligen Verzeichnisses in den FTP-Benutzer geaendert.
Ich denke dieses hat geholfen."
Hat es nicht - aber wir kriegen das noch hin.
Beim Anlegen der Verzeichnisse und Rechte setzen von Hand klappt's, also liegt es definitiv nicht am wp-shop.
Vielleicht lege ich auch ein paar hundert Verzeichnisse inkl tn-Verzeichnissen an - dann kan nix schief gehen.
:-)

Vielen Dank
sagt
Frank

Benutzeravatar
Gecko123
Beiträge: 69
Registriert: 24.02.2012, 19:16
Lizenz: wpShopGermany Enterprise

Re: Produktbilder Upload

Beitrag von Gecko123 » 25.08.2012, 23:45

Bei mir geht es seit dem ich https verwende nicht mehr.
Die Bilder ändern sich nicht, auch wenn ich sie per hand hochlade, im Backend bleibt alles gleich. Im Backend kann man sie auch nicht löschen :(

UPDATE:
Es lag nicht an https.. hab den kompletten Ordner noch mal gelöscht und neu angelegt... Bilder lassen sich wieder hochladen.. es spukt ein bisschen :mrgreen: sehr komisch, da ich vor paar Stunden den Ordner auch auf 777 hatte, also an den Rechten liegt es wohl nicht.
<?php if ( have_time() ) : while ( have_time() ) : spend_time(); ?>

Gesperrt