Produktgruppenübersicht - Fatal error apply_filter

Bitte hier nichts mehr posten!

Moderatoren: ThoGoe, maennchen1.de

Gesperrt
kungfunefar
Beiträge: 49
Registriert: 13.04.2012, 12:22
Lizenz: wpShopGermany Enterprise

Produktgruppenübersicht - Fatal error apply_filter

Beitrag von kungfunefar » 13.04.2012, 18:00

Nach dem Update auf Version 2.5.2 wird die Produktgruppenübersicht nicht mehr angezeigt und mit folgendem PHP Fehler abgebrochen:
Fatal error: Call to undefined function apply_filter() in /wp-content/plugins/wpshopgermany/mods/mod_attribute.class.php on line 143

Ich kann nicht sagen ob das bereits bei der Version 2.5.1 der Fall war, auf jeden Fall hat es mit 2.4.2 noch funktioniert.
Habe mir die Zeile 143 angeschaut und mit gefährlichem Halbwisssen aus "apply_filter()" mal "apply_filters()" gemacht aber dann entsteht der folgende Fehler:
Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 523800 bytes) in /wp-content/plugins/qtranslate/qtranslate_core.php on line 754

Produktgruppen-Modul deaktiviert und wieder aktiviert, keine Veränderung.
System
OS X: Firefox - Safari - Chrome - Opera (je die aktuelle Version)

Benutzeravatar
daschmi
m1.Mitarbeiter
Beiträge: 2377
Registriert: 04.12.2007, 18:23
Lizenz: keine
Kontaktdaten:

Re: Produktgruppenübersicht - Fatal error apply_filter

Beitrag von daschmi » 13.04.2012, 18:42

Hi,

Versuch mal die Datei aus dem Anhang, sie muß unter wp-content/plugins/wpshopgermany/mods/

Viel Erfolg

Daschmi
Dateianhänge
mod_attribute.class.zip
Fehler in Produktattributen mit RTE
(2.64 KiB) 133-mal heruntergeladen

kungfunefar
Beiträge: 49
Registriert: 13.04.2012, 12:22
Lizenz: wpShopGermany Enterprise

Re: Produktgruppenübersicht - Fatal error apply_filter

Beitrag von kungfunefar » 13.04.2012, 22:06

Die Fehlermeldung kommt jetzt nicht mehr, allerdings werden die Kategorien bzw. Produktgruppen auch nicht angezeigt :-(
System
OS X: Firefox - Safari - Chrome - Opera (je die aktuelle Version)

Benutzeravatar
daschmi
m1.Mitarbeiter
Beiträge: 2377
Registriert: 04.12.2007, 18:23
Lizenz: keine
Kontaktdaten:

Re: Produktgruppenübersicht - Fatal error apply_filter

Beitrag von daschmi » 13.04.2012, 22:18

Hi,

Hast du ne URL wo man das einsehen kann ?

VG

Daschmi

kungfunefar
Beiträge: 49
Registriert: 13.04.2012, 12:22
Lizenz: wpShopGermany Enterprise

Re: Produktgruppenübersicht - Fatal error apply_filter

Beitrag von kungfunefar » 14.04.2012, 15:20

Ist ungünstig, da die Seite aktuell noch in einer lokalen Umgebung läuft. Ich werde es die Tage mal online bereitstellen und einen Link posten.

Kann irgendjemand das Problem reproduzieren?
System
OS X: Firefox - Safari - Chrome - Opera (je die aktuelle Version)

kungfunefar
Beiträge: 49
Registriert: 13.04.2012, 12:22
Lizenz: wpShopGermany Enterprise

Re: Produktgruppenübersicht - Fatal error apply_filter

Beitrag von kungfunefar » 14.04.2012, 17:52

Also mit wpshopgermany Version 2.4.1 funktioniert es einwandfrei. Erst ab Version 2.5.x geht's zumindest bei mir nicht mehr :cry:
System
OS X: Firefox - Safari - Chrome - Opera (je die aktuelle Version)

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15880
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Produktgruppenübersicht - Fatal error apply_filter

Beitrag von maennchen1.de » 16.04.2012, 09:08

Und dafür hat dir daschmi oben die Datei zur Verfügung gestellt und hofft auf dein Feedback, nachdem du diese an die beschriebene Stelle kopiert hast.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

kungfunefar
Beiträge: 49
Registriert: 13.04.2012, 12:22
Lizenz: wpShopGermany Enterprise

Re: Produktgruppenübersicht - Fatal error apply_filter

Beitrag von kungfunefar » 16.04.2012, 13:44

Das hatte ich doch schon gemacht und dazu geschrieben, dass die Fehlermeldung jetzt nicht mehr kommt, allerdings werden die Kategorien bzw. Produktgruppen auch nicht angezeigt.
System
OS X: Firefox - Safari - Chrome - Opera (je die aktuelle Version)

Benutzeravatar
daschmi
m1.Mitarbeiter
Beiträge: 2377
Registriert: 04.12.2007, 18:23
Lizenz: keine
Kontaktdaten:

Re: Produktgruppenübersicht - Fatal error apply_filter

Beitrag von daschmi » 16.04.2012, 13:54

Was hast du denn für Produktattribute angelegt, kannst du ev. von der Konfiguration mal einen Screenshot posten?

kungfunefar
Beiträge: 49
Registriert: 13.04.2012, 12:22
Lizenz: wpShopGermany Enterprise

Re: Produktgruppenübersicht - Fatal error apply_filter

Beitrag von kungfunefar » 17.04.2012, 13:04

Danke für den Tipp, es lag tatsächlich an den Produktattributen. Ich hatte dort testweise ein Attribut angelegt, das ich bisher allerdings noch nicht benuztzt habe. Seit dem Löschen des Attributs funktioniert es wieder einwandfrei.

:smt006
System
OS X: Firefox - Safari - Chrome - Opera (je die aktuelle Version)

Benutzeravatar
daschmi
m1.Mitarbeiter
Beiträge: 2377
Registriert: 04.12.2007, 18:23
Lizenz: keine
Kontaktdaten:

Re: Produktgruppenübersicht - Fatal error apply_filter

Beitrag von daschmi » 17.04.2012, 16:19

Hi,

Ist trotzdem komisch, da ich auch Produktattribute angelegt hatte. Aber wenns erst ma wieder funzt ...

VG

Daschmi

Gesperrt