Artikel per Link in Warenkorb legen

Bitte hier nichts mehr posten!

Moderatoren: ThoGoe, maennchen1.de

Gesperrt
kool
Beiträge: 21
Registriert: 30.03.2012, 13:31
Lizenz: keine
Kontaktdaten:

Artikel per Link in Warenkorb legen

Beitrag von kool » 14.05.2012, 01:15

Hallo,
bei mir kommt bei Verwendung des Links zum Artikel in den Warenkorb legen (http://wpshopgermany.maennchen1.de/2012 ... orb-legen/) die folgende Fehlermeldung:
"Auf ihrem System sind die Cookies derzeit deaktiviert."
Habe in folgendem Thema (viewtopic.php?f=14&t=741) gelesen und den Link ohne www ersellt. Daraufhin erhalte ich den folgenden Fehler:
"Fehler: Umleitungsfehler
Die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet werden kann. Dieses Problem kann manchmal auftreten, wenn Cookies deaktiviert oder abgelehnt werden."
Dasselbe geschieht auch wenn ich die Daten via POST über ein selbst erstelltes Formular schicke...

Die via Shortcode eingebundenen Default-Produktformulare funktionieren hingegen wie gewohnt - was mache ich falsch?

Danke im Voraus!

Grüße, Tim

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16100
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Artikel per Link in Warenkorb legen

Beitrag von maennchen1.de » 14.05.2012, 13:24

Hallo!
Hier wurde das Thema schon einmal besprochen:
viewtopic.php?f=13&t=2295

Überpüfe auch, ob du die selbe Domain nutzt, auf der du auch den Shop betreibst. www.domain.de ist eine andere wie domain.de (ohne www).
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

kool
Beiträge: 21
Registriert: 30.03.2012, 13:31
Lizenz: keine
Kontaktdaten:

Re: Artikel per Link in Warenkorb legen

Beitrag von kool » 15.05.2012, 10:15

es lag daran, dass ich in den Shop-Einstellungen nicht die folgende Option aktiviert hatte: "Nach Bestellung zu Warenkorb weiterleiten". Ich denke es wäre hilfreich, wenn dies im Tutorial angemerkt werden würde.

Danke und Grüße,
Tim

MKJ
Beiträge: 3073
Registriert: 25.08.2010, 16:11

Re: Artikel per Link in Warenkorb legen

Beitrag von MKJ » 15.05.2012, 13:37

kool hat geschrieben:es lag daran, dass ich in den Shop-Einstellungen nicht die folgende Option aktiviert hatte: "Nach Bestellung zu Warenkorb weiterleiten". Ich denke es wäre hilfreich, wenn dies im Tutorial angemerkt werden würde.
@Maennchen1: Stimmt das? Da hätte ich mich allerdings auch dumm und dusselig gesucht, denn darauf kommt man ja nicht so leicht. Im Tutorial steht es in der Tat nicht drin.
Tipps und Tricks rund um wpShopGermany: www.my-blog-shop.de

backlink-butler
Beiträge: 14
Registriert: 21.05.2012, 15:17
Lizenz: keine

Re: Artikel per Link in Warenkorb legen

Beitrag von backlink-butler » 22.05.2012, 22:49

Ich habe ebenfalls das Problem, wobei es nur bei dem Link auftritt. Die normalen Produkte gehen einwandfrei.

http://www.imwebsein.de/bestellen/
"test <a href="http://www.imwebsein.de/bestellen?produ ... s_id=<?php echo session_id(2); ?>">Produkt in den Warenkorb legen</a>"

MKJ
Beiträge: 3073
Registriert: 25.08.2010, 16:11

Re: Artikel per Link in Warenkorb legen

Beitrag von MKJ » 23.05.2012, 06:44

MKJ hat geschrieben:@Maennchen1: Stimmt das? Da hätte ich mich allerdings auch dumm und dusselig gesucht, denn darauf kommt man ja nicht so leicht. Im Tutorial steht es in der Tat nicht drin.
Würde mich auch freuen, hier mal eine Antwort zu bekommen.
Tipps und Tricks rund um wpShopGermany: www.my-blog-shop.de

Benutzeravatar
daschmi
m1.Mitarbeiter
Beiträge: 2383
Registriert: 04.12.2007, 18:23
Lizenz: keine
Kontaktdaten:

Re: Artikel per Link in Warenkorb legen

Beitrag von daschmi » 23.05.2012, 09:04

Hi,

Es kann zu Problemen führen wenn man die Option "Nach Bestellung zum Warenkorb leiten" nicht aktiviert hat. Ich habe die Dokumentation um einen zusätzlichen Parameter myReferer erweitert, dies bestimmt dann die Zielseite nach dem hinzufügen.

Viele Grüße

Daschmi

backlink-butler
Beiträge: 14
Registriert: 21.05.2012, 15:17
Lizenz: keine

Re: Artikel per Link in Warenkorb legen

Beitrag von backlink-butler » 23.05.2012, 10:12

der hacken ist bei mir aber drin ...

Benutzeravatar
daschmi
m1.Mitarbeiter
Beiträge: 2383
Registriert: 04.12.2007, 18:23
Lizenz: keine
Kontaktdaten:

Re: Artikel per Link in Warenkorb legen

Beitrag von daschmi » 23.05.2012, 10:37

Hi,

Das Problem welches bei dir auftritt hat eine andere Ursache. Im Code steht das <?php ... das sollte nicht sichtbar sein und durch die Ausgabe der SessionID ersetzt worden sein.

Der Inhalt wird vermutlich durch htmlspecialchars geleitet, was durch ein Theme oder ein Plugin verursacht werden kann.

Hast du mal ohne Plugins und mit dem Standardtheme versucht ?

VG

Daschmi

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16100
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Artikel per Link in Warenkorb legen

Beitrag von maennchen1.de » 23.05.2012, 13:45

Der Link beinhaltet PHP-Code. Dieser kann nicht regulär in einer Wordpress-Seite oder einem Wordpress-Artikel ausgeführt werden. Um in Seiten oder Artikel PHP-Code ausführen zu können, ist man auf die Hilfe von Wordpress -Plugins angewiesen.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

backlink-butler
Beiträge: 14
Registriert: 21.05.2012, 15:17
Lizenz: keine

Re: Artikel per Link in Warenkorb legen

Beitrag von backlink-butler » 23.05.2012, 15:45

habe jetzt run php zu laufen aktiviert aber es hat sich nix geändert

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16100
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Artikel per Link in Warenkorb legen

Beitrag von maennchen1.de » 23.05.2012, 15:58

Überprüfe bitte deinen Quelltext im Browser. Steht in dem von dir hinzugefügtem Link immer noch "<?php ..."? Falls ja, funktioniert dein PHP-Plugin nicht, oder ist falsch konfiguriert.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

backlink-butler
Beiträge: 14
Registriert: 21.05.2012, 15:17
Lizenz: keine

Re: Artikel per Link in Warenkorb legen

Beitrag von backlink-butler » 23.05.2012, 16:49

<p>test <a href="http://www.imwebsein.de/bestellen?produ ... s_id=<?php echo session_id(2); ?>" >Produkt in den Warenkorb legen</a></p> so siehts im quelltext aus

backlink-butler
Beiträge: 14
Registriert: 21.05.2012, 15:17
Lizenz: keine

Re: Artikel per Link in Warenkorb legen

Beitrag von backlink-butler » 23.05.2012, 17:01

naja ok ich glaub das ist zu kompliziert für mich ich lass das thema lieber

MKJ
Beiträge: 3073
Registriert: 25.08.2010, 16:11

Re: Artikel per Link in Warenkorb legen

Beitrag von MKJ » 24.05.2012, 09:13

backlink-butler hat geschrieben:naja ok ich glaub das ist zu kompliziert für mich ich lass das thema lieber
Wenn das im Quelltext so aussieht, wird PHP nicht ausgeführt. Entweder hast Du einen Schreibfehler im Text oder das PHP Plugin funktioniert nicht, wie Maennchen1 schon sagte. Versuch mal ein anderes.
Tipps und Tricks rund um wpShopGermany: www.my-blog-shop.de

Gesperrt