Richtiger Import der Exportdatei in Excel?

Bitte hier nichts mehr posten!

Moderatoren: ThoGoe, maennchen1.de

Gesperrt
Benutzeravatar
garnett
Beiträge: 295
Registriert: 13.07.2010, 23:02
Lizenz: wpShopGermany Pro
Wohnort: Sachsen

Richtiger Import der Exportdatei in Excel?

Beitrag von garnett » 11.06.2012, 00:06

hy!

ich habe gerade zwei produkte exportiert. felder sind ziemlich viele ausgefüllt. im beschreibungstext steht auch was drin mit zeilenumbrüchen etc.
wenn ich das jetzt im excel öffne und als trennzeichen komma auswähle, dann zerschießt es mir trotzdem die zuordnungen. einiges passt aber vieles auch nicht.
ich habe testweise mal die beschreibungstexte entfernt und dann funktioniert der import nach excel.

import erfolgt im excel 2007.
leeres dokument --> reiter daten --> aus text --> getrennt auswählen --> trennzeichen komma

kann das jemand bestätigen?
wpsg version: 2.5.3

im anhang habe ich mal jeweils einen export mit beschreibung und einen ohne.
könnt ihr euch ja mal anschauen :)
Dateianhänge
export.zip
(1.34 KiB) 94-mal heruntergeladen
garnett mit tt
nicht mit t
nicht mit ttt
;-)

DieterG
Beiträge: 29
Registriert: 14.04.2012, 18:54
Lizenz: keine

Re: Richtiger Import der Exportdatei in Excel?

Beitrag von DieterG » 11.06.2012, 01:51

hab mir das mal in Libre-Office angeschaut und kann das nicht nachvollziehen.
Bist du auf Excel angewiesen? Oder nimmst du es nur, weil du es hast?
Ich hab in Open- wie auch in Libre-Office festgestellt, das die Tabellenprogramme Schwierigkeiten machen bei längeren Textpassagen. Und habe ein Programm gefunden, womit ich sehr zufrieden bin.
Check doch mal http://www.csv-editor.de/
Ich hab mir das mit dem Universal Extractor unter http://www.legroom.net/software/uniextract portable gemacht. Damit kann der Kunde jetzt auf einem Stick seine Produkte selber einpflegen.
Gruß Dieter

Benutzeravatar
daschmi
m1.Mitarbeiter
Beiträge: 2383
Registriert: 04.12.2007, 18:23
Lizenz: keine
Kontaktdaten:

Re: Richtiger Import der Exportdatei in Excel?

Beitrag von daschmi » 11.06.2012, 05:26

Danke Dieter für die Antwort. Ich habe es jetzt mal mit Excel probiert er hat wirklich ein Problem mit Zeilenumbrüchen, er erkennt die Spalten nicht richtig auch wenn sie in " eingeschlossen sind.

Mit einem Texteditor wie UltraEdit kannst du die Zeilenumbrüche auch recht einfach entfernen. Die Option "RTE Felder mit nl2br speichern" sollte eventuell auch helfen, da werden die Zeilenumbrüche durch <br> ersetzt, allerdings kann das auch deine Absätze zerstören.

Ich verwende die Funktion fputcsv, bin bisher davon ausgegangen das ich mich dann nicht um so einen Kram kümmern muss :)

Viele Grüße

Daschmi

Benutzeravatar
garnett
Beiträge: 295
Registriert: 13.07.2010, 23:02
Lizenz: wpShopGermany Pro
Wohnort: Sachsen

Re: Richtiger Import der Exportdatei in Excel?

Beitrag von garnett » 11.06.2012, 16:45

OK, vielen dank schon mal. ich werd mir diverse csv-editoren mal anschauen.
gebunden an excel bin ich nicht ;-)

komischerweise wird das ganze ja bei mir schon mit <br/> exportiert. bin mir nicht 100%ig sicher, aber RTE Felder mit nl2br speichern ist deaktiviert.
garnett mit tt
nicht mit t
nicht mit ttt
;-)

Gesperrt