Branding bleibt bei Download-Email

Bitte hier nichts mehr posten!

Moderatoren: ThoGoe, maennchen1.de

Helmut4u
Beiträge: 38
Registriert: 06.03.2011, 00:50

Branding bleibt bei Download-Email

Beitrag von Helmut4u » 27.06.2012, 11:27

Habe mir gestern die "Enterprise" Version zusammen mit Rechnung und Downloadplus gekauft.
Einfach eine wunderbare Software :-)

Nach Lizenzeingabe ist auch brav jedes Branding verschwunden bis auf die EMail, die den Download-Link verschickt.

Kann ich das irgendwo abstellen oder liegt es vielleicht daran, dass ich Änderungen in "user_views" habe?
Dort sind allerdings mehrere und bei allen ist es ok...

Grüße
Manu

Helmut4u
Beiträge: 38
Registriert: 06.03.2011, 00:50

Re: Branding bleibt bei Download-Email

Beitrag von Helmut4u » 27.06.2012, 16:56

..das Schlechte dabei ist, dass nicht nur die Shop-Software benannt wird, sondern zusätzlich ein Link (http://wpshopgermany.maennchen1.de), der einen Beitrag über Registrierungsprobleme zeigt.
Das macht einen ziemlich unprofessionellen Eindruck - und gerade daran wird man gemessen :-(

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15880
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Branding bleibt bei Download-Email

Beitrag von maennchen1.de » 27.06.2012, 17:14

Hallo!
Hast du deine Lizenz bereits mit dem Modulcode erweitert?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Helmut4u
Beiträge: 38
Registriert: 06.03.2011, 00:50

Re: Branding bleibt bei Download-Email

Beitrag von Helmut4u » 27.06.2012, 21:02

Ja, beide Module sind einbezogen. Habe nochmals den Key generiert und per FTP hochgeladen. Habe auch auf 2.5.4 upgedated inkl. der Module. Bleibt wie vorher. Shop und Rechnungsmodul funktioniert, DownloadPlus funktioniert auch, bis auf den Link (Brand) am Schluss der eMail.
Danke.

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15880
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Branding bleibt bei Download-Email

Beitrag von maennchen1.de » 28.06.2012, 09:26

Wir können das Problem z.Zt. leider noch nicht nachstellen.
Wie erzeugst du die Mail (manuell oder per Cron-Job)?
Kannst du testweise den Ordner user_views umbenennen, damit dieser nicht geladen wird?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Helmut4u
Beiträge: 38
Registriert: 06.03.2011, 00:50

Re: Branding bleibt bei Download-Email

Beitrag von Helmut4u » 28.06.2012, 14:48

Ich erzeuge die Mail per Cron (Owner Apache). Ich benenne mal den Ordner um. Hab ich noch nicht dran gedacht..
Danke.

Helmut4u
Beiträge: 38
Registriert: 06.03.2011, 00:50

Re: Branding bleibt bei Download-Email

Beitrag von Helmut4u » 28.06.2012, 15:10

Hab den Ordner umbenannt jetzt sind wieder die Standards da aber das Branding bleibt. Vielleicht wegen der Cron?

Inhalt:
Hallo Testvorname Tester

Ihre Bezahlung zu der Bestellung 102 ist bei uns eingegangen.
Die Produkte, die als Download vorliegen wurden für Sie freigeschaltet.

Link (wurde hier entfernt)


Sie haben für 14 Tage die Möglichkeit die Dateien herunterzuladen.
Viele Grüße
Shop Team
----------------------------------------------------------------------------

Verwendete Shop Software : wpShopGermany (http://wpshopgermany.maennchen1.de)

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15880
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Branding bleibt bei Download-Email

Beitrag von maennchen1.de » 28.06.2012, 15:21

Und du hast auch alle aktuellen Dateien von hier:
http://wpshopgermany.maennchen1.de/about/#Download
herunter geladen und auf deinem Server installiert?
Falls ja, sende mir bitte per PM deine key.txt, die du auf deinem Server installiert hast.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Helmut4u
Beiträge: 38
Registriert: 06.03.2011, 00:50

Re: Branding bleibt bei Download-Email

Beitrag von Helmut4u » 29.06.2012, 16:12

Habe Key per PN geschickt. Danke.

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15880
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Branding bleibt bei Download-Email

Beitrag von maennchen1.de » 02.07.2012, 14:34

Also am Key liegt es nicht. Wir konnten problemfrei Mails erzeugen (egal ob manuell oder per Cron).
Lade dir bitte die aktuellsten Dateien von unserer Downloadseite herunter (wpShopGermany und alle Module!) und lade diese erneut auf deinen Server.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Helmut4u
Beiträge: 38
Registriert: 06.03.2011, 00:50

Jetzt geht fast gar nichts mehr :-(

Beitrag von Helmut4u » 03.07.2012, 14:09

Hallo, ich schon wieder.

Habe jetzt wiederholt auf die neuesten Versionen upgedatet.
Jetzt geht nnichts mehr mit "Downloadplus".

1. Der Shop verschickt ein Mail, dass der Status auf "Zahlung akzeptiert" gestellt wurde. In der Bestellverwaltung zeigt er aber "Rechnung geschrieben" an. Man muss dann nochmals manuell auf "Zahlung akzeptiert schalten.

2. Cron läuft und bearbeitet auch cron.php fehlerfrei. Jedoch wird weder das PDF aufbereitet noch die Mail mit dem Donloadlink verschickt (auch nicht bei Status "Zahlung akzeptiert").

Das lief alles schon einmal mit denselben Einstellungen !

3. Zum Testen des Brandings komme ich nicht mehr.

Ich sitze schon wieder Stunden und habe alles ausprobiert, auch die alten Versionen wieder einzuspielen... Fehlanzeige.

Jetzt könnte es sein, dass mein Server-Update neuere PHP-Module eingestellt hat. Ich erlaube mir per PN den Link zu PHPINFO zu schicken.

Sorry, aber jetzt geht mir das Latein aus.

LG
Manu

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15880
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Branding bleibt bei Download-Email

Beitrag von maennchen1.de » 03.07.2012, 14:23

1.) passiert nicht einfach so. Da hast du evtl. etwas verstellt oder eine bestehende Rechnung genommen.
2.) Woher weißt du, dass der Cronjob fehlerfrei startet? Wenn die Mail nicht verschickt wird, liegt das zu 99% daran, dass ein PHP-Fehler aufgetreten ist.

Wenn du nur dieselben Dateien hochgeladen hast, die vorher schon da waren, dann ändert sich auch nichts an den Einstellungen. Es sei denn, vorher hattest du eine andere Version installiert, oder, oder, oder.

Das Problem schneller zu lösen geht evtl. per Support-Ticket.

Deine phpinfo-Datei existiert nicht unter dem angegebenen Link.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Helmut4u
Beiträge: 38
Registriert: 06.03.2011, 00:50

Re: Branding bleibt bei Download-Email

Beitrag von Helmut4u » 03.07.2012, 14:46

Sorry, habe gerade ein "altes Backup" auf die Domain eingespiel und dabei die PHPINFO wieder überschrieben. Ist jetzt wieder da !!
Das war ein komplettes WP-Restore auf eine Version, wo Download Plus noch ging - geht jetzt auch nicht mehr. Sind offensichtlich meine neuen Servereinstellungen, die ich mir mit dem Upgrade auf Plesk 11 "eingefangen" habe.

Helmut4u
Beiträge: 38
Registriert: 06.03.2011, 00:50

Apache Module

Beitrag von Helmut4u » 03.07.2012, 14:55

Im Anhang sind die Apache Module, die bei mir aktiviert sind.
Vielleicht fehlt ja einfach Eines ? Aber das jetzt emirisch auszuprobieren...
Vielleicht siehst du das ja auf einen Blick.
Wäre die einfachste Lösung, bevor ich den kompletten Server wieder "downgrade"...

Danke jedenfalls für den superior Support :D Müsste sonst nach einem anderen Shopsystem welches dann nicht mehr auf WP laufen würde.
Aber genau das ist die Zukunft und deshalb WPShopGermany als einzig brauchbare Lösung.

LG
Dateianhänge
Module.jpg

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15880
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Branding bleibt bei Download-Email

Beitrag von maennchen1.de » 03.07.2012, 15:01

Die Apache Module sind nicht weiter relevant. Wichtiger sind die PHP-Einstellungen. Was da fehlt, erfährst du sicherlich, wenn du die Wordpress-Debugging Funktionen aktivierst.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Gesperrt