Unterschiedliche Bilder in Outlook und anderen Clients ???

Forum zu Fragen und Diskussionen zum WordPress Plugin wpNewsletterGermany
http://wpnewslettergermany.maennchen1.de/

Moderatoren: ThoGoe, maennchen1.de

Antworten
eddaz
Beiträge: 20
Registriert: 20.03.2013, 14:33
Lizenz: wpShopGermany Pro
Skype-Name: eddaz.

Unterschiedliche Bilder in Outlook und anderen Clients ???

Beitrag von eddaz » 23.11.2015, 12:47

Hallo allerseits,

teste gerade das Newsletter-Plugin.

Soweit alles prima, aber beim Testversand zeigen die eMailClients unterschiedliche Bilder (Mailcontent) an.
Mail und Thunderbird alles prima, Outlook zeigt völlig andere Bilder.
Wie um alles in der Welt ist sowas möglich???
Wenn ich auf 'im Browser ansehen' klicke, sind die richtigen Bilder drin.


Verzweifelte Grüße
Edda

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15979
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Unterschiedliche Bilder in Outlook und anderen Clients ???

Beitrag von maennchen1.de » 23.11.2015, 12:57

Hallo!
Um welche Bilder geht es? Hast du ein Bild im Editor des Newsletters eingefügt?
Wenn ja, wie hast du das gemacht?
Normalerweise wird eine URL zum Bild festgelegt. Diese URL wird vom Mailclient gelesen und angezeigt. Da gibt es eigentlich keinen Spielraum...
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

eddaz
Beiträge: 20
Registriert: 20.03.2013, 14:33
Lizenz: wpShopGermany Pro
Skype-Name: eddaz.

Re: Unterschiedliche Bilder in Outlook und anderen Clients ???

Beitrag von eddaz » 24.11.2015, 13:31

Hallo,
ich habe im Html-Inhalts-Editor über Dateien hinzufügen ein Bild aus der Mediathek (also dem uploads-Ordner von WP) ausgewählt und zugefügt.
Es wird in der visuellen Ansicht korrekt angezeigt. Wenn ich den Newsletter versende kommt er in Mail und Thunderbird korrekt an, aber Outlook (2013) hat falsche Bilder drin, übrigens u. a. eurer Newsletter-Logo.
Mein Shop-Logo, welches ich fest im Template notiert habe mit http://www.eddazdesign.de/shop/wp-conte ... s/logo.jpg, wird durch den Pfeil ersetzt, welcher bei eurem Template auf 'im Browser ansehen' zeigt.
???!!!???
>>Normalerweise wird eine URL zum Bild festgelegt. Diese URL wird vom Mailclient gelesen und angezeigt. Da gibt es eigentlich keinen Spielraum...<<
So hab ich mir das auch gedacht. Aber wie ist das dann möglich?

Vielen Dank für die schnelle Antwort, die ich aber erstmal übersehen habe. Jetzt den Haken an 'Mich benachrichtigen wenn...' gemacht. :)
Liebe Grüße
Edda

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15979
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Unterschiedliche Bilder in Outlook und anderen Clients ???

Beitrag von maennchen1.de » 24.11.2015, 16:06

Hast du evtl. mehrere Newsletter (Mails) versendet?
Nicht dass du pro Newsletter ein anderes Template verwendet hast?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

eddaz
Beiträge: 20
Registriert: 20.03.2013, 14:33
Lizenz: wpShopGermany Pro
Skype-Name: eddaz.

Re: Unterschiedliche Bilder in Outlook und anderen Clients ???

Beitrag von eddaz » 25.11.2015, 10:21

Nein, an den Templates liegt es nicht. Habe ich alles ausführlichst durchprobiert.
Habe inzwischen auch mal ein anderes Wordpress-Theme aktiviert um zu sehen, ob es vielleicht irgendwie an meinem selbstgestrickten WP-Theme liegt. Bin da ja nicht wirklich Profi. Aber gleiches Ergebnis.
Habe dann mal einen der Newsletter aus Outlook weitergeleitet und in Mail geöffnet, immer noch falsche Bilder im Inhaltsbereich. Aber das Logo ist jetzt das richtige, wenn auch verzerrt.
Wunder, oh Wunder...

Liebe Grüße
Edda

eddaz
Beiträge: 20
Registriert: 20.03.2013, 14:33
Lizenz: wpShopGermany Pro
Skype-Name: eddaz.

Re: Unterschiedliche Bilder in Outlook und anderen Clients ???

Beitrag von eddaz » 25.11.2015, 10:56

Hallo nochmal,

habe jetzt mal die html-Datei des Newsletters geöffnet.
Da wird das Logo so referenziert:
<img src="cid:img0" alt="PORZELLAN + SCHMUCK" style="display:block; width:288px; height:auto; margin:0;" />
Das erste Inhaltsbild:
<img class="alignnone size-medium wp-image-673" src="cid:img1" alt="neues produkt" width="231" height="159" />
Kann mir jemand sagen wie dieses src="cid:img0", src="cid:img1" entsteht?
Die Bilder im Anhang sind übrigens die richtigen...
Möchte es wirklich gerne verstehen.
LG
Edda

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15979
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Unterschiedliche Bilder in Outlook und anderen Clients ???

Beitrag von maennchen1.de » 25.11.2015, 11:04

Dann hast du wahrscheinlich die Option "Konfiguration > Einstellungen > Versandeinstellungen > Bilder in Mail einbetten:" aktiviert.
Damit werden alle Bilder in deinem Newsletter von der Software geladen und als Anhang in deine Mail gepackt.
Wenn hier eine Zuordnung evtl. schief läuft, versuche einmal alle anderen Plugins zu deaktivieren, ein WordPress Standard Theme zu aktivieren und versende den Newsletter erneut.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

eddaz
Beiträge: 20
Registriert: 20.03.2013, 14:33
Lizenz: wpShopGermany Pro
Skype-Name: eddaz.

Re: Unterschiedliche Bilder in Outlook und anderen Clients ???

Beitrag von eddaz » 25.11.2015, 14:12

Habe ich gemacht.
Wenn die Bilder nicht eingebettet sind lädt WIN-Mail die Bilder automatisch nach. Thunderbird auch, sofern es ihm ausdrücklich erlaubt wird.
Outlook sagt, es kann nicht laden, weil etwas mit dem Pfad nicht stimmt.
Allmählich vermute ich, daß das Problem bei meiner Outlook-Installation liegt.
Werde mal versuchen irgendjemand anderes Outlook-Version zu bemühen. seufz.

Danke für die geduldige Hilfe!
Edda

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15979
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Unterschiedliche Bilder in Outlook und anderen Clients ???

Beitrag von maennchen1.de » 25.11.2015, 14:37

Viel Erfolg!
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

eddaz
Beiträge: 20
Registriert: 20.03.2013, 14:33
Lizenz: wpShopGermany Pro
Skype-Name: eddaz.

Re: Unterschiedliche Bilder in Outlook und anderen Clients ???

Beitrag von eddaz » 04.12.2015, 10:45

Problem erledigt.
Tatsächlich war es ein anderes Newsletter-Plugin, das ich zuvor getestet, deaktiviert und gelöscht hatte, von dem aber tatsächlich noch Reste im System steckten. Sowas aber auch...

Danke für die geduldige Hilfe, habe mich jetzt für euer Plugin entschieden.
Wegen Anpassbarkeit und auch weil es die Möglichkeit des Abmeldens auf der Website gibt.
Das finde ich sehr sinnvoll und ich habe das so noch in keinem anderen Newsletter-Plugin gefunden.
Gute Arbeit. :D

Edda

Antworten