Seite 1 von 2

Plugin fehlerhaft

Verfasst: 11.02.2019, 10:43
von ole1210
Sehr geehrte Damen und Herren,

ich setze Ihr Newsletter-Plugin in der Pro-Version auf unserer Verseinsseite ein.

Nun wollte ich Freitag einen Newsletter versenden und musste feststellen, das eingefügte Bilder nicht mitgesendet wurden. Da es in der Vergangenheit einwandfrei funktioniert hat, habe ich unseren Server-Admin kontaktiert, da ich von einem Server-Fehler ausgegangen bin.

Von diesem habe ich jedoch die unten angefügte Info erhalten. Können Sie dazu bitte einmal Stellung nehmen?



Hallo Ole,

sorry, kein Serverfehler. In dem Newsletter-Plugin scheint ein Fehler zu sein. Vielleicht ist es nicht kompatibel mit PHP7? Zumindest habe ich einige alte Sourcen gefunden (PEAR wird schon länger nicht mehr gepflegt). Ich hab aber auch beide Varianten der Mailausgabe getestet (PHPMailer und mail, welches über eine PEAR MIMEMail geht). Beide Varianten liefern einen falschen Mailbody aus, vermutlich wäre das Ergebnis über die SMTP-Version identisch. Das Tool versucht die Bilder vom Server als Attachment einzubinden, allerdings ist das Attachment selbst leer. Evtl. nutzt das Tool auch Funktionen die nicht erlaubt sind? Die deaktivierten PHP-Funktionen lauten:

popen, proc_close, proc_get_status, proc_nice, proc_open, proc_terminate, show_source

Ich habe den Mail-Output in wp-content/plugins/wpnewslettergermany/lib/MIMEMailxPHP4_V2.2 abgelegt, die entsprechende Stelle, die die Datei schreibt ist im selben Verzeichnis in MIMEMailxPHP4_V2.inc (Zeile 461, kannst du auch wieder auskommentieren, wenn du nicht mehr testen möchtest). Die Ausgabedatei lautet "test.log" und ist genau das was 1:1 an Postfix weitergegeben wird. Ich hab dir die Datei gezipt auch an diese Mail angehängt. Ebenfalls zwei Screenshots, bei denen ich die relevanten Stellen markiert habe.

Leider ist das wpGermanNewsletter-Plugin (vermutlich aus Gründen des "Kopierschutzes") ein wenig obfuscated, was mir das Debugging schwer macht hat, und ein Bugfixing mache ich in solchen Dateien dann auch nicht mehr kostenlos.

Re: Plugin fehlerhaft

Verfasst: 11.02.2019, 11:14
von maennchen1.de
Hallo!
wpNewsletterGermany ist derzeit nicht kompatibel mit PHP7.0 oder neuer.
In den nächsten Wochen wird es eine neue Version geben, die das kann. Einen genauen Termin kann ich leider nicht nennen. Nutze bitte bis dahin PHP5.6, sofern das geht.

Re: Plugin fehlerhaft

Verfasst: 11.02.2019, 11:30
von ole1210
Wie kann das sein? das PHP 5.6 seit dem 31.12. endgültig ausgelaufen ist, daher keinerlei Updates mehr erhält und ein erhebliches Sicherheitsrisiko darstellt, ist doch seit geraumer Zeit bekannt. PHP 5.6 ist keine Option für uns, da es auf dem Server keine derartig veraltete Software mehr gibt.

Re: Plugin fehlerhaft

Verfasst: 11.02.2019, 12:02
von maennchen1.de
Mehr kann ich leider auch nicht sagen.

Re: Plugin fehlerhaft

Verfasst: 12.02.2019, 10:56
von maennchen1.de
Wir haben dein Problem mit PHP 7.1 nicht reproduzieren können. Könntest du bitte genauere Angaben machen? Zum Beispiel: wie du den Fehler bemerkt hast, mit welchem Programm du getestet hast, etc.
In deinem Text ist die Rede von Screenshots und Logfile. Könntest du die bitte mit anhängen?

Re: Plugin fehlerhaft

Verfasst: 06.03.2019, 12:13
von ole1210
Bemerkt habe ich den Fehler dadurch, das ich Test-eMails ohne eingefügte Bilder erhalten habe. Sowohl in Outlook als auch im gmail-Web-Client.

Die Logdateien kann ich euch gerne per eMail senden, hier öffentlich möchte ich sie nicht hochladen. Welche Adresse darf ich nutzen?

Re: Plugin fehlerhaft

Verfasst: 06.03.2019, 17:05
von maennchen1.de
Die Logdateien kannst du per PN an mich hier im Forum senden. Aber grundlegend enthalten diese keine persönlichen Details, oder? Falls doch, kannst du diese schnell mit einem Editor umbenennnen.

Bitte vergiss auch nicht die Screenshots!
Überprüfe bitte einmal, ob alle Bilder nicht angezeigt werden, oder nur bestimmte. Teste ruhig auch einmal andere Formate oder Bilder von fremden Quellen (testweise, nicht das dein Grafikprogramm irgendwas falsch macht).

Re: Plugin fehlerhaft

Verfasst: 06.03.2019, 23:10
von ole1210
Die selbe Grafik die früher funktioniert hat, funktioniert nun nicht mehr. Die Datei liegt seit Jahren unverändert auf dem Server rum. Ein Fehler auf meiner Seite ist daher auszuschliessen.

Re: Plugin fehlerhaft

Verfasst: 07.03.2019, 09:35
von ThoGoe
Hallo!

Mit welcher php-Version arbeitest du genau (7.0, 7.1, 7.2, ...)? Welche WordPress-Version hast du im Einsatz?

Liebe Grüße

Re: Plugin fehlerhaft

Verfasst: 07.03.2019, 10:19
von maennchen1.de
ole1210 hat geschrieben:
06.03.2019, 23:10
Die selbe Grafik die früher funktioniert hat, funktioniert nun nicht mehr. Die Datei liegt seit Jahren unverändert auf dem Server rum. Ein Fehler auf meiner Seite ist daher auszuschliessen.
Das kann gut sein. Drumherum ändert sich aber einiges. Neben deinem WordPress wird auch der Server und dessen Dienste aktualisiert.
Es ist grundlegend völlig egal, auf wessen Seite der Fehler zu suchen ist. Wir möchten Ihn nur finden und benötigen deine Hilfe, da er bei dir auftritt und bei unserem Testsystem nicht. Deshalb möchte ich dich bitten auf die obigen Fragen einzugehen und dir die entsprechende Zeit für Tests und Antworten zu nehmen.

Re: Plugin fehlerhaft

Verfasst: 07.03.2019, 10:49
von ole1210
Es ist PHP 7.0 im Einsatz sowie das aktuelle WP 5.1

Selbstverständlich ändern sich Dinge. Der Server bekam ein Update von PHP 5.6 auf PHP 7.0. Das ja laut eurer Aussage leider bisher nicht unterstützt wird.

Da ich nicht weiß, welche Bildformate/Größen/etc. und welche Tests euch weiterhelfen, habe ich euch einen Admin-Zugang eingerichtet und per PN gesendet.

Re: Plugin fehlerhaft

Verfasst: 08.03.2019, 08:45
von maennchen1.de
Du musst lediglich von einer anderen Webseite ein Foto mopsen und das in deinen Newsletter packen und einen Testnewsletter an dich versenden.

Re: Plugin fehlerhaft

Verfasst: 08.03.2019, 10:26
von ole1210
Welche Größe darf dieses Bild haben? Lieber jpg oder png? Muss diese Seite auf PHP 7.0 laufen oder doch lieber auf PHP5.6?

Bild ist ja nunmal nicht gleich Bild. Deswegen habe ich euch ja die Admin-Zugangsdaten gegeben, damit ihr da einmal selbst reinschaut.

Re: Plugin fehlerhaft

Verfasst: 08.03.2019, 10:39
von ole1210
Lässt sich nicht vergleichen. Externe Bilder werden 08/15 per <img scr=... eingebunden, interne Bilder bastelt euer System vollkommen um und macht daraus im Quelltest ein <figure class=...

Re: Plugin fehlerhaft

Verfasst: 08.03.2019, 10:49
von maennchen1.de
In deinem Problem geht es doch darum, dass Bilder, die mitgesendet werden, nicht angezeigt werden. Externe Bilder sind doch gar nicht Gegenstand deines Problems?
Mit meinem Test, ein fremdes Bild zu verwenden und es statt deines eigenen Bildes (welches nicht angezeigt wird) zu versenden, sollte ausschließen, dass kein Problem mit deinem Grafikprogramm besteht. Dazu musst du dieses fremde Bild natürlich genauso einbinden, wie die Bilder, die nicht gehen. Dabei kann das Bild JPEG und PNG sein. Wichtig ist nur, dass du es nicht veränderst.

Außerdem ist die Frage noch offen, ob es nur bestimmte Bilder sind, die nicht angezeigt werden, oder alle.