GELÖST [4810, Bug, mittel] Probleme aktuelle Beta 3.7.0.4810

Hier findest du nur Beiträge zu aktuellen Betaversion, von Beta-Testern. Beta, Beta, Beta! :)

Moderatoren: ThoGoe, maennchen1.de

Antworten
robertskiba
Beiträge: 628
Registriert: 25.06.2012, 15:57
Lizenz: wpShopGermany Enterprise

GELÖST [4810, Bug, mittel] Probleme aktuelle Beta 3.7.0.4810

Beitrag von robertskiba » 12.08.2015, 14:23

Hi Leute,


hier einige aktuelle Problem der aktuellen Beta:
  • in der aktuellen Beta (3.7.0.4810) und ich glaube auch in der vorigen Beta werden aktuell in meinem Teststhop die %% Variablen nicht mehr aufgelöst.

    %shopinfo_accountowner% etc.

    %order_onr% %kunde_vname% %kunde_name%

    klappen aktuell nicht.
    Sorry, war mein Fehler. Altes Template! Funktioniert!
  • Außerdem werden beim Auslösen von Testmails über die Debug-Funktion in einer Bestellung (konkret: Kundenmail an Admin senden) das Bestelldatum und die Bestellnummer nicht übergeben.

    Datum ist dann 01.01.1970 00:00:00 und Bestellnummer ist leer.
  • Nach dem Speichern vieler Shop-Optionen wird nichts in die Translations.phtml geschrieben bzw. aktualisiert. z.B. shopinfos etc.
Zuletzt geändert von robertskiba am 14.08.2015, 13:49, insgesamt 1-mal geändert.
---
WPShopGermany Poweruser

Ich unterstütze gerne andere User und Shops bei Problemen im Notfall.
Schreibt mir einfach eine Mail an info@skibamedia.de oder ruft an: +49-2691-8839400.

Gerne stelle ich auch mein Know-How und meine eigenen angepassten Templates gegen Gebühr zur Verfügung und erspare euch viel Arbeit!

robertskiba
Beiträge: 628
Registriert: 25.06.2012, 15:57
Lizenz: wpShopGermany Enterprise

Re: Probleme aktuelle Beta 3.7.0.4810

Beitrag von robertskiba » 13.08.2015, 01:31

Nochmal konkret hier eine Ergänzung:

Diese Variablen werden aktuell nicht korrekt übergeben, wenn man mit "Kundenmail simulieren" arbeitet. Da diese Funktion jedoch das ständige abschicken von Test-Bestellungen erspart und daher unerlässlich ist, wenn man seine Shop-Emails schnell und komfortabel anpassen möchte, wäre es super, wenn das in der nächsten Beta funktionieren würde.

Folgende Variablen haben PRobleme:

- Bestellnummer
- Bestellkommentar
- Das Bestelldatum ist ebenfalls leer und zeigt daher bei Konvertierung den 01.01.1970 an ($this->view['basket']['checkout']['datum'])

Ursprünglich hatte ich noch ein paar mehr gefunden, aber die fallen mir gerade nicht mehr ein.
---
WPShopGermany Poweruser

Ich unterstütze gerne andere User und Shops bei Problemen im Notfall.
Schreibt mir einfach eine Mail an info@skibamedia.de oder ruft an: +49-2691-8839400.

Gerne stelle ich auch mein Know-How und meine eigenen angepassten Templates gegen Gebühr zur Verfügung und erspare euch viel Arbeit!

Benutzeravatar
daschmi
m1.Mitarbeiter
Beiträge: 2377
Registriert: 04.12.2007, 18:23
Lizenz: keine
Kontaktdaten:

Re: Probleme aktuelle Beta 3.7.0.4810

Beitrag von daschmi » 13.08.2015, 07:18

Hi,

Danke für das Feedback.

ich finde die Funktion für die Simulation der Mails auch nützlich und werde alles nochmal für die nächste Version checken.

Grüße

Daschmi

robertskiba
Beiträge: 628
Registriert: 25.06.2012, 15:57
Lizenz: wpShopGermany Enterprise

Re: Probleme aktuelle Beta 3.7.0.4810

Beitrag von robertskiba » 13.08.2015, 11:07

Ja, sie hat mir heute nacht ca. 100 Testbestellungen erspart.
---
WPShopGermany Poweruser

Ich unterstütze gerne andere User und Shops bei Problemen im Notfall.
Schreibt mir einfach eine Mail an info@skibamedia.de oder ruft an: +49-2691-8839400.

Gerne stelle ich auch mein Know-How und meine eigenen angepassten Templates gegen Gebühr zur Verfügung und erspare euch viel Arbeit!

robertskiba
Beiträge: 628
Registriert: 25.06.2012, 15:57
Lizenz: wpShopGermany Enterprise

Re: Probleme aktuelle Beta 3.7.0.4810

Beitrag von robertskiba » 13.08.2015, 11:10

robertskiba hat geschrieben:Hi Leute,


hier einige aktuelle Problem der aktuellen Beta:
  • in der aktuellen Beta (3.7.0.4810) und ich glaube auch in der vorigen Beta werden aktuell in meinem Teststhop die %% Variablen nicht mehr aufgelöst.

    %shopinfo_accountowner% etc.

    %order_onr% %kunde_vname% %kunde_name%

    klappen aktuell nicht.
Hier solltet ihr in diesem Zusammenhang mal das Aktivitäten-Journal der Bestellungen überprüfen. Hier soll ja eigentlich 1:1 die Mail gespeichert werden, die an den Kunden versendet wurde. Jedoch werden manche %%-Variablen nicht ordentlich gerendert, obwohl der Kunde sie in der Mail richtig gerendert erhält.
---
WPShopGermany Poweruser

Ich unterstütze gerne andere User und Shops bei Problemen im Notfall.
Schreibt mir einfach eine Mail an info@skibamedia.de oder ruft an: +49-2691-8839400.

Gerne stelle ich auch mein Know-How und meine eigenen angepassten Templates gegen Gebühr zur Verfügung und erspare euch viel Arbeit!

Benutzeravatar
daschmi
m1.Mitarbeiter
Beiträge: 2377
Registriert: 04.12.2007, 18:23
Lizenz: keine
Kontaktdaten:

Re: Probleme aktuelle Beta 3.7.0.4810

Beitrag von daschmi » 13.08.2015, 14:06

Hi,

- Das Protokoll sollte nun den Text enthalten der auch versendet wurde.
- Bestelldatum / Nr sollten in der Debug Mail enthalten sein
- ShopInfo sind übersetzbar

Aktuelle Beta ist erstellt. http://wpshopgermany.maennchen1.de/2013 ... ads-laden/

Grüße

Daniel

robertskiba
Beiträge: 628
Registriert: 25.06.2012, 15:57
Lizenz: wpShopGermany Enterprise

Re: Probleme aktuelle Beta 3.7.0.4810

Beitrag von robertskiba » 13.08.2015, 14:09

In der Beta von 13:00h trat folgendes auf, dass in der Beta von jetzt gerade eben immer noch auftritt:

Code: Alles auswählen

Warning: Cannot modify header information - headers already sent by (output started at /is/htdocs/wp12154433_K8Y8TEV3R1/rfz/wp-content/plugins/all-in-one-seo-pack/aioseop_class.php:1513) in /is/htdocs/wp12154433_K8Y8TEV3R1/rfz/wp-content/plugins/wpshopgermany/controller/wpsg_SystemController.class.php on line 2
passiert direkt im WArenkorb bei ?wpsg_checkout
---
WPShopGermany Poweruser

Ich unterstütze gerne andere User und Shops bei Problemen im Notfall.
Schreibt mir einfach eine Mail an info@skibamedia.de oder ruft an: +49-2691-8839400.

Gerne stelle ich auch mein Know-How und meine eigenen angepassten Templates gegen Gebühr zur Verfügung und erspare euch viel Arbeit!

Benutzeravatar
daschmi
m1.Mitarbeiter
Beiträge: 2377
Registriert: 04.12.2007, 18:23
Lizenz: keine
Kontaktdaten:

Re: Probleme aktuelle Beta 3.7.0.4810

Beitrag von daschmi » 13.08.2015, 14:23

Hi,

also die Meldung sagt aus, dass der Response Header nicht mehr verändert werden kann. (Der Shop will die Anfrage umleiten)

Der Grund ist eine Ausgabe aus dem Plugin All-In-One-Seo-Pack. Ich habe das Plugin jetzt mal Testweise bei mir installiert und habe das Problem nicht. Eventuell ist es irgendeine Konfiguration am All-In-One-Seo-Pack.

Grüße

Daschmi

robertskiba
Beiträge: 628
Registriert: 25.06.2012, 15:57
Lizenz: wpShopGermany Enterprise

Re: Probleme aktuelle Beta 3.7.0.4810

Beitrag von robertskiba » 13.08.2015, 14:24

Es tritt erst seit deiner 14:00h-Beta auf, vorher war alles OK. habe dir eine PN geschickt.
---
WPShopGermany Poweruser

Ich unterstütze gerne andere User und Shops bei Problemen im Notfall.
Schreibt mir einfach eine Mail an info@skibamedia.de oder ruft an: +49-2691-8839400.

Gerne stelle ich auch mein Know-How und meine eigenen angepassten Templates gegen Gebühr zur Verfügung und erspare euch viel Arbeit!

Benutzeravatar
daschmi
m1.Mitarbeiter
Beiträge: 2377
Registriert: 04.12.2007, 18:23
Lizenz: keine
Kontaktdaten:

Re: Probleme aktuelle Beta 3.7.0.4810

Beitrag von daschmi » 13.08.2015, 14:36

Hi,

das kann ich mir eigentlich nicht vorstellen. Also die Stelle aus deiner PN ist die Stelle wo unser Shop den Header sendet um die Anfrage umzuleiten. Das ist alles gut so.
Es darf vorher nur keine Ausgabe erfolgen, da dies den Header abschließt und sendet.

Ich kann das Problem auch leider nicht nachstellen :(

Grüße

Daschmi

robertskiba
Beiträge: 628
Registriert: 25.06.2012, 15:57
Lizenz: wpShopGermany Enterprise

Re: Probleme aktuelle Beta 3.7.0.4810

Beitrag von robertskiba » 13.08.2015, 14:59

Ich konnte das Problem nachvollziehen, es hat mit den Produktvariablen zu tun.

Ich habe in meinem Testshop eine Produktvariable "Name Mitfahrer" die Pflicht ist.

Das Problem tritt nur auf wenn du einen Artikel mit einer Produktvariable in den Warenkorb legst, keinen Eintrag (trotz Pflicht) machst und dann auf "zur Kasse" klickst.

Normalerweise soll ja dann die Fehlermeldung "Bitte im Feld "Name des Mitfahrers" eine Angabe machen!" (oder ähnlich) kommen.

Vielleicht kannst du ja damit eingrenzen, an welcher Datei in diesem Kontext du gearbeitet hast. Diese Header-Meldungen kommen ja oft schon wegen einem falsch gesetzten Leerzeichen am Anfang einer Datei vor dem <?php

(Wenn man Korrekt einen Namen eingibt, funktioniert es übrigens einwandfrei, also irgendwo im Bereich der Prüfung MItfahrername müsste das Problem sein)
---
WPShopGermany Poweruser

Ich unterstütze gerne andere User und Shops bei Problemen im Notfall.
Schreibt mir einfach eine Mail an info@skibamedia.de oder ruft an: +49-2691-8839400.

Gerne stelle ich auch mein Know-How und meine eigenen angepassten Templates gegen Gebühr zur Verfügung und erspare euch viel Arbeit!

Benutzeravatar
daschmi
m1.Mitarbeiter
Beiträge: 2377
Registriert: 04.12.2007, 18:23
Lizenz: keine
Kontaktdaten:

Re: Probleme aktuelle Beta 3.7.0.4810

Beitrag von daschmi » 14.08.2015, 07:49

Hi Robert,

danke für die detaillierte Fehlerbeschreibung. Damit konnte ich es nachstellen und beheben.

Testversion 3.7.0.4819 ist erstellt.

Grüße

Daschmi

Antworten