FIXED: Nach Update von 3.9.1 auf Beta .5051 keine Module aktiv

Hier findest du nur Beiträge zu aktuellen Betaversion, von Beta-Testern. Beta, Beta, Beta! :)

Moderatoren: ThoGoe, maennchen1.de

Antworten
Benutzeravatar
Frixi
Beiträge: 1005
Registriert: 29.10.2014, 16:25
Lizenz: keine

FIXED: Nach Update von 3.9.1 auf Beta .5051 keine Module aktiv

Beitrag von Frixi » 28.11.2015, 15:07

Hallo maennchen1,

ich habe den Thread komplett umgeschrieben, falls noch eine alte Kopie zu sehen war, da sich das Fehlerbild geändert hat.

Ich habe sowohl in meiner Testumgebung, als auch auf meiner produktiven Seite (natürlich mit Backup) das Beta-Update .5051 durchgeführt und bei beiden feststellen müssen, dass nach dem Update die zusätzlichen gekauften Module (Rechnung, PayPal PLUS, Statistik) a) nicht geladen werden, und b) auch nicht nachgeladen/aktualisiert werden können.
Screenshot (2015-11-28 14.08.03).png
Beim Versuch, die Module manuell über "installiere 3.9.1.5051" zu aktualisieren führt zu einer weißen Seite - ich weiß, dass das eine unterdrückte Fehlermeldung von WP ist, ich finde nur gerade nicht, wie ich die Fehlermeldung anzeigen lassen kann. Ich trage das noch nach, wenn ich es denn finde...

Das gilt übrigens auch für alle anderen Module, die vorher noch nicht installiert waren.

Danke im voraus für eure freundliche Hilfe.

VG, Frixi.

PS: Sorry, hätte eigentlich ins Unterforum für Betas gesollt...
Zuletzt geändert von Frixi am 22.01.2016, 00:16, insgesamt 2-mal geändert.
WP V.4.9.6 - WPSG V.3.12.7 - Shop: friXtender.de/shop

Benutzeravatar
Frixi
Beiträge: 1005
Registriert: 29.10.2014, 16:25
Lizenz: keine

Re: Nach Update von 3.9.1 auf Beta .5051 keine Module aktiv

Beitrag von Frixi » 29.11.2015, 16:44

Da brat mir doch einer einen Storch: ich habe das Update jetzt bestimmt 3 oder 4x probiert (mit immer wiederhergestellten Daten), jedes Mal mit dem og. Fehler. Nun habe ich den Debug-Modus von WP aktiviert - und damit hat es nun funktioniert... wie kann das denn sein?

Aber ich habe nun einige Probleme mit dem neuen PayPal PLUS Modul, aber dazu mehr in dem verlinkten Thread.

EDIT: Obwohl das Update durchgeführt wurde und irgendwann auch die Module mit upgedatet wurden, kann ich keine Module nachinstallieren, es kommt der weiße Bildschirm, hier die debug.log Datei:

Code: Alles auswählen

[29-Nov-2015 16:21:49 UTC] PHP Strict Standards:  Declaration of wpsg_mod_paypalapi::order_view_afterpayment() should be compatible with wpsg_mod_basic::order_view_afterpayment(&$order_id) in /var/www/vhosts/hosting4283.af929.netcup.net/httpdocs/wp-test/wp-content/plugins/wpshopgermany/mods/wpsg_mod_paypalapi.class.php on line 2
[29-Nov-2015 16:21:49 UTC] PHP Notice:  Die verwendete Konstruktoren-Methode für WP_Widget ist seit Version 4.3.0 <strong>veraltet</strong>! Verwende stattdessen <pre>__construct()</pre>. in /var/www/vhosts/hosting4283.af929.netcup.net/httpdocs/wp-test/wp-includes/functions.php on line 3457
[29-Nov-2015 16:21:49 UTC] PHP Notice:  Die verwendete Konstruktoren-Methode für WP_Widget ist seit Version 4.3.0 <strong>veraltet</strong>! Verwende stattdessen <pre>__construct()</pre>. in /var/www/vhosts/hosting4283.af929.netcup.net/httpdocs/wp-test/wp-includes/functions.php on line 3457
[29-Nov-2015 16:21:49 UTC] PHP Strict Standards:  Declaration of wpng_mod_bounce::abonnent_edit() should be compatible with wpng_mod_basic::abonnent_edit(&$abo) in /var/www/vhosts/hosting4283.af929.netcup.net/httpdocs/wp-test/wp-content/plugins/wpnewslettergermany/mods/wpng_mod_bounce.class.php on line 53
[29-Nov-2015 16:21:49 UTC] PHP Strict Standards:  Declaration of wpng_mod_userfields::abonnent_edit() should be compatible with wpng_mod_basic::abonnent_edit(&$abo) in /var/www/vhosts/hosting4283.af929.netcup.net/httpdocs/wp-test/wp-content/plugins/wpnewslettergermany/mods/wpng_mod_userfields.class.php on line 69
[29-Nov-2015 16:21:49 UTC] PHP Fatal error:  Call to undefined function installModul() in /var/www/vhosts/hosting4283.af929.netcup.net/httpdocs/wp-test/wp-content/plugins/wpshopgermany/mods/wpsg_mod_basic.class.php on line 2
WP V.4.9.6 - WPSG V.3.12.7 - Shop: friXtender.de/shop

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15979
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Nach Update von 3.9.1 auf Beta .5051 keine Module aktiv

Beitrag von maennchen1.de » 30.11.2015, 09:35

Mit Version 3.9.1.5052 ist nachfolgende Fehlermeldung verschwunden und Modul sollten sich problemfrei wieder installieren lassen. Danke für die Meldung!

Code: Alles auswählen

[29-Nov-2015 16:21:49 UTC] PHP Fatal error:  Call to undefined function installModul() in /var/www/vhosts/hosting4283.af929.netcup.net/httpdocs/wp-test/wp-content/plugins/wpshopgermany/mods/wpsg_mod_basic.class.php on line 2
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Antworten