Versandkostenfrei

Wir starten bald mit wpShopGermany4. Alle Fragen dazu dürfen hier gestellt werden.
Alle Informationen dazu gibt es im Blog: https://beta4.wpshopgermany.de

Moderatoren: ThoGoe, maennchen1.de

Antworten
k-rasch
Beiträge: 155
Registriert: 19.10.2012, 23:37
Lizenz: wpShopGermany Pro

Versandkostenfrei

Beitrag von k-rasch » 13.10.2017, 18:50

Hallo, ich habe einen Shop nur für Downloadprodkte. Hier ist alles versandkostenfrei. Ich habe "Versandkostenfrei" in der Modulverwaltung aktiviert und im Produkt zur "Auswahl" hinterlegt. Im Warenkorb steht nun die Angabe "Versandkosten können nicht angezeigt werden, bitte manuell nachfragen". "Versandkostenfrei" wird nirgends angezeigt und kann nicht ausgewählt werden.

Wenn ich "Downlodprodukte" aktiviere, dann wird bei "Versand per Email" im Produkt aktiviert, diese Versandart ebenfalls nicht angezeigt.

Wenn ich nuin "Versandarten" aktiviere und zusätzlich "Post" im Produkt, dann wird nur "Post" im Warenkorb zur Auswahl angezeigt, "Versand per Email" und "versandkostenfrei" wird aber immer noch nicht angezeigt. Ich vermute, das ist nicht so gedacht. Grüße Klaus

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2687
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Versandkostenfrei

Beitrag von ThoGoe » 16.10.2017, 09:31

Hallo!

Wie bist du genau vorgegangen? Ich habe das Modul "Downloadprodukte" und das Modul "Versandkostenfrei" aktiviert und ein DownloadProdukt angelegt.
Im Produkt wird nun "Versandkostenfrei" als Versandart angehakt. Bei einem Downloadprodukt kannst du lediglich die Versandart "Versand per Mail" aktivieren, da diese Versandart kostenfrei ist. Damit würde das Modul "Versandkostenfrei" wegfallen.

Liebe Grüße
Dateianhänge
Versand-von-DownloadProdukten.png
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

k-rasch
Beiträge: 155
Registriert: 19.10.2012, 23:37
Lizenz: wpShopGermany Pro

Re: Versandkostenfrei

Beitrag von k-rasch » 16.10.2017, 20:25

Hallo, nun habe ich noch ein normales Produkt angelegt mit "Versandkostenfrei". Ja, das funktioniert. Dann habe ich ein Download-Produkt angelegt und einen Download damit verknüpft. "Versand per Email" ? Ja das funktioniert auch (aber nur mit verknüpftem Download). War also falscher Alarm. Beste Wünsche Klaus

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2687
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Versandkostenfrei

Beitrag von ThoGoe » 17.10.2017, 07:19

Hallo!

Es freut mich, dass alles soweit funktioniert. Danke für die Rückmeldung!

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

k-rasch
Beiträge: 155
Registriert: 19.10.2012, 23:37
Lizenz: wpShopGermany Pro

Re: Versandkostenfrei

Beitrag von k-rasch » 04.11.2017, 13:27

Hallo,

warum habe ich eigentlich immer die selben Probleme mit WPSG? Also ich habe ein Abo-Produkt angelegt, ich habe keine Versandarten für das Abo, es ist versandkostenfrei. Aktivierte Module in diesem Shop sind also: Aboprodukte, Versandkostenfrei, Produktartikel. Wenn ich nun zur Kasse gehen will geht es nicht weiter, da ich keine Versandart konfigurieren kann: "Keine Versandart möglich / Bitte manuell anfragen". Im Aboprodukt habe ich versandkostenfrei angeklickt, was auch die einzig mögliche Einstellung ist, da ich nix anderes aktiviert habe. Was mache ich falsch?

In dem Zusammenhang verstehe ich auch die Einstellung "Versandkosten bei 0 nicht anzeigen" nicht, die ich aktiviert habe. Versandkostenfrei ist 0, ich würde das dann so verstehen, dass dann da nix angezeigt wird...
VG
Zuletzt geändert von k-rasch am 04.11.2017, 13:59, insgesamt 1-mal geändert.

k-rasch
Beiträge: 155
Registriert: 19.10.2012, 23:37
Lizenz: wpShopGermany Pro

Re: Versandkostenfrei

Beitrag von k-rasch » 04.11.2017, 13:50

Hallo, nachdem ich den oben beschriebenen Fehler gefunden hatte, habe ich bis auf das WPSG-Beispiel-Produkt alle anderen angelegten Produkte gelöscht (darunter auch eine WPML-Übersetzung) und versuche nun nochmal ein Abo-Produkt anzulegen. Jetzt geht aber gar nichts mehr: SYSTEMFEHLER:Call to a member function getProductName() on null. ... Nun dann teste ich an einem anderen Tag, für heute reichts.

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2687
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Versandkostenfrei

Beitrag von ThoGoe » 06.11.2017, 10:32

Hallo!

Bitte schau einmal im nebenstehenden Thread. Dort wird das besagte Problem bereits bearbeitet.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

k-rasch
Beiträge: 155
Registriert: 19.10.2012, 23:37
Lizenz: wpShopGermany Pro

Re: Versandkostenfrei

Beitrag von k-rasch » 11.11.2017, 00:17

Hallo, täglich grüßt das Murmeltier: ich möchte -mittlerweile in Version 4.0- (endlich) ein Aboprodukt anlegen. Da in diesem Shop nur Abos zu haben sind habe ich nur "versandkostenfrei" aktiviert, keine Versandarten. Andere als "versandkostenfrei" gibt es nicht in der Auswahl. Im Warenkorb erscheint leider nach wie vor: "Keine Versandart möglich / Bitte manuell anfragen". Aufgrund der Einstellungen muss aber eigentlich "versandkostenfrei" im Warenkorb angezeigt werden. (Merkwürdig ist noch, dass in der Version 4.0 in der Modulverwaltung nur Module 3.99.12 angezeigt werden. Vielleicht liegt es daran?) Schönes Wochenende

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2687
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Versandkostenfrei

Beitrag von ThoGoe » 13.11.2017, 09:34

Hallo!

Bietest du Downloadprodukte im gleichnamigen wpShopGermany4-Modul an? Bitte beachte, dass in diesem Modul die Versandart hinterlegt werden sollte.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

k-rasch
Beiträge: 155
Registriert: 19.10.2012, 23:37
Lizenz: wpShopGermany Pro

Re: Versandkostenfrei

Beitrag von k-rasch » 13.11.2017, 20:55

Hallo, ich schrieb: "ich habe einen Shop nur für Downloadprodukte. Hier ist alles versandkostenfrei." Leider war das von mir falsch, sorry. Ich habe einen Shop für Abo-Produkte (Mitgliedschaften). Hier ist alles versandkostenfrei. Es ist also kein Downloadprodukt im Shop, auch nicht aktiviert. Die Versandart für ein Mitglieds-Abo sollte versandkostenfrei sein, aber "versandkostenfrei" funktioniert nicht. Ich hätte aber gerne, dass "versandkostenfrei" angezeigt wird und der Kunde aus-checken kann. VG

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15979
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Versandkostenfrei

Beitrag von maennchen1.de » 13.11.2017, 21:07

Das Modul ist zu unflexibel, da es für einen anderen Einsatz gedacht war.
Nutze einfach das normale Modul Versand- und Lieferart und stelle dort einen neuen Versender "versandkostenfrei" mit dem Schlüssel "0" an. Dann dürfte alles os funktionieren, wie du möchtest.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

k-rasch
Beiträge: 155
Registriert: 19.10.2012, 23:37
Lizenz: wpShopGermany Pro

Re: Versandkostenfrei

Beitrag von k-rasch » 15.11.2017, 13:02

Hallo, ich bin nun so vorgegangen: das normale Modul Versand- und Lieferart genutzt und dort einen neuen Versender "versandkostenfrei" mit dem Schlüssel "0" eingestellt und das Ergebnis ist: "Keine Versandart möglich / Bitte manuell anfragen". Und der Kunde kommt nicht zur Kasse. Richtig sein sollte: "versandkostenfrei".

"Das Modul ist zu unflexibel, da es für einen anderen Einsatz gedacht war." Wie soll ich das Modul den einsetzen? Ich möchte ein versandkostenfreies Abo anlegen. Es geht nicht über "Versandkostenfrei" und es geht nicht über "Versand- und Lieferart".

Es scheint aber noch ein Problem zu geben: ich benutze das Modul Produktartikel. Ich kann nur das voreingestellte Demoprodukt öffnen. Die Produkte, die ich neu anlege führen ins nichts: 404 Seite nicht gefunden. Egal ob Abo-Produkt oder normales Produkt.

Ich habe alles auf die neue 4.0 Lizenz aktualisiert. Und ich habe verschiedene Themes erprobt, geht nicht.

VG

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15979
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Versandkostenfrei

Beitrag von maennchen1.de » 15.11.2017, 14:55

Hast du bei dem entsprechenden Produkt im Backend eine bestimmte Versandart ausgewählt?
Falls nicht, poste hier bitte einmal die Einstellungen des Moduls Versandarten und deines Produktes.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

k-rasch
Beiträge: 155
Registriert: 19.10.2012, 23:37
Lizenz: wpShopGermany Pro

Re: Versandkostenfrei

Beitrag von k-rasch » 15.11.2017, 15:54

Hallo,
in der Modulverwaltung sind aktiviert: Aboprodukte, Produktartikel, Statistik, Versandarten und diverse Zahlungsarten. Alle Module sind auf Version 4.0 aktualisiert. Im "Probe-Produkt" habe ich nicht viel gemacht: einen Namen vergeben, nur 1x mit Menge 1, der Link zur Produktseite ist korrekt aufgebaut (es handelt sich um eine Subdomain). Url-Benachrichtigung habe ich nichts eingetragen, Texte und Bewertungen sind unbearbeitet, Preis/Steuer: Bruttopreis: 60 EUR 7% MWSt. Erlaubte Zahlungsarten. alle, erlaubte Versandarten: versandkostenfrei. Dann nur noch in Abo eingetragen: Aboprodukt ja, Anzahl beschränken ja, Anzahl 1, Abo-Preis 60 EUR, Abo Dauer 30. (Ich bemerke, dass im Produkt allgemein schon der Preis und die Mengenbeschränkung angegeben wurden, also hier was doppelt ist).

Das Versandmodul ist so konfiguriert: versandkostenfrei, aktiv ja, Hinweistext keine Angaben, Grundlage Bestellwert, Versandzonen alle, Kostenschlüssel 0, Steuer Nullsatz.

Ich habe schon ein bisschen rumgespielt, alle möglichen Variationen führen zu dem Ergebnis: Seite nicht gefunden. Auch wenn ich das Teil per Post versende, das Abo deaktiviere, ein anderes Theme wähle (2017), immer führt der Link ins Nichts.

Wenn ich nun noch das Modul Produktartikel deaktiviere, dann bleibt der Link im Produkt, trotz Speichern des Produkts, ein Produktartikel-Link.... und führt wieder ins Nichts. Kann es sein, dass das Modul Produktartikel in der Version 4.0 noch ein Problem hat??

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15979
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Versandkostenfrei

Beitrag von maennchen1.de » 15.11.2017, 16:06

Welcher Link führt ins nichts? Ich denke es gibt ein Problem mit den Versandarten?
Sofern du mehrere unterschiedliche Probleme hast, lass uns bitte erst eins lösen und danach das andere. Das kannst du dann bitte in einen neuen Thread posten.

Das du alles richtig eingetragen hast glaube ich dir. Mittels einem vollständigen Screenshot können wir uns aber ein Bild machen, ob es Elemente gibt, die du gar nicht berücksichtigt hast, weil du der Meinung bist, dass es nicht erwähnenswert ist. Mach bitte die geforderten Screenshots. Danke!
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Antworten