Update / Neue Instalation

Allgemeine Fragen zur Verwendung von wpShopGermany4 und dessen integrierten Modulen

Moderatoren: ThoGoe, maennchen1.de

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2584
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Update / Neue Instalation

Beitrag von ThoGoe » 09.04.2018, 09:07

Hallo!

Handelt es sich um die Subinstanz, auf der bereits der 3er-Shop lief? Bei der Umstellung auf Version 4 hast du den Konverter durchlaufen lassen? Nutze bitte vorerst php-Version 7.0. Unter Umständen können mit Version 7.1 und 7.2 in einer Multiblogumgebung noch Problemen auftreten.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

karlstatt
Beiträge: 27
Registriert: 12.04.2012, 13:40
Lizenz: wpShopGermany Enterprise

Re: Update / Neue Instalation

Beitrag von karlstatt » 09.04.2018, 17:24

Der Konverter ist durchgelaufen und eine Änderung auf PHP 7.0.29 bewirkt leider keine Veränderung, auch nicht eine testweise Änderung auf PHP 5.6.x

karlstatt
Beiträge: 27
Registriert: 12.04.2012, 13:40
Lizenz: wpShopGermany Enterprise

Re: Update / Neue Instalation

Beitrag von karlstatt » 10.04.2018, 09:24

Bei Bedarf kann ich gerne Zugangsdaten für WP und FTP stellen.

karlstatt
Beiträge: 27
Registriert: 12.04.2012, 13:40
Lizenz: wpShopGermany Enterprise

Re: Update / Neue Instalation

Beitrag von karlstatt » 11.04.2018, 15:20

Ich habe noch mehrere Dinge probiert, u.a. die netzweite Freigabe - dann aber kommt bei den Subwebs die Meldung "Allgemeiner Fehler: Call to a member function add_cap() on null". Ich wäre dankbar für Hilfe, denn sämtliche Subinstanzen laufen seit dem Update ohne Shop. Auf der Hauptinstanz läuft er einwandfrei.

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2584
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Update / Neue Instalation

Beitrag von ThoGoe » 12.04.2018, 14:29

Hallo!

Es handelt sich hierbei um unterschiedliche php-Versionen. Die Hauptdomain läuft mit php 7.0.29 und die Subdomains laufen mit php 5.3.10. Bitte stelle beides auf php 7.0 um.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

karlstatt
Beiträge: 27
Registriert: 12.04.2012, 13:40
Lizenz: wpShopGermany Enterprise

Re: Update / Neue Instalation

Beitrag von karlstatt » 12.04.2018, 15:04

Hallo,

danke für die Antwort. Dass das etwas ausmachen würde, hätte ich im Leben nicht gedacht, da die gemappten Domains ja gar keine eigenen PHP-Daten haben. Allerdings ändert das nichts am Problem, sondern nur die Fehlermeldung:

Allgemeiner Fehler: Call to a member function add_cap() on null

Das Problem selbst bleibt, dass die Subinstanzen das Shop-Plugin nicht installieren können.

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2584
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Update / Neue Instalation

Beitrag von ThoGoe » 13.04.2018, 07:43

Hallo!

Bitte wirf einen Blick / lass deinen Provider einen Blick auf deine php-Einstellungen werfen. Da deine Subdomains mit php 5.3.10 laufen, ist das jenseits der Mindestanforderungen für den wpShopGermany.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

karlstatt
Beiträge: 27
Registriert: 12.04.2012, 13:40
Lizenz: wpShopGermany Enterprise

Re: Update / Neue Instalation

Beitrag von karlstatt » 13.04.2018, 11:01

Die Installation läuft unter Plesk Onyx, dort habe ich sämtliche Domains auf PHP 7.0.29 umgestellt, ausgeführt als FastCGI-Anwendung (eine andere Option habe ich auf diesem etwas älteren Server nicht).

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2584
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Update / Neue Instalation

Beitrag von ThoGoe » 13.04.2018, 11:47

Hallo!

Hast du noch andere Domains, die auf den gleichen Ordner zeigen? Die haben eventuell unterschiedliche php-Versionen.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

karlstatt
Beiträge: 27
Registriert: 12.04.2012, 13:40
Lizenz: wpShopGermany Enterprise

Re: Update / Neue Instalation

Beitrag von karlstatt » 13.04.2018, 12:40

ThoGoe hat geschrieben:Hast du noch andere Domains, die auf den gleichen Ordner zeigen? Die haben eventuell unterschiedliche php-Versionen.
Nein. Ich habe sogar sämtliche Domains auf dem Server bei der Gelegenheit mal durchgesehen und aktualisiert (bis auf eine, die dann zickt), aber das sind alles getrennte Abonnements und haben mit dem Kunden gar nichts zu tun.

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2584
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Update / Neue Instalation

Beitrag von ThoGoe » 13.04.2018, 13:19

Hallo!

Ich würde dich bitten, einmal deinen Provider anzufragen, ob er die php-Versionen angleichen könnte.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

karlstatt
Beiträge: 27
Registriert: 12.04.2012, 13:40
Lizenz: wpShopGermany Enterprise

Re: Update / Neue Instalation

Beitrag von karlstatt » 13.04.2018, 14:15

Was meinst Du mit angleichen? Unterschiedliche PHP-Versionen kann man bei Plesk für jede Domain wählen. Sämtliche Domains dieser Installation haben die folgende Einstellung:
SNAG-0010.jpg
SNAG-0011.jpg

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15820
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Update / Neue Instalation

Beitrag von maennchen1.de » 13.04.2018, 14:42

Wenn die PHP Version jetzt auch auf den anderen Domains größer als 5.3 ist (z.B. PHP 7), dann solltest du dort auch das Plugin aktivieren können. Hast du das schon einmal probiert?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

karlstatt
Beiträge: 27
Registriert: 12.04.2012, 13:40
Lizenz: wpShopGermany Enterprise

Re: Update / Neue Instalation

Beitrag von karlstatt » 13.04.2018, 14:50

maennchen1.de hat geschrieben:Wenn die PHP Version jetzt auch auf den anderen Domains größer als 5.3 ist (z.B. PHP 7), dann solltest du dort auch das Plugin aktivieren können. Hast du das schon einmal probiert?
Selbstverständlich. Es ändert sich nur die Fehlermeldung in: "Allgemeiner Fehler: Call to a member function add_cap() on null"

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15820
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Update / Neue Instalation

Beitrag von maennchen1.de » 13.04.2018, 15:58

Könntest du bitte von der entsprechenden Stelle einen Screenshot machen? Danke!
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Antworten