Produkteinstellungen funktionieren nicht

Allgemeine Fragen zur Verwendung von wpShopGermany4 und dessen integrierten Modulen

Moderatoren: ThoGoe, maennchen1.de

Holz
Beiträge: 89
Registriert: 26.02.2013, 18:29
Lizenz: wpShopGermany Pro

Re: Produkteinstellungen funktionieren nicht

Beitrag von Holz » 22.02.2018, 18:43

Hallo,
ich kann ja verstehen, daß Ihr aufgrund der vielen Probleme bei der Umstellung überlastet seid. Aber offensichtlich habt Ihr mein Problem immer noch nicht verstanden.
Es geht um genau das Problem, das hier in diesem Thread beschrieben ist:
" Und zwar fehlen mir die Einstellungsmöglichkeiten bei den Modulen bzw Einstelloptionen: "Versand-Zahlungsarten, Produktbilder, Kategorie-Artikel, Produktattribute, Produktvarianten, Statistik". Anstatt Einstellmöglichkeiten, sehe ich nur eine leere Fläche.. Die ersten vier Einstellungsmöglichkeiten in der Produktverwaltung funktionieren." Sh ganz oben.
Ihr habt dann empfohlen, auf php 7.1 umzustellen. Das habe ich getan (vorher hatte ich 7.0). Das Problem ist nicht behoben.

Was soll ich nun tun?

Gruß

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16015
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Produkteinstellungen funktionieren nicht

Beitrag von maennchen1.de » 22.02.2018, 22:58

Danke für dein Verständnis, aber es gibt nicht viele Probleme und wir sind auch nicht überlastet.
Du hast in deinem Anhang die von mir zitierte Fehlermeldung gepostet. Besteht denn dieser Fehler noch?

Schau mal unter „Konfiguration > Über“. Dort steht die PHP Version, welche wpShopGermany nutzt.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Holz
Beiträge: 89
Registriert: 26.02.2013, 18:29
Lizenz: wpShopGermany Pro

Re: Produkteinstellungen funktionieren nicht

Beitrag von Holz » 23.02.2018, 14:41

Hallo,
bei "Über" steht PHP-Version 7.1.13

Es gibt immer noch den Fehler, daß ich in der Produktbearbeitung nur "Allgemein"; "Texte" und "Preis/Steuer" anklicken kann.
Die Button "Versand/Zahlarten"; "Produktbilder"; "Produktgruppen" und "Produktvarianten" zeigen nichts an.
Im Frontend habe ich nun auch festgestellt, daß es bei den Produkten keine Auswahlmöglichkeiten mehr gibt.

Was kann ich nun tun?

Gruß

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16015
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Produkteinstellungen funktionieren nicht

Beitrag von maennchen1.de » 23.02.2018, 16:32

Gehe bitte einmal diese Schritte durch, um den Fehler einzugrenzen:
viewtopic.php?f=24&t=8934
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Holz
Beiträge: 89
Registriert: 26.02.2013, 18:29
Lizenz: wpShopGermany Pro

Re: Produkteinstellungen funktionieren nicht

Beitrag von Holz » 27.02.2018, 14:38

Hallo,
ich habe alle Punkte der Liste abgearbeitet, doch beide Fehler sind immer noch da.
Es kommt auch keine Fehlermeldung im debug-Modus.

Was kann ich nun tun?

Gruß

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16015
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Produkteinstellungen funktionieren nicht

Beitrag von maennchen1.de » 27.02.2018, 18:33

Beschreibe bitte, wie genau du beim Update vorgegangen bist.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Petra
Beiträge: 77
Registriert: 19.01.2017, 23:06
Lizenz: wpShopGermany Pro

Re: Produkteinstellungen funktionieren nicht

Beitrag von Petra » 27.02.2018, 22:08

Hallo Holz,

das Problem hatte ich auch. Ich habe dann das Modul "Staffelpreise" deaktiviert und konnte danach die einzelnen Punkte wieder beim jeweiligen Produkt auswählen. Vielleicht hilft dir das ja weiter?

Liebe Grüße
Petra

Holz
Beiträge: 89
Registriert: 26.02.2013, 18:29
Lizenz: wpShopGermany Pro

Re: Produkteinstellungen funktionieren nicht

Beitrag von Holz » 28.02.2018, 16:48

Hallo,
vielen Dank Petra, ich habe nun auch das Modul Staffelpreise deaktiviert und komme ich auch in die Produktbearbeitung.
Allerdings sind immer noch die Varianten verschwunden. Wenn ich in der Produktbearbeitung auf Produktvarianten klicke, könnte ich zwar neue Varianten anlegen, aber die ganzen Varianten, die bei den vielen Artikeln bereits angelegt waren, sind nicht mehr da. Wie bekomme ich die wieder? Was wäre Wahnsinn, wenn ich die alle neu anlegen müßte. Geschätzt mind. 60 Stunden Arbeit.

Wie bin ich beim Update vorgegangen? Genau nach Anleitung:
Zuerst habe ich bei Strato die Systemanforderungen geklärt. Ein netter Mitarbeiter hat alles geprüft und die nicht passenden PHP-Einstellungen habe ich dann mit einer php.ini-Datei geändert. Dazu möchte ich gleich einfügen, dann ich nach dem Update die Einstellungen geprüft habe (sh. oben) und feststellte, daß upload_ma_filesize nicht 40M sondern nur 36M war. Das habe ich inzwischen aber auch geändert. Bei "register_globals" zeigt es kein "Off" aber auch kein "On". Der Strato-Mitarbeiter sagte mit, es wäre "off". Ich habe versucht, mit der php.ini eine "Off" einzutragen, funktioniert aber nicht.

Nachdem ich die Daten gesichert hatte, habe ich wie beschrieben, auf der Plugin-Seite wpShopGermany deaktiviert und mit FileZilla im FTP-Zugriff den Ordner "wpshopgermany" aus wp-content/plugins/ entfernt.
Dann habe ich die 4er Version in wp-content/plugins hochgeladen.
Als ich dann in der Pluginverwaltung aktivieren wollte, kam zunächst eine Fehlermeldung. Da stand aber vorher noch "Version 3.12.5". Nachdem die Seite neu geladen war, stand da "Version 4.0.5" Dann funktionierte auch das Aktivieren.
Es kam danach nicht die Meldung wie in der Anleitung, daß die Datenbank aktualisiert werden soll, sondern daß es ein Problem gibt. Als ich dann auf das "hier" geklickt habe, kam der Converter. Ich habe dann auf Automatisch geklickt und gewartet. Es kam dann eine Meldung, daß die Seite nicht reagiert und ich hatte zur Wahl "warten" oder "neu laden". Ich habe auf warten geklickt. Diesen grünen Balken wie in der Anleitung gab es nicht. Nach ungefähr 5 x warten habe ich dann doch auf "neu laden" geklickt. Danach waren dann grüne Haken bis Anreden. Ich habe dann auf Mediathek geklickt und nach 1 warten kam da auch der grüne Haken. Das ging dann auch bei Produkte und Preise. Als ich auf Kategorien geklickt habe, hat er mich rausgeworfen. Ich bin dann neu rein und habe den Converter wieder automatisch gestartet. (Hatte im Forum gelesen, das man den mehrmals durchlaufen lassen kann). Das funktionierte dann auch relativ schnell.

Ich hoffe, Ihr könnt mir nun helfen, damit ich meine Varianten wieder bekomme.

Gruß

Petra
Beiträge: 77
Registriert: 19.01.2017, 23:06
Lizenz: wpShopGermany Pro

Re: Produkteinstellungen funktionieren nicht

Beitrag von Petra » 28.02.2018, 17:45

hallo Holz,

schön, dass ein Teil funktioniert hat. Bei den Varianten bin ich jedoch überfragt, da ich selbst keine Varianten angelegt habe und daher nicht aus Erfahrung berichten kann. Drück die Daumen, dass es funktioniert!

Liebe Grüße, Petra

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16015
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Produkteinstellungen funktionieren nicht

Beitrag von maennchen1.de » 28.02.2018, 19:36

Danke für die überdurchschnittliche gute Erklärung für das Update!
Das Modul Varianten ist aktiv?
Falls ja, aktiviere bitte das Modul Converter noch einmal und konvertiere die Varianten erneut.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Holz
Beiträge: 89
Registriert: 26.02.2013, 18:29
Lizenz: wpShopGermany Pro

Re: Produkteinstellungen funktionieren nicht

Beitrag von Holz » 01.03.2018, 14:40

Hallo,
das hat funktioniert! Vielen Dank!

Gruß

Antworten