Kundenexport funktioniert nicht

Allgemeine Fragen zur Verwendung von wpShopGermany4 und dessen integrierten Modulen

Moderatoren: ThoGoe, maennchen1.de

Antworten
Michi82
Beiträge: 111
Registriert: 15.10.2014, 14:38
Lizenz: wpShopGermany Enterprise

Kundenexport funktioniert nicht

Beitrag von Michi82 » 22.02.2018, 12:16

Hallo zusammen,

ich nutze die Version 4.0.5, Wordpress 4.9.4 und bei mir funktioniert der Kundenexport nicht.
Wenn ich in der Kundenverwaltung auf "Daten-Export" klicke, erscheint eine weiße Seite. Es wird kein Tabelle oder sonstiges erstellt, egal ob ich nur einen Kunden oder alle auswähle.
Muss ich vor dem Export noch etwas machen?

Vielen Dank für eure Hilfe.

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2591
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Kundenexport funktioniert nicht

Beitrag von ThoGoe » 22.02.2018, 14:10

Hallo!

Bitte aktiviere einmal den Debugmodus im Backend unter wpShopGermany > Konfiguration > Einstellungen > Erweitert und führe den Export erneut aus. Auf der weißen Seite sollte dir dann eine Fehlermeldung angezeigt werden. Poste diese Meldung bitte hier einmal.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

Michi82
Beiträge: 111
Registriert: 15.10.2014, 14:38
Lizenz: wpShopGermany Enterprise

Re: Kundenexport funktioniert nicht

Beitrag von Michi82 » 22.02.2018, 16:02

Hallo ThoGoe,

der Debugmodus ist aktiviert, es wird leider trotzdem keine Fehlermeldung angezeigt.
Gibt es eine andere Möglichkeit?

viele Grüße

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2591
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Kundenexport funktioniert nicht

Beitrag von ThoGoe » 22.02.2018, 16:35

Hallo!

Aktiviere bitte einmal deinen Debug-Modus in der wp-config. Dort findest du eine Zeile:

Code: Alles auswählen

define('WP_DEBUG', false);
Diese Zeile stellt du auf true:

Code: Alles auswählen

define('WP_DEBUG', true);
Wird dir jetzt eine Fehlermeldung angezeigt?

Wenn dir immer noch keine Fehlermeldung angezeigt wird, musst du bitte einmal in dein error.log schauen, ob dir eine Fehlermeldung zum entsprechenden Zeitpunkt protokolliert wird. Ein weißer Bildschirm muss eine Fehlermeldung produzieren und anhand dieser Meldung kann man den Bug herausfinden.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

Michi82
Beiträge: 111
Registriert: 15.10.2014, 14:38
Lizenz: wpShopGermany Enterprise

Re: Kundenexport funktioniert nicht

Beitrag von Michi82 » 22.02.2018, 17:26

Hallo,

jetzt werden mir die folgenden Fehler angezeigt:

Notice: Undefined index: page in /homepages/17/d523035898/htdocs/anmeldung.skfv-bmwgroup.de/wp-content/plugins/twenty-eleven-theme-extensions/moztools/mozadmin.php on line 162

Notice: Undefined index: page in /homepages/17/d523035898/htdocs/anmeldung.skfv-bmwgroup.de/wp-content/plugins/twenty-eleven-theme-extensions/moztheme2011admin.php on line 150

Notice: has_cap wurde mit einem Parameter oder Argument aufgerufen, der seit Version 2.0.0 veraltet ist! Die Verwendung von Benutzer-Levels ist veraltet. Verwende stattdessen Berechtigungen. in /homepages/17/d523035898/htdocs/anmeldung.skfv-bmwgroup.de/wp-includes/functions.php on line 4031

Notice: Undefined index: page in /homepages/17/d523035898/htdocs/anmeldung.skfv-bmwgroup.de/wp-content/plugins/twenty-eleven-theme-extensions/moztools/mozadmin.php on line 162

Warning: Cannot modify header information - headers already sent by (output started at /homepages/17/d523035898/htdocs/anmeldung.skfv-bmwgroup.de/wp-content/plugins/twenty-eleven-theme-extensions/moztools/mozadmin.php:162) in /homepages/17/d523035898/htdocs/anmeldung.skfv-bmwgroup.de/wp-admin/includes/misc.php on line 1114

Was bedeutet das?
Vielen Dank für die Hilfe.

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15880
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Kundenexport funktioniert nicht

Beitrag von maennchen1.de » 22.02.2018, 18:02

Das sind Notice Meldungen, die bedeuten nichts.
Poste hier doch bitte einmal einen Screenshot deines Moduls Export, damit wir deinen Fehler reproduzieren können.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2591
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Kundenexport funktioniert nicht

Beitrag von ThoGoe » 23.02.2018, 08:05

Hallo!

Bitte zudem ein aktuelles Standardtheme (TwentySeventeen).

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

Michi82
Beiträge: 111
Registriert: 15.10.2014, 14:38
Lizenz: wpShopGermany Enterprise

Re: Kundenexport funktioniert nicht

Beitrag von Michi82 » 23.02.2018, 13:05

Hallo,

ich wusste nicht, dass man für den Kundenexport ein Exportprofil anlegen muss. Das habe ich jetzt gemacht (siehe Bilder Kundenexport).

Habe den Export jetzt darüber laufen lassen und jetzt bekomme ich noch mehr Fehler angezeigt (sieher Bild Fehlermeldung). Dieser Fehler kommt dann mehrere Male.

Ich nutze das Standarttheme Twentyeleven. Ist das ok?

Vielen Dank für die Hilfe.
Dateianhänge
Fehlermeldung.JPG
Kundenexport 1.JPG
Kundenexport.JPG

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 15880
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Kundenexport funktioniert nicht

Beitrag von maennchen1.de » 23.02.2018, 16:30

Die Notice-Meldungen sind uninteressant und verschwinden wieder, wenn du den Debug-Modus deaktivierst.
Interessant ist die letzte Meldung: Die Scriptausführungszeit wurde begrenzt und nach 30 Sekunden abgebrochen. Das liegt daran, dass die Aufgabe/Datenmenge für den Server zu groß war. Entweder du minimierst das mögliche Ergebnis durch den Einsatz des Filters, oder setzt die Scriptausführungsszeit deines Servers hoch. Frage dazu bitte deinen Provider, wenn du nicht weißt, wie du die Zeit konfigurierst.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Michi82
Beiträge: 111
Registriert: 15.10.2014, 14:38
Lizenz: wpShopGermany Enterprise

Re: Kundenexport funktioniert nicht

Beitrag von Michi82 » 23.02.2018, 18:00

OK ,vielen Dank schonmal für die Info.

2 Fragen hätte ich da noch.

1. Was meinst du mit "mit dem Filter minimieren"? So ein Filter wie beim Bestellexport gibt es bei den Kunden nicht. Jedenfalls finde ich es nicht.
Wenn ich den Hacken bei einem Kunden mache, sollte der Export doch nur diesen Kunden exportieren oder? Das macht es aber auch nicht, weil das ja nicht so lange dauern würde.

2. Was ist mit der normalen Funktion "Daten Export"? Also nicht über das Modul Export. Warum funtioniert das nicht? In der Version 3 hat das immer funktioniert. Da wurden mir immer alle Infos in einer Spalte ausgegeben.

viele Grüße und danke für die Hilfe

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2591
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Kundenexport funktioniert nicht

Beitrag von ThoGoe » 26.02.2018, 09:43

Hallo!

Der "normale" Datenexport über "Daten Export" erzeugt bei dir eine weiße Seite, ist das korrekt? Wird dir mittels Debugfunktion, entweder unter wpShopGermany > Konfiguration > Einstellungen > Erweitert und/oder in der wp-config, eine Fehlermeldung angezeigt bzw. wird eine Fehlermeldung im error.log deines Servers dargestellt?

Bitte schau einmal in folgendes Template: wpShopGermany > views > mods > mod_kundenverwaltung > index.phtml in die Zeile 33. Dort hat sich ein Schreibfehler eingeschlichen. Tausche bitte die Zeile 33 mit folgendem Code aus:

Code: Alles auswählen

<li role="presentation" class="<?php echo ((wpsg_isSizedString($_REQUEST['action'], 'export'))?'active':''); ?>"><a href="<?php echo WPSG_URL_WP; ?>wp-admin/admin.php?page=wpsg-Customer&action=export&noheader=1"><span class="glyphicon glyphicon-export"></span><?php echo __("Daten-Export", "wpsg"); ?></a></li>
Mit dem nächsten Update wird der Bugfix einfließen. Vielen Dank für den Hinweis!

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

Michi82
Beiträge: 111
Registriert: 15.10.2014, 14:38
Lizenz: wpShopGermany Enterprise

Re: Kundenexport funktioniert nicht

Beitrag von Michi82 » 26.02.2018, 13:44

Hallo ThoGoe,

genau, das war der Fehler.
Vielen Dank für die Hilfe.

Beste Grüße

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2591
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Kundenexport funktioniert nicht

Beitrag von ThoGoe » 26.02.2018, 16:40

Hallo!

Sehr gerne. Freut mich, dass jetzt alles wieder funktioniert.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

Antworten