Deaktivierte Versandart

Allgemeine Fragen zur Verwendung von wpShopGermany4 und dessen integrierten Modulen

Moderatoren: ThoGoe, maennchen1.de

Petra
Beiträge: 78
Registriert: 19.01.2017, 23:06
Lizenz: wpShopGermany Pro

Deaktivierte Versandart

Beitrag von Petra » 25.02.2018, 21:43

Hallo,

seit dem Update auf die Version 4.0.5 habe ich das Problem, dass bei unterschiedlichen Versandarten eine Fehlermeldung auf der Rechnung und Bestellmail erscheint. Mit der alten 3er-Version war es kein Problem.

Wenn ich eine Kombibestellung habe mit Paketversand und E-Mail-Versand (kostenfrei) erscheint nach dem Wort Versandkosten "Deaktivierte Versandart (6_2) + Deaktivierte Versandart (6_5)"

Wenn Kunde nur einen Artikel per Paketversand oder E-Mail-Versand hat, kommt keine Fehlermeldung und es wird ganz normal angezeigt.

Die Einstellungen sowie den Ausdruck habe ich unten eingestellt und hoffe, dass ihr mir eine Lösung habt. Vielen Dank.

Liebe Grüße
Petra
Dateianhänge
Rechnungstext.jpg
Versand.jpg

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2975
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Deaktivierte Versandart

Beitrag von ThoGoe » 26.02.2018, 10:24

Hallo!

Bitte schaue zuvor in diesen Thread.

Welche Fehlermeldungen werden dir angezeigt?

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

Petra
Beiträge: 78
Registriert: 19.01.2017, 23:06
Lizenz: wpShopGermany Pro

Re: Deaktivierte Versandart

Beitrag von Petra » 27.02.2018, 22:00

ThoGoe hat geschrieben:Hallo!

Bitte schaue zuvor in diesen Thread.

Welche Fehlermeldungen werden dir angezeigt?

Liebe Grüße
Hallo,

vielen Dank für deine Antwort. Ich verstehe nicht ganz, was du mir mit dem Link sagen möchtest. Ich habe sowohl "hallo" gesagt, wie auch die Versionen genannt, beschrieben wann der Fehler auftritt und Screenshots gemacht.

Da es vermutlich Browser-unabhängig ist, weil es auch auf den Kundenrechnungen erscheint, bin ich nun ratlos, was ich falsch gemacht haben sollte.

Was ist für dich noch unklar?

Liebe Grüße, Petra

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2975
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Deaktivierte Versandart

Beitrag von ThoGoe » 28.02.2018, 09:04

Hallo!

Um größeren Unklarheiten vorzubeugen zitiere ich aus dem verlinkten Thread:
maennchen1.de hat geschrieben:
  1. Versionsnummer von WordPress (z.B. 4.9.2)
  2. Versionsnummer von PHP (z.B. PHP7.1)
  3. Wenn aktualisiert wurde, die Versionsnummern (auch eine ungefähre Zahl ist besser als nichts) der Vorgänger
  4. optional: ein Link zu deiner Webseite (Frontend)
Es wäre schön, wenn du uns zudem verrätst, von welcher wpShopGermany-Versionsnummer du auf die 4.0.5 aktualisiert hast.

Bitte nutze zum Testen folgende Schritte:
  1. Standardtheme einstellen
  2. alle anderen Plugins (außer wpShopGermany) deaktivieren
  3. user_views deaktivieren
  4. Debug-Modus unter wpShopGermany > Konfiguration > Einstellungen > Erweitert aktivieren
  5. eventuelle Fehlermeldungen posten
Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

Petra
Beiträge: 78
Registriert: 19.01.2017, 23:06
Lizenz: wpShopGermany Pro

Re: Deaktivierte Versandart

Beitrag von Petra » 28.02.2018, 17:57

Hallo,

ich weiß es leider nicht, von welcher Version ich upgedatet hatte, daher hatte ich im Eingangspost nur "3er" geschrieben. Ich kann nur noch raten, von welcher Version ich das gemacht habe, daher bringt das vermutlich nichts - oder höchstens Verwirrung.

Aber bevor ich mich nun durch die kompletten Einstellungen durchkämpfe und suche, wie was überhaupt geht bzgl. Einstellung Standardtheme und Deaktivierung von sonstigen Plugins, ist nur meine (vielleicht etwas PC-naive) Frage, ob das überhaupt mit anderen Plugins und Themes zusammenhängen kann? Zuvor hatte es ja ohne Probleme funktioniert und ich vermute das Probleme eher in den Softwareeinstellungen des Programmes. Denn zuvor hatte es ja ohne Probleme funktioniert.

Wie deaktiviert man die User_views?

Wo und wann kommen die Fehlermeldungen, wenn ich den Debug-Modus aktiviert habe? Wo kann ich die dann finden?

Liebe Grüße
Petra

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16100
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Deaktivierte Versandart

Beitrag von maennchen1.de » 28.02.2018, 19:37

Schau mal hier: viewtopic.php?f=24&t=8934
:)
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Petra
Beiträge: 78
Registriert: 19.01.2017, 23:06
Lizenz: wpShopGermany Pro

Re: Deaktivierte Versandart

Beitrag von Petra » 28.02.2018, 20:53

vielen Dank, der Link hat mir sehr gut weitergeholfen.

Leider konnte das Problem nicht behoben werden. Folgende Veränderungen/Tests habe ich nun durchgeführt:
- User Views deaktiviert
- Themes auf Shop Theme One umgestellt
- Besitze WordPress Version 4.9.4 und PHP 7.0.27 (lt. 1und1 PHP 7.0)
- Debug-Modus hat bisher keine Fehler gelistet (zumindest hab ich keine gesehen)
- alle anderen Plugins deaktiviert

Alles beim alten, sobald zwei Versandarten zusammen aufgeführt werden in einer Rechnung/Bestellung erscheint die Fehlermeldung, von der ich im ersten Posting einen Screenshot hochgeladen habe.

Bestellt Kunde nur ein Buch, dann kommt die Versandart korrekt als Paketversand, bestellt er ein E-Book, dann kommt der richtige Text dazu. Bestellt er aber eine Kombi aus beiden und es werden somit der Paket- und Email-Versand gelistet, erscheinen die Fehlermeldungen "deaktivierte Versandart..."

Hast du noch eine Idee, was ich machen könnte?

Liebe Grüße, Petra

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16100
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Deaktivierte Versandart

Beitrag von maennchen1.de » 28.02.2018, 22:39

Poste bitte einmal einen Screenshot deiner Versandarten und eines Produktes (Backend).
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Petra
Beiträge: 78
Registriert: 19.01.2017, 23:06
Lizenz: wpShopGermany Pro

Re: Deaktivierte Versandart

Beitrag von Petra » 01.03.2018, 09:19

Guten Morgen,

nachfolgend die Screenshots der Übersichten.

Liebe Grüße
Petra
Dateianhänge
Rechnungstext.jpg
Versandarten.jpg
Produkt.jpg

Petra
Beiträge: 78
Registriert: 19.01.2017, 23:06
Lizenz: wpShopGermany Pro

Re: Deaktivierte Versandart

Beitrag von Petra » 01.03.2018, 15:10

puh, ich hab das Problem lösen können! :) Hat nun einiges an Nerven gekostet und ich bin an meine technischen Grenzen gekommen - und dabei war es einfacher als gedacht. Nur habe ich an falscher Stelle gesucht....

Falls jemand auch das Problem hat, möchte ich hier kurz ein paar Worte dazu schreiben.

Das Problem war, dass ich keine gemeinsame Versandart hatte, die eine war Paketversand, die andere Email-Versand. Das geht so wohl nicht mehr mit der neuen Version, dass das System beides zusammenführt... Daher habe ich eine neue Versandart gewählt "Paketversand + Email-Versand" und dies habe ich dann bei beiden Produkten als Standardversand genommen.

Nachteil ist, dass ich dafür extra ein neues Produkt habe anlegen müssen, welches für den Kombi-Versand vorgesehen ist. Bei meinen Produkten geht das, aber ich befürchte, bei anderen Shops ist das nicht so einfach möglich.

Liebes Männchen & Team, ich hoffe, dass euch meine Beschreibung hilft

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2975
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Deaktivierte Versandart

Beitrag von ThoGoe » 01.03.2018, 17:08

Hallo!

Es freut uns, dass du die Problemlösung gefunden hast und nun alles funktioniert. Vielen Dank für die ausführliche Darstellung.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

Dirk
Beiträge: 244
Registriert: 04.02.2015, 12:50
Lizenz: wpShopGermany Enterprise
Wohnort: München

Re: Deaktivierte Versandart

Beitrag von Dirk » 08.03.2018, 23:23

Hallo Petra,

das gleiche Problem habe ich auch - ich probier es mal mit Deinem Lösungsansatz.

Liebe Grüsse, Dirk

Petra
Beiträge: 78
Registriert: 19.01.2017, 23:06
Lizenz: wpShopGermany Pro

Re: Deaktivierte Versandart

Beitrag von Petra » 09.03.2018, 19:19

Hallo Dirk,

hat es bei dir so funktioniert oder hast du mittlerweile einen anderen Lösungsansatz gefunden?

Liebe Grüße, Petra

Petra
Beiträge: 78
Registriert: 19.01.2017, 23:06
Lizenz: wpShopGermany Pro

Re: Deaktivierte Versandart

Beitrag von Petra » 04.04.2018, 19:37

Hallo,

nun melde ich mich nochmals, da es sich auf Dauer recht umständlich gestaltet, alle Varianten einzukalkulieren, wie versandt werden kann.

Daher möchte ich nachfragen, ob es von Programmseite aus eine Lösung gibt, wie man verschiedene Versandarten in einer Bestellung vereinen kann ohne dass es zu "deaktivierten Versandarten" kommt? Denn wenn es falsch läuft, wird die Mehrwertsteuer auch falsch berechnet. Wenn man nicht aufpasst, bekommt man daher mit dem Finanzamt Probleme, wenn man die Rechnung nicht im Nachhinein korrigiert und dem Kunden zum Austausch zuschickt.

Bei der Version 3.x (ich weiß nicht mehr, welche die letzte Version vor dem Update war) hatte es noch funktioniert, bei Version 4.0.5 und 4.0.6 nicht.

Ich bitte euch, dass Problem anzuschauen. Vielen lieben Dank!

Liebe Grüße
Petra

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2975
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Deaktivierte Versandart

Beitrag von ThoGoe » 05.04.2018, 07:33

Hallo!

Ich habe testweise ein Produkt mit der Versandart DHL und ein Produkt mit der Versandart Post in den Warenkorb gelegt und Im Warenkorb (siehe Screenshot), sowie im Checkout2 (Bezahlung/Versand), Bestellabschluss und dem gesamten Bestell-Backend wird es korrekt angezeigt. Die einzigste unterschiedliche Einstellung (wie deine Versandarteneinstellungen) ist, dass bei mir die Versandzone auf "alle Versandzonnen" eingestellt ist. Bitte teste das Ganze noch einmal.

Liebe Grüße
Dateianhänge
Kombinierte Versandart.PNG
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

Antworten