User_views werden nicht gezogen

Allgemeine Fragen zur Verwendung von wpShopGermany4 und dessen integrierten Modulen

Moderatoren: ThoGoe, maennchen1.de

Antworten
fiat500
Beiträge: 66
Registriert: 17.11.2011, 10:09
Lizenz: wpShopGermany Pro

User_views werden nicht gezogen

Beitrag von fiat500 » 28.06.2018, 12:08

Hallo!

Habe schon versucht, in anderen Threads Hilfe zu finden, aber leider ohne Erfolg. Hat sich bzgl. Einbindung von user_views etwas Grundlegendes von V3 zu V4 geändert?

Habe versucht, dieses Dok zu befolgen:
https://doc.maennchen1.de/docs/wpshopge ... alisieren/

Testweise sollte eine veränderte standard.phtml drei große XXX ausgeben, aber leider funktioniert das nicht.

Hier hoffentlich hilfreiche Screenshots:
uv1.PNG
uv2.PNG
uv3.PNG
uv4.PNG
Freue mich über Unterstützung!

fiat500
Beiträge: 66
Registriert: 17.11.2011, 10:09
Lizenz: wpShopGermany Pro

Re: User_views werden nicht gezogen

Beitrag von fiat500 » 28.06.2018, 13:22

Update:
jetzt bin ich komplett verwirrt. Warum wird eine "standard.phtml" aus dem Theme gezogen? Oder anders gefragt (wenn das richtig sein sollte): wie lege ich user_views zum Theme an?
uv5.PNG
uv5.PNG (4.17 KiB) 51 mal betrachtet

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16014
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: User_views werden nicht gezogen

Beitrag von maennchen1.de » 28.06.2018, 16:24

Hallo!
Schau mal bitte, ob du in deinem uploads-Ordner (oder einem Unterordner) eine htaccess Datei liegen hast. Deaktiviere diese testweise einmal durch Umbenennung (z.B. old.htaccess).
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

nkx
Beiträge: 2
Registriert: 18.02.2018, 20:36
Lizenz: wpShopGermany Enterprise

Re: User_views werden nicht gezogen

Beitrag von nkx » 05.08.2018, 01:34

Na ja, was soll ich sagen,

nach dem Update auf Version 4 läuft das Shopsystem mehr als unzufriedenstellend. Die User-Views kann ich nach jedem Update manuell anpassen, weil irgend ein Scheiß in der Programmierung nicht stimmt. Der Extra-Ordner außerhalb der Installation funktioniert nicht und hat noch nie funktioniert, das letzte Update hat sämtliche Grid-Views auf List-Views umgestellt, das neue WP-Update behindert die Aktualisierung von Produktartikeln etc. Egal, an welcher Stelle ein Update erfolgt: der Shop zickt rum, während andere Plugins keine Probleme bereiten und sich mit einem einzigen Klick erwartungegemäß integrieren. Die Ansichten musste ich mühsam im völlig verhunzten Quellcode bereinigen, weil die Funktionen nicht übernommen werden. Und das, obwohl ich Laie bin und nur rudimentäre Kenntnisse habe, die Fehler aber dennoch erkenne! Testet man den Shop mit verschiedenen Designs, hakt es immer an der selben stelle, nämlich der korrekten Darstellung der Produktbilder.

Es kann doch nicht sein, dass jedes Design dem Shop angepasst werden muss, statt, dass der Shop dem Prinzip von Wordpress angepasst wird.

Der Support hat immer Antworten parat - schuld sind nur komischer Weise immer die anderen. Man muss die htaccess überprüfen, andere Plugins ausschalten und und und. Dabei liegt das Interesse jedes Betreibers wohl vorrangig darin, ein funktionierendes System zu haben und nicht bei jedem einzelnen Update das Augenmerk auf den wpshop auf seine Funktionalität zu überprüfen.

Wie wäre es einfach einmal mit einer sauberen Programmierung? Die Preise, die für die Module inzwischen abverlangt werden, dürfen wohl in Abgrenzung zu funktionierenden kostenfreien Plugins eine gewisse Professionalität erwarten lassen.

Ich liebe den wpshop dafür, dass er sich - zumindest theoretisch - in den eigenen Blog integrieren lässt, während woocommerce ein shopeigenes Layout voraussetzt, was man ja gerade nicht will. Wenn die Bugs jedoch so weitergehen, kommen durchaus auch die etablierten Systeme in Frage. Magento, Prestashop und Co. laufen wenigstens, und mit dem passendne Theme-Gernerator wird irgend wann auch woocommerce attraktiv. TemplateToaster ist dran! Und dann: Adios, wpshopgermany, wenn eure Bugs so weitergehen.

Sorry, das musste einmal raus, weil es mich schon seit der Einführung der Version 4 einfach nur abnervt.

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2770
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: User_views werden nicht gezogen

Beitrag von ThoGoe » 06.08.2018, 08:00

Hallo!

Ich kann leider keine Frage aus deinem Beitrag herauslesen. Gerne helfen wir dir natürlich weiter, sofern eine Frage besteht.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

nkx
Beiträge: 2
Registriert: 18.02.2018, 20:36
Lizenz: wpShopGermany Enterprise

Re: User_views werden nicht gezogen

Beitrag von nkx » 08.08.2018, 23:55

Na ja, was soll ich auch groß fragen, wenn im Grunde gar nichts richtig läuft???

Beispiel: Ich möchte einen Artikel aktualisieren. Was passiert, wenn ich speichern möchte? Nichts. Ein weißer Bildschirm.

Okay: Versuche ich es einfach einmal, einen Artikel zu kopieren. Was passiert? Nichts! Ein weißer Bildschirm.

Okay: warte ich auf das nächste Update. Was passiert? Nichts, weil es noch keins gibt. Und wenn es ein Update gibt: Was passiert? Die eigenen Einstellungen, die ich nach Anleitung in den user-views gespeichert habe, werden einfach überschrieben und müssen aktualisiert werden. Eine Aktualisierung führt aber wieder zum weißen Bildschirm.

Solll ich also eine Frage stellen, damit ihr eure Großbaustelle in den Griff bekommt?

Ich sehe einen weißen Bildschirm, wenn ich meine Artikel anpassen will. Woran zur Hölle liegt das jetzt schon wieder?

Meine user-views werden bei den Updates nicht übernommen. Woran zum Teufel liegt das?

Und wie erklärt ihr es, dass mit jedem Wechsel des Themes - ob nun über Artisteeer, TemplatetToaster oder einem Standard-WordPress-Theme - die Artikelbilder anders, aber nie wie gewünscht dargestellt werden werden?

Ich habe bislang nichts an den Seiten, die bisher funktionierten, geändert. Und die Änderungen, die erforderlich sind, funktionieren nicht!

Was soll ich also fragen, um euren neuen Shop zum Laufen zu bekommen?

Übrigens: Er läuft auf verschiedenen Servern mit unterschiedlichen Konfigurationen. Die Probleme sind überall dieselben! Was soll ich an einem weißen Bildschirm erklären, außer, dass er weiß ist?

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16014
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: User_views werden nicht gezogen

Beitrag von maennchen1.de » 09.08.2018, 07:52

Ich glaube, dass es sich hier immer um ein und das selbe Problem handelt.
Schau bitte einmal hier: https://wpshopgermany.maennchen1.de/faq ... ch-machen/
und hier: https://forum.maennchen1.de/viewtopic.php?f=24&t=8934
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2770
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: User_views werden nicht gezogen

Beitrag von ThoGoe » 09.08.2018, 07:57

Hallo!
nkx hat geschrieben:
08.08.2018, 23:55
Beispiel: Ich möchte einen Artikel aktualisieren. Was passiert, wenn ich speichern möchte? Nichts. Ein weißer Bildschirm.
Bitte aktiviere einmal den Debug-Modus im Backend unter wpShopGermany > Konfiguration > Einstellungen > Erweitert. Dadurch wird auf dem weißen Bildschirm eine Fehlermeldung sichtbar. Poste diese bitte hier einmal!
Leider kann nur mit einer Fehlermeldung kann ein Fehler gefunden werden, da ein weißer Bildschirm viele Ursachen haben kann. Wurde der Fehler gefunden, kann ein Bugfixing stattfinden, dass in ein die Version überführt und mit einem Update veröffentlicht wird.
nkx hat geschrieben:
08.08.2018, 23:55
Meine user-views werden bei den Updates nicht übernommen. Woran zum Teufel liegt das?
Bitte poste einmal den Pfad, wo deine user_views liegen!
nkx hat geschrieben:
08.08.2018, 23:55
Und wie erklärt ihr es, dass mit jedem Wechsel des Themes - ob nun über Artisteeer, TemplatetToaster oder einem Standard-WordPress-Theme - die Artikelbilder anders, aber nie wie gewünscht dargestellt werden werden?
Themes nehmen stets Einfluss auf die dargestellten Bilder. Sie überschreiben die darzustellenden Größen und Ausrichtungen, fügen Rahmen oder Schatten hinzu, ... . Das Sinnvollste ist die eigenständige Anpassung an die eigenen Wünsche (um es zu 100% so zu haben).

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

Antworten