Fehler beim Absenden einer Bestellung

Allgemeine Fragen zur Verwendung von wpShopGermany4 und dessen integrierten Modulen

Moderatoren: ThoGoe, maennchen1.de

Antworten
Gitta
Beiträge: 65
Registriert: 05.01.2014, 12:13
Lizenz: wpShopGermany Enterprise
Wohnort: Nürnberg

Fehler beim Absenden einer Bestellung

Beitrag von Gitta »

Hallo,

heute hat mich ein Kunde angeschrieben, weil beim Absenden der Bestellung ein Fehler aufgetreten ist. Ich habe das geprüft - also vollständige Bestellung getätigt und dann den Kauf-Button geklickt.

Es erscheint eine weiße Seite mit folgender Meldung: Hallo Administrator, Eine neue Bestellung ist im Online-Shop eingegangen.

Die Bestellung steht in der Bestellverwaltung aber es wird nicht zu PayPal weitergeleitet auch nicht zur Danke-Seite mit der Bankverbindung (bei Auswahl Überweisung). Es werden auch keine E-Mails verschickt - weder an mich, noch an den Kunden.

Ich habe keine User-Views oder sonstige Änderungen eingefügt. Das letzte Update ist aktiv, die Datenbank habe ich aktualisiert. Mir ist nicht bewusst, dass ich an den Einstellungen was verändert hätte.

Kann mir bitte jemand helfen? Wo könnte der Fehler liegen?
Viele Grüße
Gitta

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 3582
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Fehler beim Absenden einer Bestellung

Beitrag von ThoGoe »

Hallo!

Du hast also die Version 4.1.1 des wpShopGermany, die WordPress-Version 5.1.1 aktiv? Bitte aktiviere einmal den Debug-Modus unter wpShopGermany > Konfiguration > Einstellungen > Erweitert. Nun sollte dir keine weiße Seite, sondern eine Fehlermeldung angezeigt werden. Ich würde dich bitten, diese Meldung einmal hier zu posten.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

Gitta
Beiträge: 65
Registriert: 05.01.2014, 12:13
Lizenz: wpShopGermany Enterprise
Wohnort: Nürnberg

Re: Fehler beim Absenden einer Bestellung

Beitrag von Gitta »

Hallo,

ja, ich habe die neueste Version von wpShopGermany (4.1.1) und auch die neueste Version von WP (5.1.1).

Nach dem Aktivieren des Debug-Modus wird nach dem Absenden einer Bestellung keine Fehlermeldung angezeigt. Auf der weißen Seite steht weiterhin oben genannter Text. Das Bestellprotokoll ist leer.

Im Backend unter Bestellverwaltung/Entwickleroptionen habe ich die angebotenen Links getestet:
Kundenmail simulieren - es wird die weiße Seite mit dem Text "Hallo (Kundenname), vielen Dank für Ihre Bestellung" angezeigt.
Adminmail simulieren - erscheint der Text: "Hallo Administrator, Eine neue Bestellung ist im Online-Shop eingegangen!"
Die Bestell-Abschlussseite wird ganz normal angezeigt.

Unter Bestellverwaltung/Bestelldaten erscheint folgende Meldung:

Array
(
[sum] => Array
(
[product_netto] => 39.8
[product_brutto] => 39.8
[product_tax] => 0
[productsum_netto] => 39.8
[productsum_brutto] => 39.8
[payment_netto] => 0
[payment_brutto] => 0
[shipping_netto] => 0
[shipping_brutto] => 0
[discount_netto] => 0
[discount_brutto] => 0
[netto] => 39.8
[brutto] => 39.8
[tax] => 0
[shipping_tax] => 0
[payment_tax] => 0
)

[tax] => Array
(
[e_1] => Array
(
[key] => e_1
[tax_value] =>
[netto] => 39.8
[brutto] => 39.8
[part] => 1
[sum] => 0
)

[c_1] => Array
(
[key] => c_1
[tax_value] => 0
[netto] => 0
[brutto] => 0
[part] => 0
[sum] => 0
)

)

[product] => Array
(
[0] => Array
(
[product_id] => 16
[product_key] => 16
[product_index] => 1
[order_product_id] => 2302
[eu] =>
[targetCountry] =>
[netto] => 19.9
[brutto] => 19.9
[netto_single] => 19.9
[brutto_single] => 19.9
[tax] => 0
[amount] => 1
[tax_key] => e_1
[bruttonetto] => 0
[set] => 19.90
)

[1] => Array
(
[product_id] => 15
[product_key] => 15
[product_index] => 0
[order_product_id] => 2301
[eu] =>
[targetCountry] =>
[netto] => 19.9
[brutto] => 19.9
[netto_single] => 19.9
[brutto_single] => 19.9
[tax] => 0
[amount] => 1
[tax_key] => e_1
[bruttonetto] => 0
[set] => 19.90
)

)

[shipping] => Array
(
[0] => Array
(
[shipping_key] => 6_2
[targetCountry] =>
[netto] => 0
[brutto] => 0
[netto_single] => 0
[brutto_single] => 0
[tax] => 0
[amount] => 1
[tax_key] => c_1
[bruttonetto] => 0
[set] => 0
)

)

[payment] => Array
(
[0] => Array
(
[payment_key] => 1
[targetCountry] =>
[netto] => 0
[brutto] => 0
[netto_single] => 0
[brutto_single] => 0
[tax] => 0
[amount] => 1
[tax_key] => e_1
[bruttonetto] => 0
[set] => 0
)

)

[voucher] =>
[discount] =>
)


Sorry, ich bekomme das nicht in ein JPG. Sonst erscheint nirgends eine Meldung, die einen Fehler anzeigt.

Ich hoffe, du kannst damit was anfangen.
Viele Grüße
Gitta

Gitta
Beiträge: 65
Registriert: 05.01.2014, 12:13
Lizenz: wpShopGermany Enterprise
Wohnort: Nürnberg

Re: Fehler beim Absenden einer Bestellung

Beitrag von Gitta »

Hallo,

darf ich daran erinnern, dass der Fehler noch nicht behoben ist ... Seit heute Morgen warte ich auf Hinweise, wie ich das Problem beheben kann. Leider meldet sich niemand mehr vom Support. Das enttäuscht mich sehr.

Ich musste meinen Shop schließen, um nicht noch mehr Kunden zu verärgern.
Viele Grüße
Gitta

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 17321
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Fehler beim Absenden einer Bestellung

Beitrag von maennchen1.de »

Hallo!
Der Fehler wurde hier im Forum vor Kurzem bereits gemeldet und ist behoben.
Die heute erschienene Version 4.1.2 behebt diesen Fehler. Bitte probiere Version 4.1.2 einmal aus und gib uns Rückmeldung. Vielen Dank!
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
Wie poste ich eine Frage zu einem Problem?
FAQ / häufig gestellte Fragen
Anzeige-Fehler / Funktionsfehler in wpShopGermany erkennen und selbst beheben
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Gitta
Beiträge: 65
Registriert: 05.01.2014, 12:13
Lizenz: wpShopGermany Enterprise
Wohnort: Nürnberg

Re: Fehler beim Absenden einer Bestellung

Beitrag von Gitta »

Hallo,

tut mir leid aber selbst das Update konnte den Fehler nicht beheben. Ich habe es eben auf meiner Testseite ausprobiert. Nach Absenden der Bestellung wird weiterhin die weiße Seite mit oben genannten Text angezeigt.

Und nun?
Viele Grüße
Gitta

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 17321
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Fehler beim Absenden einer Bestellung

Beitrag von maennchen1.de »

Bitte deaktiviere einmal die user_views und teste erneut.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
Wie poste ich eine Frage zu einem Problem?
FAQ / häufig gestellte Fragen
Anzeige-Fehler / Funktionsfehler in wpShopGermany erkennen und selbst beheben
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Gitta
Beiträge: 65
Registriert: 05.01.2014, 12:13
Lizenz: wpShopGermany Enterprise
Wohnort: Nürnberg

Re: Fehler beim Absenden einer Bestellung

Beitrag von Gitta »

ich habe keine User-Views, weil ich nichts in den Dateien geändert habe. Trotzdem habe ich das Häkchen gesetzt und nochmals eine Bestellung durchgeführt - ohne Erfolg.
Viele Grüße
Gitta

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 17321
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Fehler beim Absenden einer Bestellung

Beitrag von maennchen1.de »

Welche PHP Version setzt du ein? Ändert sich etwas am Fehler, wenn du die PHP Version veränderst?
Welche Zahlart verwendest du, wenn das Problem auftaucht?
Kannst du bitte einen Screenshot der Seite "Konfiguration > Über" hier posten?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
Wie poste ich eine Frage zu einem Problem?
FAQ / häufig gestellte Fragen
Anzeige-Fehler / Funktionsfehler in wpShopGermany erkennen und selbst beheben
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Gitta
Beiträge: 65
Registriert: 05.01.2014, 12:13
Lizenz: wpShopGermany Enterprise
Wohnort: Nürnberg

Re: Fehler beim Absenden einer Bestellung

Beitrag von Gitta »

Hallo,

auf meinem Webserver ist die PHP-Version 7.2.7 eingestellt aber ich weiß nicht, wie ich die ändern kann.

Es gibt nur zwei Zahlarten: PayPal und Überweisung. Der Fehler tritt bei beiden Zahlarten auf.

Das mit dem Screeshot verstehe ich nicht ganz. Welche Seite der Konfiguration meinst du?
Viele Grüße
Gitta

Gitta
Beiträge: 65
Registriert: 05.01.2014, 12:13
Lizenz: wpShopGermany Enterprise
Wohnort: Nürnberg

Re: Fehler beim Absenden einer Bestellung

Beitrag von Gitta »

Guten Morgen,

nun bin ich etwas verwirrt, denn soeben habe ich gesehen, dass unter Konfiguration - Über steht, dass die PHP-Version 5.6.40 aktiv ist. In meinem Konto bei meinem Provider wird aber 7.2.7 angegeben. Ich weiß nicht, was nun stimmt.

Gestern Abend habe ich noch die zwei neuen Plugins, die ich Anfang März installiert habe, deaktiviert und erneut getestet. Auch das führte nicht zum Erfolg.

Hier ist der Screenshot
uber1.JPG
Dateianhänge
uber1.JPG
Viele Grüße
Gitta

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 3582
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Fehler beim Absenden einer Bestellung

Beitrag von ThoGoe »

Hallo!

Die abgefragte php-Version unter "Über" wird die entsprechend genutzte Version sein. Bitte frage einmal bei deinem Hostanbieter nach. Nachdem die php-Version auf 7.2 umgestellt wurde, teste das Ganze bitte noch einmal.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

Gitta
Beiträge: 65
Registriert: 05.01.2014, 12:13
Lizenz: wpShopGermany Enterprise
Wohnort: Nürnberg

Re: Fehler beim Absenden einer Bestellung

Beitrag von Gitta »

Guten Morgen,

vielen Dank für die Hilfe, der Fehler ist behoben. Es lag an der PHP-Version. Nach langer Suche im meinem Provider-Konto habe ich nun doch noch die Seite gefunden, auf der ich die PHP-Version umstellen kann. Jetzt ist PHP 7.2 eingestellt und alles funktioniert, wie es sein soll - Bestellungen laufen normal durch und die E-Mails an Kunden und mich werden auch verschickt. Danke nochmals!
Viele Grüße
Gitta

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 3582
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Fehler beim Absenden einer Bestellung

Beitrag von ThoGoe »

Hallo!

Vielen Dank für das Feedback. Freut mich, dass es jetzt funktioniert.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

Antworten