Keine Weiterleitung auf done.phtml

Allgemeine Fragen zur Verwendung von wpShopGermany4 und dessen integrierten Modulen

Moderatoren: ThoGoe, maennchen1.de

stgoldmann
Beiträge: 18
Registriert: 25.06.2013, 11:42
Lizenz: wpShopGermany Pro

Keine Weiterleitung auf done.phtml

Beitrag von stgoldmann » 10.08.2019, 16:13

Hallo,

ich bin gerade dabei den Shop von 3 auf 4 zu heben. Auf meiner Beta läuft auch schon alles. Nur ganz am Ende des Verkaufs erscheint lediglich ein kleines weißes Quadrat auf schwarzem Grund, statt dem Inhalt der done.phtml. Debug spuckt mir dabei nichts aus, denn es wird einfach das Bild Fehler-frei geladen mit der Adresse ../warenkorb/?order_id=xxx&wpsg_done=3nhjZnK4MzyEC4ABnxxxx

Der Kauf ist auch in der Datenbank und alles ist soweit fein.

Über eine Idee bin ich sehr dankbar.

Viele Grüße

Stephan

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16863
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Keine Weiterleitung auf done.phtml

Beitrag von maennchen1.de » 12.08.2019, 08:00

Hallo!
stgoldmann hat geschrieben:
10.08.2019, 16:13
Debug spuckt mir dabei nichts aus, denn es wird einfach das Bild Fehler-frei geladen
Hast du den Debug-Modus so aktiviert?
viewtopic.php?f=24&t=8934#p53534

Was für ein Bild wird dir angezeigt? Was steht im Quellcode der erzeugten Webseite?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
Wie poste ich eine Frage zu einem Problem?
FAQ / häufig gestellte Fragen
Anzeige-Fehler / Funktionsfehler in wpShopGermany erkennen und selbst beheben
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

stgoldmann
Beiträge: 18
Registriert: 25.06.2013, 11:42
Lizenz: wpShopGermany Pro

Re: Keine Weiterleitung auf done.phtml

Beitrag von stgoldmann » 12.08.2019, 09:14

Ja, habe ich. Es geht glatt durch, bis eben ein schwarzer Screen mit einem kleinen weißen Kästchen erscheint.

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16863
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Keine Weiterleitung auf done.phtml

Beitrag von maennchen1.de » 12.08.2019, 11:03

Und was steht im Quellcode der erzeugten Webseite?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
Wie poste ich eine Frage zu einem Problem?
FAQ / häufig gestellte Fragen
Anzeige-Fehler / Funktionsfehler in wpShopGermany erkennen und selbst beheben
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

stgoldmann
Beiträge: 18
Registriert: 25.06.2013, 11:42
Lizenz: wpShopGermany Pro

Re: Keine Weiterleitung auf done.phtml

Beitrag von stgoldmann » 12.08.2019, 12:35

Nichts, es ist ein Bild. Das ist keine Seite, sondern eine Art Pixel oder so.

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16863
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Keine Weiterleitung auf done.phtml

Beitrag von maennchen1.de » 12.08.2019, 13:30

Gehe bitte einmal diese Anleitung vollständig durch:
viewtopic.php?f=24&t=8934
Irgendwoher muss ja das Pixel kommen...
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
Wie poste ich eine Frage zu einem Problem?
FAQ / häufig gestellte Fragen
Anzeige-Fehler / Funktionsfehler in wpShopGermany erkennen und selbst beheben
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

stgoldmann
Beiträge: 18
Registriert: 25.06.2013, 11:42
Lizenz: wpShopGermany Pro

Re: Keine Weiterleitung auf done.phtml

Beitrag von stgoldmann » 12.08.2019, 14:28

Hm. Hier sind also Yoast Premium und WPSG nicht kompatibel aus irgendeinem Grund. Verstehe leider immer noch nicht, was da passiert, zumal Yoast ein mir wichtiges Plugin ist.

Konkret:
Ich habe sämtliche debug Modes angeschaltet. Sie schmeißen zwar Notices, aber keine Fehler.
Ich habe 2019 angeschaltet.
Ich habe alle Plugins bis auf WPSG deaktiviert und wieder eingeschaltet.

Probleme gibt es einerseits bei Yoast, das produziert den Pixel-Fehler, aber auch das Varnish Cache Plugin.

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16863
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Keine Weiterleitung auf done.phtml

Beitrag von maennchen1.de » 12.08.2019, 14:47

OK, dann haben wir doch schon mal die Ursache gefunden!
Jetzt gilt es, mit Einstellungen zu spielen. Da ich nicht weiß, was du alles aktiviert hast:
Prüfe einmal die Einstellungen hinsichtlich Eingriff in den Quellcode. Da du von einem Pixel gesprochen hast, wird YOAST irgendwie versuchen einen Zählpixel zu setzen. Allerdings so, dass es die Ausgabe vom Shop unterbricht. Eventuell kannst du das unterbinden, oder anderweitig bewerkstelligen?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
Wie poste ich eine Frage zu einem Problem?
FAQ / häufig gestellte Fragen
Anzeige-Fehler / Funktionsfehler in wpShopGermany erkennen und selbst beheben
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

stgoldmann
Beiträge: 18
Registriert: 25.06.2013, 11:42
Lizenz: wpShopGermany Pro

Re: Keine Weiterleitung auf done.phtml

Beitrag von stgoldmann » 12.08.2019, 16:57

Ich habe nun folgenden Verdacht: Sowohl Varnish Cache, als auch Yoast Seo haben Probleme mit der Done-Seite. Der Firefox allerdings sagte mir noch etwas mehr, nämlich, dass ein Bild fehlerhaft gerendert wurde. Und wenn ich die Plugins abgeschaltet habe, erscheint beim Barcode der Vorkasse ein seltsames Kauderwelsch, statt einem Bild. Ich habe dann das Modul Vorkasse abgeschaltet und siehe da, die Seite wirft keinen Fehler mehr, sondern erscheint einfach mit "Vielen Dank für Ihre Bestellung!"

Es liegt für mich also nahe, dass der Barcode bei mir aus irgendeinem Grund falsch erzeugt wird. Kann ich spezifisch den Barcode irgendwo auskommentieren im Quellcode?

In der neuen version Vermisse ich übrigens auch das normale bezahlen auf Rechnung. Gibt es das nicht mehr?

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16863
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Keine Weiterleitung auf done.phtml

Beitrag von maennchen1.de » 12.08.2019, 17:15

Zunächst: Der Cache sollte unbedingt auf den Shopseiten deaktiviert werden. Das war bisher nie anders. wpShopGermany erzeugt dynamisch Seiten. Ein Cache nutzt erzeugte Seiten um sie nicht neu generieren zu müssen und um dem Server Zeit zu sparen. Bei einem Shop müssen aber manche Seiten (z.B. Warenkorb und Checkout sowie Produktdarstellungen) immer wieder neu erzeugt werden, weil Sie die Inhalte verändern.

Dann: Verwendest du bereits die aktuelle Beta? Die ist auf jeden Fall besser als die aktuelle "stable" Version, da sie eine Menge Bugfixes mitbringt. Ich würde sie dir unbedingt ans Herz legen. Stabil ist diese bereits allemal (derzeit kommen nur im Backend unnütze Fehlermeldungen, die ignoriert werden können).
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
Wie poste ich eine Frage zu einem Problem?
FAQ / häufig gestellte Fragen
Anzeige-Fehler / Funktionsfehler in wpShopGermany erkennen und selbst beheben
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

stgoldmann
Beiträge: 18
Registriert: 25.06.2013, 11:42
Lizenz: wpShopGermany Pro

Re: Keine Weiterleitung auf done.phtml

Beitrag von stgoldmann » 12.08.2019, 18:13

Cache: Das haben wir zumindest auf der Hauptpräsenz im Griff. Dort läuft der 3er Shop ganz wunderbar.
Habe eben den 4.1.3 installiert und habe jetzt den Fehler eingetauscht gegen "Table 'xxx_beta.wp_wpsg_order_voucher' doesn't exist" (ich erlaube mir mal der ersten Teil des Datenbanknamens auszu-xen)
PS: Und ich habe die Datenbank aktualisieren lassen.

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16863
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Keine Weiterleitung auf done.phtml

Beitrag von maennchen1.de » 13.08.2019, 10:50

Hast du das Modul Gutscheine aktiv, oder hattest es einmal aktiv?
Es dürfte gerade deaktiviert sein. Aktiviere es bitte einmal und der Fehler sollte verschwinden. Danke für die Rückmeldung!
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
Wie poste ich eine Frage zu einem Problem?
FAQ / häufig gestellte Fragen
Anzeige-Fehler / Funktionsfehler in wpShopGermany erkennen und selbst beheben
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

stgoldmann
Beiträge: 18
Registriert: 25.06.2013, 11:42
Lizenz: wpShopGermany Pro

Re: Keine Weiterleitung auf done.phtml

Beitrag von stgoldmann » 13.08.2019, 12:53

Das wirft mir leider auch einen Fehler: "Die Website hat technische Schwierigkeiten. Bitte das E-Mail-Postfach des Website-Administrators prüfen, um dort weitere Anweisungen zu finden." Alles andere der Webseite funktioniert. Kann ich das irgendwie in der DB direkt beheben?

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16863
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Keine Weiterleitung auf done.phtml

Beitrag von maennchen1.de » 13.08.2019, 16:00

Wann genau erhältst du die Fehlermeldung?
Konntest du das Modul aktivieren?
Welche Build Version der Beta hast du installiert (nenne bitte einmal die vollständige Versionsnummer)?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
Wie poste ich eine Frage zu einem Problem?
FAQ / häufig gestellte Fragen
Anzeige-Fehler / Funktionsfehler in wpShopGermany erkennen und selbst beheben
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

stgoldmann
Beiträge: 18
Registriert: 25.06.2013, 11:42
Lizenz: wpShopGermany Pro

Re: Keine Weiterleitung auf done.phtml

Beitrag von stgoldmann » 13.08.2019, 17:54

Die Fehlermeldung kommt, wenn Ich versuche das Gutschein-Modul im Demomodus zu installieren - die Installation ist auch nicht erfolgreich. Ich habe Version 4.1.3.7496 - ich kann gerne alle Infos aus dem Bereich "Über diese Installation" posten, wenn das hilft.

Antworten