Probleme mit Produktartikel

Alle Fragen zu den Kauf-Modulen von wpShopGermany4.

Moderatoren: ThoGoe, maennchen1.de

Antworten
Dirk
Beiträge: 228
Registriert: 04.02.2015, 12:50
Lizenz: wpShopGermany Enterprise
Wohnort: München

Probleme mit Produktartikel

Beitrag von Dirk » 20.03.2018, 15:36

Tag zusammen.

Habe heute auf 4.0.5 upgegradet. Das klappte wohl.

Bei Produktartikeln ist in der Konfiguration der Pfad (Path Key (Produkte)) standardmässig auf "produkte" gesetzt.
Wie ist die Vorgehensweise, wenn ich das auf etwas anderes ändern möchte?
Kann ich das irgendwie auf [fester-Begriff]/[Name-der-Produktgruppe]/produktname einstellen?
Muss ich nach dem Speichern ganz unten noch neben "Zuordnung Produkt zu Artikel" auf "neu aufbauen" klicken? Das dauert bei mir sehr lange, habe viele Produkte.

Was passiert da? Ist das irgendwo dokumentiert? Das scheint mir ein wichtiger Schritt zu sein, wäre es nicht sinnvoll, das direkt oben neben/unter den Eingabefeldern für den Pfad zu positionieren?

Wenn ich den Pfad abändere von "produkte" auf irgendetwas anderes, dann werden nicht überraschend in den Produktdefinitionen die schönen URLS gelöscht und auf das übliche Format

https://www.----.com/produktdetail/?wpsg_action=showProdukt&produkt_id=50

gesetzt. Egal ob ich in den settings auf "neu aufbauen" geklickt habe oder nicht.
Wenn ich dann erneut das Produkt speichere, dann ist der Server komplett für ca 5 Minuten lahmgelegt und alles ist hinterher so wie vorher.

Das error log sagt dann
PHP Fatal error: Maximum execution time of 30 seconds exceeded in /usr/www/users/.../wp-includes/wp-db.php on line 2794

Was passiert denn genau, wenn ich den Pfad von "produkte" auf etwas anderes ändere?
Was sollte das neu aufbauen erledigen? Wie kann ich kontrollieren ob das passiert ist?
Was passiert wenn ich dann ein Produkt erneut speichere? Hier scheint offenbar der Hänger zu sein.

Danke für Eure Hilfe.
Grüsse, Dirk

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16014
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Probleme mit Produktartikel

Beitrag von maennchen1.de » 20.03.2018, 16:14

Hallo!
Der "Neu aufbauen" Link schreibt lediglich alle Informationen aus der Produktverwaltung in jeweils einen Custom Post Type. Das wird regulär automatisch beim speichern eines Produktes gemacht und kann hier manuell angestoßen werden. Da du sehr viele Produkte zu haben scheinst (Anzahl unbekannt) und dein Provider die Scriptausführungszeit auf 30 Sekunden begrenzt, kann es passieren, dass die umfangreiche Aufgabe abgebrochen wird.

Wenn du den Path Key ändern möchtest, machst du das an dieser Stelle und speicherst die Einstellungen. Mehr musst du nicht machen.

Hier können aber noch andere Plugins dazwischen stänkern, insofern solltest du deine Einstellungen mit einem rudimentären Setup (ohne weitere Plugins) zunächst prüfen.

Wenn das nicht klappt, teile uns bitte folgende Informationen mit:
- Wie lautet dein Path Key?
- Wie lautet die URL des Produktes und wo hast du diese abgelesen?
- Was hast du unter "Einstellungen > Permalinks" eingestellt?

Gern darfst du auch Screenshots posten, das geht manchmal schneller als Text.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Dirk
Beiträge: 228
Registriert: 04.02.2015, 12:50
Lizenz: wpShopGermany Enterprise
Wohnort: München

Re: Probleme mit Produktartikel

Beitrag von Dirk » 20.03.2018, 18:03

Hallo ihrs,

da mein Portal Hubschrauber-Rundflüge verkauft, soll der PathKey "hubschrauber-rundfluege" sein. (BTW: ü oder ue besser?)
Das habe ich so geändert und scheint so geschluckt. Kann es sein, dass die Zuordnungen automatisch losgelaufen sind?
produktartikelconfig.JPG
In der Produktkonfig steht die URL im Bereich "allgemein"
http://testsite.heliflieger.com/produkt ... ukt_id=268
produktkonfig.JPG
Wenn ich hier auf "Speichern" klicke, müsste doch eine neue URL aufgebaut werden? Passiert aber nicht, ist nachher immer noch leer und die URL kryptisch.

Es sind in der Testumgebung momentan alle Plugins ausser WPShop deaktiviert, die custom views aus und ein standardtheme aktiv.
Grüsse, Dirk

Dirk
Beiträge: 228
Registriert: 04.02.2015, 12:50
Lizenz: wpShopGermany Enterprise
Wohnort: München

Re: Probleme mit Produktartikel

Beitrag von Dirk » 20.03.2018, 18:04

Achja: Die Permalinks stehen auf "Beitragsname".

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 2770
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Probleme mit Produktartikel

Beitrag von ThoGoe » 21.03.2018, 09:48

Hallo!

Das Problem ist, dass du lediglich 20 Zeichen eintragen kannst (laut WordPress-Dokumentation). Mit dem Begriff "Hubschrauberrundflug" funktioniert das Ganze wieder.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

Dirk
Beiträge: 228
Registriert: 04.02.2015, 12:50
Lizenz: wpShopGermany Enterprise
Wohnort: München

Re: Probleme mit Produktartikel

Beitrag von Dirk » 21.03.2018, 16:19

Vielen Dank, das wars.
Wäre aber sinnvoll, die 20-Zeichen-Beschränkung da nochmal zu erwähnen wenigstens in der Infobox bzw noch besser gar nicht erst mehr als 20 Zeichen zuzulassen. Da kommt doch keiner drauf.

Meine nächste Frage ist nun, warum am Ende der generierten URL immer eine Zahl angehängt wird, etwa
wird als "URL path segment" generiert: "rundflug-20-min-konstanz1"
Wenn ich das im Produkt ändere wird es wieder mit der 1 angelegt.

Wenn ich den Namen des Produkts ändere und die URL lösche und wieder speichere, wird es neu ohne Zahlen angelegt.
Ich kann die Zahl auch im Wordpress-beitragseditor löschen bzw die URL dort auch ändern...
Wie ist die Logik hinter den Nummern?

Danke, Grüsse, Dirk

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16014
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Probleme mit Produktartikel

Beitrag von maennchen1.de » 21.03.2018, 16:49

Die 20 Zeichen sind quasi WordPress Allgemeinwissen. ;)
Bisher hatten wir noch keine so langen Namen.
Im nächsten Update wird das Inputfeld begrenzt, so dass nicht mehr wie 20 Zeichen eintippen kann. Allerdings wird dann wahrscheinlich die Frage kommen, wieso nur 20 Zeichen möglich sind... :)

Das mit der Zahl passiert, wenn bereits ein Beitrag vorhanden ist, der genau so heißt. Wenn du diesen nicht siehst, schau mal in den Papierkorb.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Dirk
Beiträge: 228
Registriert: 04.02.2015, 12:50
Lizenz: wpShopGermany Enterprise
Wohnort: München

Re: Probleme mit Produktartikel

Beitrag von Dirk » 21.03.2018, 17:29

Dann baue ich mal wieder etwas Allgemeinwissen auf :-)
Danke für die geduldige Hilfe.

Grüsse, Dirk

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16014
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Probleme mit Produktartikel

Beitrag von maennchen1.de » 21.03.2018, 17:34

Gern!
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Antworten