Modul Kundengruppen lässt sich nicht deaktivieren

Hier kannst du dich vorstellen und Fragen zum Plugin stellen.
Installation, Administration, etc.

Moderatoren: ThoGoe, maennchen1.de

aliossi
Beiträge: 141
Registriert: 23.05.2013, 08:48
Lizenz: wpShopGermany Pro

Modul Kundengruppen lässt sich nicht deaktivieren

Beitrag von aliossi » 11.06.2018, 14:32

Hallo,

Version: 3.12.6

Wollte gerade das Modul Kundengruppen ausprobieren (Demo), leider ohne Erfolg. Sowohl der Bereich Kundengruppen, aber auch der Bereich Kundenverwaltung zeigen nun eine weiße Seite an.
Debug ist eingeschaltet und wirft folgende Fehlermeldung aus (siehe Anhang).

Sofern ihr keine Lösung adhoc parat habt, würde ich mich freuen, wenn ihr mir sagt, wie ich das Modul Kundengruppen manuell deaktiviert bekomme, da es keine Button "Einstellung speichern" mehr gibt. Durch die Fehlfunktion ist nun nämlich auch meine Kundenverwaltung defekt. Ich habe in den anderen Beiträgen mit dem Thema "Kundengruppen" keine Lösung für die manuelle deaktivierung gefunden.
Bildschirmfoto 2018-06-11 um 14.20.56.png

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16175
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Modul Kundengruppen lässt sich nicht deaktivieren

Beitrag von maennchen1.de » 11.06.2018, 17:44

Hallo!
Könntest du bitte kurz beschreiben, wie du vorgegangen bist? Insbesondere wie du das Modul installiert hast.
Das Modul ist derzeit nicht aktiviert.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

aliossi
Beiträge: 141
Registriert: 23.05.2013, 08:48
Lizenz: wpShopGermany Pro

Re: Modul Kundengruppen lässt sich nicht deaktivieren

Beitrag von aliossi » 11.06.2018, 18:09

Hallo,

ich hab gerade mein Datenbank-Backup eingespielt, weil ich nicht wußte wie ich den Zustand wieder beseitigt bekomme. Jetzt funktioniert wieder alles. Kundengruppenmodul ist deaktiviert. Da ich nicht weiß, wie man es manuell deaktiviert, habe ich gerade Zweifel es noch einmal anzuschalten.


Ich habe das Modul über das Backend -> Konfiguration -> Module installiert, danach aktiviert und dann gab es eine weiße Seite. Ebenfalls nicht mehr aufrufbar war die Kundenverwaltung (weißer Bildschirm).

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16175
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Modul Kundengruppen lässt sich nicht deaktivieren

Beitrag von maennchen1.de » 11.06.2018, 18:25

Dann hat irgendein Datenbank-Update nicht funktioniert.
Dann musst du nach der Installation lediglich den Link anklicken: "Konfiguration > Einstellungen > Allgemein > Aktualisieren"
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

aliossi
Beiträge: 141
Registriert: 23.05.2013, 08:48
Lizenz: wpShopGermany Pro

Re: Modul Kundengruppen lässt sich nicht deaktivieren

Beitrag von aliossi » 11.06.2018, 18:33

Habs gerade noch einmal ausprobiert. Das Rabatt-Modul ausgeschaltet (verursachte bei einigen Fehler habe ich gelesen). Kundengruppenmodul aktiviert -> Kundengruppen -> weiße Seite. Datenbank aktualisiert - >immer noch weiße Seite.

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16175
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Modul Kundengruppen lässt sich nicht deaktivieren

Beitrag von maennchen1.de » 12.06.2018, 09:24

Könntest du bitte die Debug-Meldung wieder einschalten, damit wir sehen können, ob die Fehlermeldung (die ersten 5 Zeilen) die selbe ist?

Weiterhin würde ich mich freuen, wenn du mir noch sagen könntest, welche PHP Version du installiert hast.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

aliossi
Beiträge: 141
Registriert: 23.05.2013, 08:48
Lizenz: wpShopGermany Pro

Re: Modul Kundengruppen lässt sich nicht deaktivieren

Beitrag von aliossi » 12.06.2018, 16:44

kein Problem. erledigt. Soll ich das fehlerhafte Modul "Kundengruppen" auch wieder anschalten? Sicherlich, oder?

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16175
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Modul Kundengruppen lässt sich nicht deaktivieren

Beitrag von maennchen1.de » 12.06.2018, 17:19

Ja, bitte mache das so, wie zuvor von dir beschrieben. Dort wo die weiße Seite sonst auftaucht wird jetzt eine Fehlermeldung erscheinen, wenn der Debug-Modus aktiviert ist.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

aliossi
Beiträge: 141
Registriert: 23.05.2013, 08:48
Lizenz: wpShopGermany Pro

Re: Modul Kundengruppen lässt sich nicht deaktivieren

Beitrag von aliossi » 12.06.2018, 17:36

Fehler ist wieder da.
Bildschirmfoto 2018-06-12 um 17.33.49.png

aliossi
Beiträge: 141
Registriert: 23.05.2013, 08:48
Lizenz: wpShopGermany Pro

Re: Modul Kundengruppen lässt sich nicht deaktivieren

Beitrag von aliossi » 12.06.2018, 20:09

...und noch einmal die Bitte, wie man in so einem Fall, dass Modul wieder deaktivieren kann, ohne gleich ein DB-Backup einzuspielen.

Danke

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16175
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Modul Kundengruppen lässt sich nicht deaktivieren

Beitrag von maennchen1.de » 12.06.2018, 21:53

Kannst du bitte jetzt den oben angesprochenen Link zum Aktualisieren der Datenbank anklicken? Besteht danach der Fehler immer noch?
Welche PHP Version hast du installiert?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

aliossi
Beiträge: 141
Registriert: 23.05.2013, 08:48
Lizenz: wpShopGermany Pro

Re: Modul Kundengruppen lässt sich nicht deaktivieren

Beitrag von aliossi » 12.06.2018, 22:24

Ja, der Fehler besteht nach dem Aktualisieren immer noch.
Bildschirmfoto 2018-06-12 um 22.17.01.png
PHP 7.0.27

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16175
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Modul Kundengruppen lässt sich nicht deaktivieren

Beitrag von maennchen1.de » 13.06.2018, 08:22

Bitte stelle dein PHP auf Version 5.6 um und aktualisiere erneut die Datenbank. wpShopGermany 3.* ist nicht optimiert für PHP7.

Wenn das dann immer noch nicht klappt: Hast du Zugriff auf die die Datenbank per phpMyAdmin? Falls ja, würde mich mal ein Screenshot der Tabelle ("Struktur") wp_wpsg_customergroup interessieren.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

aliossi
Beiträge: 141
Registriert: 23.05.2013, 08:48
Lizenz: wpShopGermany Pro

Re: Modul Kundengruppen lässt sich nicht deaktivieren

Beitrag von aliossi » 13.06.2018, 13:44

1. PHP auf 5.6 eingestellt.
2. Datenbank aktualisiert

Fehler erscheint immer noch.

3. Screenshot DB
Bildschirmfoto 2018-06-13 um 13.40.13.png
4. Nochmals die Bitte um Erklärung wie man das Modul, deaktiviert, ohne ein DB-Backup einzuspielen.

Beste Dank
Andreas

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16175
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Modul Kundengruppen lässt sich nicht deaktivieren

Beitrag von maennchen1.de » 13.06.2018, 14:12

Klasse, die Tabelle ist da, aber es fehlt die ID. :(
Kannst du mir noch der Vollständigkeit halber sagen, welche WordPress Version du installiert hast?

Du kannst das Problem beheben, durch Ausführung dieses SQL-Dumps (einfach in der Tabelle bleiben, wo du den Screenshot gemacht hast und dort oben auf "SQL" klicken):

Code: Alles auswählen

ALTER TABLE `wp_wpsg_customergroup` ADD `id` MEDIUMINT(9) NOT NULL AUTO_INCREMENT FIRST, ADD PRIMARY KEY (`id`);
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Antworten