Produkt ID konnte nicht gebildet werden

Allgemeine Fragen zur Verwendung von wpShopGermany4 und dessen integrierten Modulen

Moderatoren: ThoGoe, maennchen1.de

Antworten
Ben Vart
Beiträge: 115
Registriert: 29.03.2018, 09:00
Lizenz: wpShopGermany Enterprise

Produkt ID konnte nicht gebildet werden

Beitrag von Ben Vart » 13.07.2018, 07:21

Ich weiß nicht, ob ich mit dem Problem hier richtig bin. Als nein, bitte verschieben.
Seite dem Update auf ShopVersion 4.0.11 werden in der Produktübersicht auf meiner Startseite nicht mehr die Produkte als Liste angezeigt, sondern nur die ähnlichen Artikel. Ich will nicht ausschließen, dass es möglicherweise auch mit WP-Version 4.97 zusammenhängt
Dafür erscheint die Meldung: "Produkt ID konnte nicht gebildet werden".
Dies geschieht sowohl bei WP-Themes von Drittanbietern wie auch dem von Euch zur Verfügung gestellten Theme. Hier allerdings nur, soweit ich gesehen habe, unter meinem Menü-Punkt "Produktübersicht".
Gibt es womöglich eine Idee, woran das liegen könnte?
Dateianhänge
Produktübersicht.jpg

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 3065
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Produkt ID konnte nicht gebildet werden

Beitrag von ThoGoe » 13.07.2018, 07:42

Hallo (soviel Zeit muss sein)!

1. Bitte poste einmal deine Einstellungen im Seitenbackend für die Produktübersicht.
2. Bitte deaktiviere einmal deine user_views und teste das Ganze noch einmal.
3. Wurde nach dem Update die Datenbank aktualisiert? Wenn nicht, führe die Aktualisierung bitte einmal durch und teste das Ganze noch einmal.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

Ben Vart
Beiträge: 115
Registriert: 29.03.2018, 09:00
Lizenz: wpShopGermany Enterprise

Re: Produkt ID konnte nicht gebildet werden

Beitrag von Ben Vart » 13.07.2018, 08:12

Hallo (und danke für die Belehrung!)
zu 3: Datenbank wurde aktualisiert.
zu 2: keine Änderung durch Deaktivierung der User_views
zu 3: wo finde ich diese Produktübersicht?

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16134
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Produkt ID konnte nicht gebildet werden

Beitrag von maennchen1.de » 16.07.2018, 11:48

Hallo!
Hattest du schon einen Blick in die Dokumentation geworfen?
https://doc.maennchen1.de/docs/wpshopge ... ersichten/
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Ben Vart
Beiträge: 115
Registriert: 29.03.2018, 09:00
Lizenz: wpShopGermany Enterprise

Re: Produkt ID konnte nicht gebildet werden

Beitrag von Ben Vart » 23.07.2018, 12:48

Hallo,

hat etwas gedauert, da ich unterwegs war.

Meinst du diese Einstellungen?
Dateianhänge
Produktuebersicht.jpg
ProdUesicht.jpg

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16134
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Produkt ID konnte nicht gebildet werden

Beitrag von maennchen1.de » 23.07.2018, 14:08

Hast du Varianten bei den Produkten angelegt, die hier angezeigt werden sollen?
Oder hast du Produktgruppen ausgewählt, die leer sind?

Das o.g. Update, hast du wie genau durchgeführt (von welcher Version, per FTP oder Plugin-Manager)?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
FAQ / häufig gestellte Fragen
wpShopGermany Fehler? Hilfeanleitung!
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

Ben Vart
Beiträge: 115
Registriert: 29.03.2018, 09:00
Lizenz: wpShopGermany Enterprise

Re: Produkt ID konnte nicht gebildet werden

Beitrag von Ben Vart » 23.07.2018, 15:07

Ich habe keine Varianten angelegt und das Update wie alle vorherigen auch mit dem Plugin-Manager.

Sonnige Grüße

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 3065
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Produkt ID konnte nicht gebildet werden

Beitrag von ThoGoe » 26.07.2018, 08:00

Hallo!
maennchen1.de hat geschrieben:
23.07.2018, 14:08
Oder hast du Produktgruppen ausgewählt, die leer sind?
Poste bitte einmal die Zuweisung der Produktgruppe im Produkt (unter Produktverwaltung > [ein Produkt auswählen] > Produktgruppen).

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

Ben Vart
Beiträge: 115
Registriert: 29.03.2018, 09:00
Lizenz: wpShopGermany Enterprise

Re: Produkt ID konnte nicht gebildet werden

Beitrag von Ben Vart » 30.07.2018, 22:10

Hallo,

ich hoffe, der Screenshot hilft weiter.
Dateianhänge
ProdVerwaltung.jpg
ProdGrup.jpg

Ben Vart
Beiträge: 115
Registriert: 29.03.2018, 09:00
Lizenz: wpShopGermany Enterprise

Re: Produkt ID konnte nicht gebildet werden

Beitrag von Ben Vart » 07.08.2018, 08:36

Guten Morgen,

ich vermute jetzt Mal, Ihr wisst auch nicht, woran es liegen könnte?

Vielleicht liegt es daran, dass ich kürzlich ein Produkt gelöscht habe und noch irgendwo Reste davon herumgeistern?

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 3065
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Produkt ID konnte nicht gebildet werden

Beitrag von ThoGoe » 07.08.2018, 15:48

Hallo!

Bitte poste einmal einen Link zu dem entsprechenden Shop. Wir sind dabei, das Problem zu reproduzieren. Die Darstellung war, bevor du das Produkt gelöscht hast, hervorragend?

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

Ben Vart
Beiträge: 115
Registriert: 29.03.2018, 09:00
Lizenz: wpShopGermany Enterprise

Re: Produkt ID konnte nicht gebildet werden

Beitrag von Ben Vart » 07.08.2018, 16:18

ThoGoe hat geschrieben:
07.08.2018, 15:48
Hallo!

Die Darstellung war, bevor du das Produkt gelöscht hast, hervorragend?

Liebe Grüße
Hallo,

das weiß ich jetzt ehrlich gesagt nicht mehr. Mir ist lediglich aufgefallen, dass beim klick auf "nächsten Artikel" die Meldung kommt "Produkt-ID konnte nicht gebildet werden" erscheint, der danach folgende Artikel wieder korrekt angezeigt wird.

Schaut mal hier:
http://orzi.eu/2018/05/14/wie-schmeckt-der-himmel/

dann klickt nächster Artikel.

Gruß

Benutzeravatar
ThoGoe
m1.Mitarbeiter
Beiträge: 3065
Registriert: 21.07.2014, 08:25
Lizenz: wpShopGermany Enterprise

Re: Produkt ID konnte nicht gebildet werden

Beitrag von ThoGoe » 07.08.2018, 16:35

Hallo!

Aktiviere bitte einmal ein Standardtheme und teste das Ganze noch einmal. Unter Umständen kommt das Theme mh_elegance mit dem wpShopGermany nicht klar.
Auffallend ist die "lange" Ladezeit deines Produktfrontend von der Produktübersicht zur Produktdetailseite.

Liebe Grüße
Wenn du glaubst, es geht nicht mehr, kommt von uns die Hilfe (http://shop.maennchen1.de/kontaktformular/) her.
Hast du wenig Geld, doch dafür Zeit, stell es der Wunschliste (https://wpshopgermany.uservoice.com/for ... 61-general) bereit!

Ben Vart
Beiträge: 115
Registriert: 29.03.2018, 09:00
Lizenz: wpShopGermany Enterprise

Re: Produkt ID konnte nicht gebildet werden

Beitrag von Ben Vart » 07.08.2018, 17:33

Hallo,

hab's auf euer Theme umgestellt. Die Ladezeit ist nach wie vor lang, und wenn ihr auf diesen Link geht:
http://orzi.eu/2018/05/14/produktuebersicht/

werdet Ihr ebenfalls die Fehlermeldung "Keine Produkt ID" erhalten.

Gruß

Antworten