Link abgelaufen im backend?

Allgemeine Fragen zur Verwendung von wpShopGermany4 und dessen integrierten Modulen

Moderatoren: ThoGoe, maennchen1.de

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16850
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Link abgelaufen im backend?

Beitrag von maennchen1.de » 01.10.2019, 22:24

Bitte antworte eindeutiger. Franziska schrieb vom Link "Ansehen". Du hast das Problem aber an einer anderen Stelle. Das sind zwar zwei gleiche Ursachen, aber an zwei unterschiedlichen Stellen. Das ist essenziell zu wissen!

Unten stehender Link zeigt, dass ihr eine veraltete PHTML Datei verwendet. Bitte prüfe, ob tatsächlich die user_views ausgeschaltet sind, die aktuellste Version installiert ist und keine PHTML-Dateien weiter angepasst wurden.
onic hat geschrieben:
01.10.2019, 21:04
Bei Franziska: /wp-admin/admin.php?page=wpsg-Order&action=view&edit_id=385
Deinen Link musst du bitte noch beschreiben, welcher das ist, bzw. generell wo dein Fehler auftaucht.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
Wie poste ich eine Frage zu einem Problem?
FAQ / häufig gestellte Fragen
Anzeige-Fehler / Funktionsfehler in wpShopGermany erkennen und selbst beheben
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

onic
Beiträge: 170
Registriert: 20.10.2017, 20:17
Lizenz: wpShopGermany Enterprise

Re: Link abgelaufen im backend?

Beitrag von onic » 02.10.2019, 13:21

Hallo,

okay, die user_views haben wir natürlich wieder angeschaltet, da das Problem dadurch nicht verändert wurde.

Hier einmal ein Screenshot von der Stelle, wo es bei mir auftritt:
shop-ansehen.png
Klicke ich auf Ansehen, erhalte ich die folgende Nachricht: Der Link, dem du gefolgt bist, ist abgelaufen. Bitte versuche es nochmal.

Mit user_views: wp-admin/admin.php?page=wpsg-Order&action=ajax&noheader=1&mod=wpsg_mod_rechnungen&do=getRechnung&edit_id=44&r_id=41&_wpnonce=dda8a012f9

Ohne user_views (ignoriert): /wp-admin/admin.php?page=wpsg-Order&action=ajax&noheader=1&mod=wpsg_mod_rechnungen&do=getRechnung&edit_id=44&r_id=41&_wpnonce=dda8a012f9

Hilft das weiter?

Herzliche Grüße sendet

Christian

Dirk
Beiträge: 312
Registriert: 04.02.2015, 12:50
Lizenz: wpShopGermany Enterprise
Wohnort: München

Re: Link abgelaufen im backend?

Beitrag von Dirk » 02.10.2019, 13:23

Hi,
wenn ich eine bereits erstellte Rechnung ansehen möchte, kommt ebenfalls der Fehler. Dieser link sollte eigentlich die Rechnung anzeigen:

/wp-admin/admin.php?page=wpsg-Order&action=ajax&noheader=1&mod=wpsg_mod_rechnungen&do=getRechnung&edit_id=7816&r_id=2675&_wpnonce=48ddc0aa42

Beim Lieferschein tritt das auch auf - der link zur gleichen Buchung:

/wp-admin/admin.php?page=wpsg-Order&action=ajax&noheader=1&mod=wpsg_mod_deliverynote&do=get&edit_id=7816&dn_id=1166

Grüsse, Dirk

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16850
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Link abgelaufen im backend?

Beitrag von maennchen1.de » 02.10.2019, 13:49

onic hat geschrieben:
02.10.2019, 13:21
Hilft das weiter?
Ja, mit Screenshot perfekt. Im Grunde das gleiche Problem, was Dirk (der Threadersteller) hat. Das können wir reproduzieren und mit dem nächsten update beheben.

Das zweite Problem: "Bestellung ansehen" von Franziska ist aber noch in der Schwebe:
Hast du dort den Link "Bestellung ansehen" getestet, so wie es in Ihrem Screenshot gezeigt wird, mit ausgeschalteten user_views, ohne angepasste PHTML-Datei?
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
Wie poste ich eine Frage zu einem Problem?
FAQ / häufig gestellte Fragen
Anzeige-Fehler / Funktionsfehler in wpShopGermany erkennen und selbst beheben
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

onic
Beiträge: 170
Registriert: 20.10.2017, 20:17
Lizenz: wpShopGermany Enterprise

Re: Link abgelaufen im backend?

Beitrag von onic » 02.10.2019, 14:31

Hallo,

ich habe das jetzt bei Franziska nochmal mit ignorierten user_views kontrolliert. Sie kommt in diesem Fall genau so weit wie ich.

Dann müssten wir doch jetzt beide Fehlerquellen ausfindig gemacht haben, oder?

Ich schaue mir mit Franziska heute Abend die user_views an und wir gleichen das mal mit den aktuellen Dateien ab. Wann macht ihr denn das nächste Update?

vielen Dank und herzliche Grüße sendet

Christian

Benutzeravatar
maennchen1.de
Administrator
Beiträge: 16850
Registriert: 14.08.2003, 16:55
Lizenz: wpShopGermany Enterprise
Wohnort: Thüringen, Ellersleben
Kontaktdaten:

Re: Link abgelaufen im backend?

Beitrag von maennchen1.de » 02.10.2019, 22:00

Wenn ich dich richtig verstehe, hat sich dieses Problem mit der Deaktivierung der user_views erledigt?
Ein Update wird es wahrscheinlich nächste Woche geben.
Kein Support per PN! Alle Fragen beantworten wir hier im Forum. Per PN bitte nur Passwörter, Namen und URLs - sofern notwendig.
Bitte vor dem posten lesen:
Wie poste ich eine Frage zu einem Problem?
FAQ / häufig gestellte Fragen
Anzeige-Fehler / Funktionsfehler in wpShopGermany erkennen und selbst beheben
PHTML-Dateien richtig verwenden (für eigene Anpassungen)

onic
Beiträge: 170
Registriert: 20.10.2017, 20:17
Lizenz: wpShopGermany Enterprise

Re: Link abgelaufen im backend?

Beitrag von onic » 02.10.2019, 22:51

Ja, wir müssen uns die user_viiews vornehmen.

Wir melden uns, wenn wir Ergebnisse haben. ;-)

onic
Beiträge: 170
Registriert: 20.10.2017, 20:17
Lizenz: wpShopGermany Enterprise

Re: Link abgelaufen im backend?

Beitrag von onic » 14.10.2019, 20:22

Hallo,

soweit ich das jetzt beurteilen kann, ist das Problem jetztbehoben.

Vielen Dank und beste Grüße

Christian

Antworten